Windows 7 media shares


#1

I just spent about 6 hours trying to get my WD TV Live to play my network shares. nothing that I tried worked.

When the device is on, I can see it on my W7 machine as a media device, but when I go to Video > network shares from the device it can’t see my computer. I can get on youtube and watch videos just fine.

Is there a proper working tutorial/fix out there for Windows 7? A lot of people seem to be having this same issue…


#2

Hi,

I’m also having trouble getting network shares working under Win 7 [WD TV Live sees the shares then says username / password is wrong].  Win XP shares work.

If you’re keen run Wireshark on the Win 7 PC and monitor the traffic between the WD TV Live and the PC. Any errors will show there.

Have followed the instructions given on WD website, no go. Have contacted WD Support, still waiting. I can also access the Win7 shares from a WinXP PC without supplying a username / password so the Win7 side appears to be setup correctly. I asked WD for help about 3 months ago. The responses were not helpful ( make sure the WD TV Live and the Win 7 PC are connected via Ethernet. How else would I connect them? String! ). I did explain that the WD TV Live listed the shares; this would indicate the 2 systems were connected… and streaming works, another indicator.

There is a tutorial for Win 7 streaming at the WD Community website. I don’t have the specific details but essentially it tells you how to allow streaming to a device under Win 7.  Fortunately streaming works; Unfortunately Win 7s Streaming is broken, or more accurately the library updater is flawed. Otherwise appears to be a good product.

2 tips: Win 7’s Media Center is flawed. It can take up to 24 hours to update the library after new files have been added. There is no “update” button or selection you can make to force a re-read of the libraries.  Workaround is to remove and then re-add the folders to the library.

Will start a new thread but you may be able to check something for me. Audio at 44.1KHz won’t play through HDMI or Digital Audio out.  If I remux the audio at 48KHz it plays fine.  I have asked WD but no answer yet. I’m not sure if it’s an issues with the WD TV Live or Win 7.  Workaround is a pain (remux all videos with a 44.1KHz audio stream to replace the stream with 48KHz audio).

Cheers from Oztralia :wink:


#3

Make sure PASSWORD PROTECTED SHARING is disabled; and regular file sharing is ENABLED.

Go to the folder you want to share.

Right Click.

Select Share with…(specific people.)

In that window, select EVERYONE, and set permissions to READ.

Click OK until you’re out.

Done.  Problem solved.

Now, if you really need password protection, it will work, but you have to limit the passwords to non-complex passwords apparently.  (I don’t do this, but another forum post fleshed that out…)


#4

I’ve done the correct permissions and share settings. THe problem that I have now is that the WD TV Live cant even see my computer. I know everything is setup correctly on my W7 box because it was able to play content for about an hour. then out of nowhere it just stopped and was unable to see the machine anymore. If I shutdown my computer and leave it off for about 10 seconds, then boot it back up, maybe 30% of the time the WD TV live will see the machine and be able to play stuff. But it just cant even see my computer when I do the network shares.

This is a very buggy device and they need to fix the network shares !!!


#5

okay I just spent literally 8 hours playing with this thing. I can finally get it to see my computer and it will start to play a video for about 15 seconds then the screen goes blank and it goes back to the browse view, and then the screen will say:

There was a problem connecting to the network.

The Device could not connect to the network.

I AM SO **bleep**ING PISSED RIGHT NOW


#6

Yup, i’ve just been through the same process.

Network share is working great, if I run it through Linux.  

Just tested on Ubuntu 9.10 and I had no problems with transferring a 3GB file (solid 3.2MB/s transfer rate) from my PC to the WD Live (16GB Sandisk USB flash drive), but on Windows 7, on the same hardware and network connection, the largest file I can get across is < 256MB, and even then it’s flakey and the speed is only ~1MB/s (for the short time it lasts).

On Windows 7 I have tried static IP and DHCP, tried both USB ports on the WD Live and different flash drives. Verified USB drives were FAT32 and file system permissions for media on PC were accessible for everyone.

So basically I think I’ve ruled out the media, the hardware and the network.

After that I fired up win32 wireshark and could see various errors when transferring:

349 22.874463 192.168.1.3 192.168.1.2 SMB Trans2 Response, QUERY_PATH_INFO, Error: STATUS_OBJECT_PATH_NOT_FOUND

991 173.433240 192.168.1.3 192.168.1.2 SMB NT Create AndX Response, FID: 0x0000, Error: STATUS_SHARING_VIOLATION

1155 203.350126 192.168.1.3 192.168.1.2 SMB NT Create AndX Response, FID: 0x0000, Error: STATUS_OBJECT_NAME_NOT_FOUND

1228 203.454738 192.168.1.3 192.168.1.2 SMB Trans2 Response, QUERY_FILE_INFO, Error: STATUS_NETWORK_ACCESS_DENIED

Now I’m not a network engineer by trade, but I am a software developer, and it’s apparent there is a problem with the way WD Live is talking to Windows, that is not evident when talking to other Linux based devices.

I hope this can be looked at and fixed by WD.


#7

I installed TVersity and everything is working now. kinda blows you need to use a 3rd party app to stream media to the box. but oh well.


#8

I had problems with Win7 then I saw this video that gave me a clue to how to fix it - no problems since.

Basically everyone needs permissions on the files - this way anonymous users can connect. I have not tried to use a password protected share.

Check out this link:

http://www.youtube.com/watch?v=EQstgQ4eJCM&feature=player_embedded#


#9

that did not work for me.


#10

Nothing is broken on the WDTV with respect to Windows 7, aside from the simple vs complex password issue; Windows allows passwords that you can’t use on the WDTV.

If you:

   1-  Enable Simple File Sharing

   2-  Disable Password Protected File Sharing

   3-  Share your media folder

   4-  Grant Access to EVERYONE

   5-  Then use the WDTV to login as Anonymous…

— it will work.

My primary media PC is Windows 7 x64 and is working fine with 2 WDTV Live HDs.  Not a problem one.

Your Wireshark trace proves you don’t have sharing set up the way you need to.