Cant see Network Shares but can see Media Servers......?


#1

Hi

I have 3 Windows 7 PC’s networked  along with the WD TV Live + Also a NAS all that work as seen as Media Servers, but for some reason my WD box has stopped seeing my Windows 7 PC’s as Network shares. It used to see them just fine and i could go to the shared folders as setup and watch content. Now as Media Servers the Media content is all over the place.

Any help please?

Thanks

~Brian


#2

You can verify the settings on the folders you are sharing on windows 7

Check this article 


#3

I did it . Still can’t see my Laptop (win7) under Network share , while it’s visible under Media Server . Using WDTV Gen3…Pl Advice. 


#4

If this isn’t resolved yet, let us know, and I’ll take a shot at resolving it.


#5

Hi, 

I tried my best. I can see my win7 laptop in Media Server menu while not in Network share … PL Help… 

Regards


#6

OK, I am back to try and help solve this problem.  I have similar issues with Shares appearing and disappearing on the WD media player.  I don’t know what exactly causes it (although I suspect Win 7 sharing), so here is my situation – see what you can use here to help solve your problem.

I have 3 PCs networked to share among themsleves and the WDTV.  One is a Win 7, and the other two are XP machines.  We also have 2 wireless printers w/SD cards that appear as shares.  When work computers are on, they also show as shares but they are not set up to share with the other components.  So, when everything is working right, all this stuff shows as shares on the WDTV. 

The problem of disappearing/non-showing shares seems to center around components being turned off, on, rebooted, etc. and most frequently it seems caused in some way by the Win 7 PC.  If it is turned off, rebooted, back-on ,it somehow blocks all the other items from showing on the network.   This is what I do to get things right again.  Once the Win 7 laptop is fully booted, I unplug the ethernet cable from it (effectively removing it from the network – all PCs and WD are wired in; not wireless).  I then restart the WDTV, and in most cases all the other shared items that are on the network at the time reappear as shares.  If they don’t, I go into the WDTV Settings and re-connect it to the network using the automatic connect button.  Once all but the Win7 are showing up again, I plug in the ethernet cable back to it, and most usually the Win 7 shows back up on the WD shares again.  If not, I may have to go through some of these steps again.  I eventually get ot all working right again using these steps.

Hope this helps.

 added later . . .

If after all the above you do not see your shares on the WD, back out of the Network Shares menu to the top, and go back into the shares again.  If it all worked well, you will then see the shares. Can’t explain why this is so.


#7

“Can’t explain why this is so.”

I can. It is so because this model is buggy. It would be great if WD would solve the networking issues of this model.


#8

“I can. It is so because this model is buggy. It would be great if WD would solve the networking issues of this model.”

Boy, you’re not kidding; I’m surprised WD hasn’t been sued over this disaster.  I own 2 WDTVLives, used one for over a year with firmware 5xx and it seemed pretty reliable, at least I could access the network computers to play files.

After the first issues started showing up with Windows Live login assistant, it’s been all downhill.  First they say you’ve got to uninstall Windows Live, yet all the computers and my Patriot Box office and a Samsung BD player can access each other just fine, playing files etc.  I finally quit using my 2 WD boxes because I never knew how much time I was going to have to waste trying to connect just to play a file.

Kindly explain why I have to tweak browser master settings, plug in and unplug units, and jump through a dozen hoops so the WD can access a file that every other machine accesses without a hitch.  One day it connects and I play a movie from a network share, later that day it tells me it’s not accessible, or else there is no media in the folder (what folder, there are a dozen shared folders full of media).

Kindly explain why I can right-click a file in Win7 and play it to the WDTV without a hitch, yet over that very same network it tells me the network share cannot be accessed, or there’s no media.  On second thought, never mind.  I have two Win7 media server boxes now set up, and the faithful and reliable Patriot Box office if I ever need it, so I’ll stick these in a drawer and wait until I need a simple player to play something from a USB drive.  For anything else, they’re worthless.

They need to epoxy over the network plug and advertise these things as media players for USB-connected drives, because these things are the most frustrating devices to connect and share on a network; they make the old days of setting up a network in Windows 3 or DOS look like a picnic.

Look at this forum…multiple and repetitive posts for the same problems with networking, and if someone does get theirs fixed, a month later it’s not working again.  I don’t want to tinker with this blasted thing every time I want to watch something, why would anyone want something like that?  WD, you should be ashamed of yourselves, not being able to make something so simple as a networkable device that stays networkable without a full-time IT person babysitting it.

Those of you struggling with this, do yourselves a favor; set up a Windows Media center machine to your TV; you’ll be able to access ALL network machines, watch and record live tv, play every format of movie, photo, music, then add XBMC to it for a beautiful interface to access and organize your files, smash your WDTVLive, and mail it back to WD…it will work almost as good as it ever did, and be much less frustrating.


#9

I feel the pain expressed on dissappearing network shares and been at that point of frustration many times and I totally agree it shouldn’t be this difficult.

For my setup and final solution to unavailablility of network shares, I’ve gone to highly reliable media servers - free versions of. In particular Asset for music - rock solid and highly reviewed - and Playon media server from mediamall for video. Both media servers can be purchased but the totally free versions work good enough. Asset will serve up flac music files and flawlessly be available ALL the time. Asset also works with mp3 files. The setup for Playon is using “My Media” with configuration for pass trhough on standard movie file types - .avi, .mp4 etc. Playon will also be availabe ALL the time - just add your PC folders to Playon configuration and do regular syncing on new files (should do it automatically in background anyway). Playonworks with pictures too.

For anyone invested in a WMA lossless collection of music this would be fully dependant on being able to access WMP as a media server and in my experience is not at 100% available but is steady enough. Personally I go with flac for lossless format.

For ripping DvD’s to a folder for WD TV to access and play with menuing this falls down (as far as I know) without network share availabiltiy, but if a NAS is on the network, ripping straight to a NAS unit folder should work since the NAS folders should show up in network share browsing.

I have a Linksys NAS200 which will knock out network share browsing as soon as I turn it on and it is connected to the network. The protocols of the NAS somehow override the WD TV network share protocols. Turning off the NAS, and all other PC’s on the network with further first turning on the WD TV then restarting PC’s with the NAS off will have network shares available again.

With the WD TV total experience, Windows 7 WMP12 Play To has to be part of good entertainment - of which I have 3 Windows 7 PC’s and the 2 most recent installs without Windows Live and with only using Windows MSE antivirus the Play On works flawlessly. The other Windows 7 install never has worked but I had installed much on it and loaded it with applications before trying the Play To function.

I also find that the Windows regular updates will cause issues for extablished network connections of various kinds which leads me to think that WD isn’t necessarily the only culprit in this situation of on and off network problems. I’ve tried using Samsung DLNA based applications, AllShare which is reviewed as the best implementaiton of DLNA but hit insurmountable issues as well with attempts at media serving. Overall it’s a complicated set of protocols from various manufacturers all layered on top of each other that  breaks down smooth consistant media playback.

I’m hoping to help resolve some of the frustration with getting good entertainment vs numbing technical issues. Best I can offer is trying known good  software media servers - again Asset and Playon (or whatever other PC installable meida server that is stable) - and migrate away from use of network shares. Since we all do have WD TV units and have spent the money then find good, non-techinical, easy enough ways to use them for entertainment value.


#10

This problem seems to be all over the forums. 

I’m at my wits end with these devices. 

I have 4! wdtv live (gen 1) and up until recently people thought I worked for WD as I would always tell people how great these little boxes are. 

But ever since the eternal loop of “there is no media…” and/or “Invalid username…” error messages, 

Having to reboot, clear log in info, change auto log in, sacrifice a chicken, say 10 Hail Marys etc…

Just praying the the problem will fix itself, and then at best, if it does, you get a couple of days use, before the same problem hits again. 

Honestly, what the **bleep** is going on? This is clearly a problem that is effecting many many people, have WD even acknowledged that a problem exists?

I see that they removed the latest firmware, but they did not list the above as one of the reasons. 

The amount of time I have spent on ALL 4 OF MY WDTV live boxes just trying to stream something from my network is insane

I’ve posted on various threads over the past few weeks, but WD have yet to respond

James


#11

Hello, I had similar problems on my Seagate FreeAgent.  Seems like this problem is affecting all of the media servers out there and the problem seems to lie in a set of Windows 7 registry settings.  I think recent Windows updates have modified some registry settings. I found the solution from another member on the Seagate forum and it solved my problem.  Use this tool RegistryEditTool, run it and set the settings to match what’s shown below.  Then simply close the tool (“x” at the upper right).  Hope this works for you. WindowsNetworkTool.png


#12

Has anyone else tried this and had success? I’m a bit dubious about changing things in windows I don’t understand.


#13

Personally I would be more dubious about downloading software via a link which has been added by a person who has only posted once.


#14

Same old story… been searching all over the internet for an answer… about to give up and beg for help here.

I had an old Gen1 and a Hub and everything worked fine.

I tried to upgrade with a Gen 3 but for some reason it cant see the hub in Network Shares

…and that means I can’t import the Metadata. Does anyone think this is a router problem or a Gen 3 problem?

Obviously, my Win8 network is set up correctly for at least one of them.


#15

I had what sounds like the exact same issue.  Here is how I solved it easy.

To fix not being able to see network shares, do the following:

  1. Go to Settings, Network Settings
  2. Turn Auto login to network shares to Off
  3. Click the Clear login info for network share
  4. Now go to Video, Network Shares
  5. Select the machine that you want to log into and enter the credentials
  6. Do this for each machine you want to log into.
  7. Now go back to Settings, Network Settings and Turn Auto login to network shares to On.

I used Guest and a blank password for the credentials.

Now I can see all of my machines under Network Shares.

Bruce