WDTV Live doesn't see shared drives

My WDTV is connected wirelessly to my Cisco/Linksys Router. I am running a home domain with Windows 2008 R2 Server and multiple desktop/laptop clients.

The litle orange arrow just spins and spins but it never finds any shared drives. I give the everyone group full control and have tried sharing the clients as well. I have changed the workgroup name to the domain name and also left it at workgroup.

Any idea what might be going on? I have configured the WDTV Live with a static ip like all of my other network nodes. I have tried pointing the DNS at both the server and internet. All of the apps work fine, I just can’t see any network shares.

Firmware is the latest.



from any of the computers, are you able to see the media player? or the share folder that you have?

1 Like

I can see the media player from a workstation. I can also see my network share from any workstation.


I checked a few more pc(s).

I can see the media player all of my pc(s) whether client or server, wired or wireless…

Now noticing that the media player is seeing my router and printer but not the shared drive yet.

What is wrong with you? Why are you hijacking my thread?

Moved one of my boxes into a workgroup…worked fine. Not willing to turn my domain into a workgroup for this to happen.

Might just create a vm in a workgroup on my domain controller. That way I don’t have to destroy my domain.

Used Hyper-V VM in it’s own workgroup for media center shared drive. This worked very well. Wasn’t willing to tear down a domain for this.