WD TV Live doesn't find shared folders in home network

I just bought a new WD TV Live and it works just fine with YouTube and my external HDDs, but it cannot find the shared folders on my PC (WinXP). I have my WDTV connected via wifi to my router (Buffalo AirStation) and computer connected to the same router via an ethernet cable. The workgroups on both devices are exactly the same, the folders are shared correctly on my PC. I have my firewall settings correct (F-Secure 2011), but I had the FW off for a test and it still didn’t work. I have all my media shared in the Windows Media Player settings and it recognizes my WDTV in the network, however, for some reason I can’t “ping” the WDTV correctly on my command prompt. (This is the part where I am not exactly sure if I’m using the right terms so bare with me. :slight_smile: ) I was told to go Start>Run> type cmd>type net view, to see the devices that I can currently connect to ( I guess). For some weird reason it sometimes ONLY finds my WDTV, sometimes ONLY my PC, but only once has it seen both devices. And as I typed in net view 5 seconds later in only saw my PC again. Could this have something to do with the problem. Is the network connection too weak? ( I can play HD quality videos on my WDTV YouTube with no problems whatsoever). So this here is what I see from my PC. I don’t have another PC to check if I can access the shared folders from it, but I expect that I have shared them correctly as I have read about a hundred ‘how to share folders’-tutorials today.

What I see on my WDTV: when I go to Videos>Network Shares I only see Windows Shares. I select that and it will animate that ‘thinking’ icon there for about 7-10 minutes and the screen will go black and I have to hard reboot the unit. My files are on a hard drive connected via USB to my PC but that shouldn’t be a problem? I have about 800 GBs of media on that HDD, could the large amount of data cause a problem? ( I also tried a 1GB shared folder on my desktop, but the WDTV still couldn’t find anything.) Any advice would be helpful, has someone had similar problems? Should I have something like SMB/CIFS onmy WDTV screen instead of Windows Shares?

The basic problem is that like the rest of us WD customers, you bought their product without reading any reviews. It is without doubt the most frustrating and time consuming temperamental electronic product ever invented.

Do not be fooled into thinking that it will ever work on a consistent basis; it will not. 

Obtain a full refund if you can and get on with your life.

Happy new year!

Hmm, judging from your honorable number of posts I believe I can safely assume that you are here to troll. Anyways, I’d really like to get a *helpful* answer for my problem. And jimmyboot, I did read a ton of reviews and I’ve used my gf’s dad’s Gen 1 model for almost two years now so I have some experience to reflect on. However that unit is hooked up to a Mac so he can’t really help me with my WinXP problem. I don’t believe it’s the unit being damaged, its just something with my network settings. Any help would be GREATLY appreciated! Thanks ahead of time!

Odezodez, yeah, a marginal network could DEFINITELY account for the results you’re seeing.

see if yu can borrow a long cable and try wired, see if it improves.  Then you’ll know what you’re dealing with.

I never got my hands on a longer network cable and because the network connection worked really well I figured the problem must be in my network settings on my PC. I downloaded a software called Serviio, a media server sw and it just started to work, for a reason I still don’t understand. But I guess it’s better than nothing, eh? With Serviio I can make my PC a media server and drag all the objects (folders) I want to share to the application, it processes them really quickly and I can instantly play them on my WDTV. It even searches for new updates in the folders automatically. Serviio is free however there is a paid version out there but I don’t really know anything about it cause the free version offers essentially everything I need.[I’m writing this for the noobies out there so old-school programmers don’t hate. :)] I still don’t know why I can’t see my shared folders in Network Shares but I’m using Media servers>Serviio and it’s working like a dream. And I still can’t ping my WDTV correctly in the command prompt. :laughing:

So I guess I solved my problem? :smiley:

I got mine about the same time, Christmas 2012.

It was a refurb ($66) but still had it’s plastic sealed remote and adapter. The Unit still had the manufacturers plastic on top. It was shipped from WD on 12/19/2012, WD’s own label on Box although shipped from somebody else?

Anyway to cut a long story short. On plugging it in it still had somebody’s previous attempts at setup. Verizon Wireless Network which I don’t have. That threw me a curve but as it found the Network it went into a Firmware upgrade and then I reset to defaults. Iodated it has the latest firmware.

I have never yet iodated been able to do Windows Shares.  The PC running Win7 64 Ultimate see’s the TVLive, all the settings are as specified by WD. Work Network, Workgroup (NW2) names the same, Shared Folders, permissions all set but still nothing. It will attempt, then lock down aftter about 20 minutes and at the same time take out the WD Powerline Adfapter it’s connected to and anything else that maybe connected to it.

After spending probably 20 hours over the last month going back and forth down the hall from computer to TVLive I have had it. Todate it has never been used to watch a stored movie.

I connected a Patriot Box Office in place of the WDTV Live and without doing anything it immediately found the shares in Net.  I then picked up an Android Box which also found the shares immediately, I mean at powerup with no user input.

I then used a new hard disk, did a virgin install of Win7. 32-bit home, nothing on it but a new folder into which I put a couple of movies to try. Added a brand new out the box Router DL-657, reconnected the WD Powerline Adapters, set up a work network from scratch as it were, reconnected the TVLive, switched on and still nothing. Again it hangs.

Downloaded MyNetViewfull from WD, it’s found the WDTV Live but still nothing. No Shares.

There is a rabbit amiss somewhere, I can’t believe for one minute WD would put out a piece of hardware that was so particular in its share setup when I can go get any number of media players which you set set your shares on the PC and plugin without have to make any changes to the player. It’s antiquated to say the least.

I wish Patriot were still making the legacy Box Office because at present it’s got the WDTV Live beat and that upsets me becuase unfortunately the Patriot doesn’t provide thumbnails for cover art, just file names and when that gets over a couple hundred then one has to have a good memory. It also doesn’t have Netflix and anyway, I like WD, have so many WD products already,

Somebody please confirm settings or this becomes a doorstop as just another good idea that wasn’t.


If you use windows media player and share your media to the network then all your media (audio, photo and video) will be available from your windows OS >Vista PC and this will include USB drives connected to that PC.

I’m using FW: 1.06.41V beta.

Also available your media player folders - playlists, ratings etc.

Accessible from Media Server:smiley:.


Not sure if this will help you;  I set up sharing on my local network by establishing a user and password for the WDTV Live to login to.  This normally works very well and is stable, but I discovered something interesting.  Whenever I try an update on my WDTV Live (and invariably end up having to revert back to 1.05.04V), I have to refresh the WDTVLive user password on the PC server that has the shared folder.  This is after re-entering the usual user and password in the Live, which gets cleared out whenever the firmware is changed (along with the Utube search cache, grrr, grrr…).  Logging into the share yields the message “no media found in this folder”.  I then go to the share server (an old Win2K machine), open up the WDTV Live user account in the Users Manager, and simply re-enter the same password.  Going back to the WDTV Live, logging into the user now finds the shared media files, and remains working as long as I don’t try to update the Live firmware again.

RPH_16by9 hi,

As I did not understand this part of your post:

"…I have to refresh the WDTVLive user password on the PC server that has the shared folder.  This is after re- …

and how do you do that anyway?

… I went off to my PC to change the workgroup as suggested by another member, then remembered something about setup files for the WD and thought they were on my laptop (that was your post), I opened it up, but could not find the relevant files (thats because I did not understand your post).  So, being a little confused as usual, I went to the WD box and looked at my Network Settings again.  I thought to myself, even though my WD box never changes its IP, since its always been on automatic, what would happen if I changed it to manual?

Well, the first thing was that the radio stopped playing and I thought what the **** now, not another WD special (as one has to now adaze) so off I went to the radio and amazingly got it going, then thought where was I, I know trying to get to my Network shares.  So, I went to the Network Shares and all my shares came up including some I did not realize I had shared.  Tried some audio, photo and not video yet but what I did try worked.

I am totally gob smacked, where did that come from just changing from Automatic to Manual, no changes in the values offered, a simple change Automatic to Manual and press OK.

YES Network Shares works again:smiley::heart::smiley:  but for how long?

Anybody dare to explain?


Firmware version 1.06.41_V on a WDBAAP0000NBK box.

What I meant in my post is that I went into the server’s User Accounts manager in the Control Panel (this is an old Win2000 machine ),  opened up the user for the WDTV Live and performed a “Change Password”, entering the same password I’ve always used for the player.  Once I did that, and without any changes to settings on the WDTV,  the WDTV could see the shared media files/folders again when it logged in.  I’m not sure if this is a Win2K thing but it  behaved as if the WDTV remotely set a new (unknown) user password for itself on that server PC when the new firmware tried to connect up, even though I had entered the same password in the share login dialogue box on the WDTV.

Sorry, can’t explain what happened when you set to manual IP mode.  I’ve very seldom used manual mode (I’ve never had serious network issues with just the WDTV Live) but I can only assume that it locks in the last address it received through DHCP in auto mode.  I’ve noted that some WDTV owners on this forum have claimed success by shunning auto mode and always using manually set  IP addresses.  The only time I’ve EVER had a network problem was when a MACbook was connected to my Windows network.  It did something to my DHCP server so that the WDTV along with a network Bluray player, several Windows laptops and desktops, and a second MACBook, could not connect in auto mode.  This force me to manually assign IP addresses during the week the MACs were present.  After the MACs left my LAN airspace, I set everything back to auto and restarted absolutely everything in the network chain (router, switches, servers, etc.).  All returned back to normal operation.