WDTV LIve can't find network shares


Hopefully somebody can help me, I am almost about to give up, and I can’t understand why I can’t get it to work. I have tried everything, I could find in this and other forums, but it haven’t helped me.

Here is the setup/issue:

My data is placed on a server (windows 2008 x86), on the server I have shared the folders with my data, the folders can be opened from my laptop.

From the WD TV live, I go into select content source, and choose network share, and then windows shares, but it finds nothing at all. ( I have enabled netbios on the server, which was mentioned somewhere)

From the server I can see the WD TV Live, from the network view and they are in the same workgroup.

I have also tried to setup up, a test from my laptop with windows 7 with a shared folder, I have followed different guides, I have found, but its the same issue as with the server, I am not able to find the shares from the WD Tv live. But I am able to use my windows 7, as media server, then WD Tv can find it, without any issues. 

My router is a linksys/Cisco WRT610N Ver. 2 (Running newest firmware), I have read that others also are having issues with this router and WD TV Live, to see network shares. So I think it has something to do with the router, I have tried disable home network defender which was mentioned somewhere but it did not help. Is there someone, who can confirm if its the router or not? If its not the router then have a suggestion what the issue could be.

I have tried to use both wired and wireless connection to my WD TV Live, but its the same issue.

Any help will be appreciated. 

See if this tutorial for troubleshooting helps:


Hi TonyPh12345 :smiley:

I think I found the solution, it was the WRT610N router, because this router has the possibility to act as a media server, the router need to be in a different workgroup then the computers.

I tried to set my router to workgroup horse, then I tried to access the shares from the WD TV, and now it finds the server and is asking for cridentials, so hopefully it will work now. :smiley:

Thanks for your reply to my post…