WD TV Live suddenly won't find my network shares (Windows 7 x64)

Yesterday it was working fine. today it won’t find any of my shares.

Nothing has been changed in my network or on my computer. Nothing at all. but the player suddenly won’t find them.

Other machines can find them fine. but my WD TV won’t.

What the **bleep** do I do? -_-

See if this tutorial for troubleshooting helps:


Well it seems another computer on my LAN is the “master browser” - makes sense, because it appears as the only item under “media servers”, however nothing comes up under network shares.

How do I make my computers with the shares the master browser then?

I have been dealing with this same problem on my Live Plus the past few days, basically for the first itme ever in well over a year of working perfectly.  My main server PC that setup my network is a Win7  64-bit.  I found a solution it appears for the past few days now:  REBOOT the Win7 PC and problem was solved.

Now, here are the details of the solution.  I noticed shares seemed to not be there a few days ago except for the Win7 PC.  I knew sharing was set right, as the Win7 and all other network shares of all other PCs and printers, along with the Win7 were working between themselves; the problem was at the Live Plus TV display.  After checking stuff, I decided to put the newly-purchased used Live Plus I bought for a spare in place of the original one.  Problems remained the same.  So, not the WDTV at fault.

After more head-scratching, I figured the problem HAD to be coming from the Win7 PC, and somehow it was blocking all shares at the Live Plus.  So, with the original Plus back in the loop and while it was still on, I rebooted the PC, and once the reboot was good and over with, I looked at the TV, and all network shares were back again.

I attribute the cause to possibly originate from a recent Win7 update (I have experienced computer problems in the past after updates, and a month or so later they are gone (likely due to a fix in a susequent Win update).

Also, other people here have recently described having a similar shares problem that just began; again making me suspect a Win7 update issue.

Nonetheless, I recently added a Pogoplug with software and hardware to the network, and it has its own particular issues, so I will check to see if it could be the cause of all this, but not likely; it appears to the Live Plus as a new server (not a share).

Or, it could just be due to sunspot activity.  Heck, who knows!   :-)

When all else fails, don’t start tampering with settings that worked; and should still work;  just REBOOT the PC (or WDTV, etc).

Some updates to my post directly above.  This problem continues, and shows up every day or so.  Sometimes it skips a day.  Today, I had to reboot Win7 PC, and when it came back up the shares had disappeared again except for the Win7 PC.  Another reboot of the PC didn’t help, so I rebooted the WD, and that made them all appear.  So, it seems the problem is complicated in that one of the other needs a reboot.  Later today one of the three PCs needed a reboot after software update.  I went back to the TV and watched the other shares disappear when the XP computer rebooted.  Anyway, I got it all back again after the XP rebooted fully, but this stuff is frustrating and it takes various solutions it seems to get them all back again.  What a time sponge it all is!

I cant get my WB to find my network share. It just loads till the screensaver turn on… Worked just fine a couple of days ago.

Tried the fix, butthis is all i got:

C:\Users\AvaAdore3.0>net view
Server Name            Remark

The command completed successfully.

My WD says its online. It can find my computer if i try a Media server search, but then it dosnt find any files. And yes, I have shared files on my computer.

Edit: I have also rebootet my comuputer and my WD live TV hub.

Edit: Tried again today, and I noticed that if I unplug the ethernet cable whil its searching, it will say that i coundt find the source…

I kind of had the same strange problem where my WD TV Live cannot find my Windows shares. Some quick background; I used to have an Ubuntu Linux server streaming all my content and it worked great except I had a **bleep** of a time getting VNC to work with a headless unit. Samba worked great and the WD TV never lost its windows share connection.

But I got tired of doing everything by command line so I rebuilt the server with Windows 7 Ultimate 32 bit. This time everything worked fine except XMBC didn’t like working with RDP and I kept on losing my Windows shares. So I scrapped XMBC and went with the beta version of Plex. This fixed my Media Server problem but I loved the fact that I can stream iso files over my windows shares to the WD TV and I didn’t want to lose that functionality. I knew from reading the forum that chances were that my windows workgroup wasn’t functioning correctly.

Ok, so my day job is as a network designer and I know my way around switches and routers but I really don’t like Microsoft products and trying to troubleshoot them. The funny thing was that every time I booted my laptop up to troubleshoot the problem WD TV started working. Windows shares on my server were visible by both the laptop and WD TV. By reading all the information in this forum I assumed my problem was with NetBIOS especially since everything worked fine with Samba. 

By using net view and nbtstat I could see that the laptop was always the master browser (makes sense that everything worked when I booted up my laptop). So I wanted to find a way to make sure the server was always the master browser. I found a registry hack that I ran forcing the server to be the master browser and the laptop to never become the master browser. This time nothing worked because no device was a master browser. I checked everything I could including making sure NetBIOS was turned on at the NIC but I couldn’t find anything.

So now I had to troubleshoot why the server was never becoming the master browser. When I finally remembered to check the computer browser service I found that it was off and set to manual. Now keep in mind that this was a newly built Windows 7 installation and I never turned this service off. Once I set the Computer Browser service on and to automatic the WD TV has always found the windows shares on the server.

I know this was a long story but I figured some of you would enjoy it.