WD TV Live can't find any network shares

I’ve been using a WD TV Live for over a year now and it’s been OK, very frustrating at times having to re set things up every now and again but it worked, kind of.

 Recently though it’s been playing up and wont connect to network shares at all and I’m at the end of my patience with it. I’m having to plug a hard drive into it just to watch what I want which is pointless to me.

I’m trying to connect it to a Windows 7 PC, one that it’s connected to before, both on the same Wifi network and both in the same workgroup. I’ve followed the numerous guides/troubleshooting tips that google has found and nothing has worked.

I even hard reset the box and started over and still nothing, just the arrow chasing it’s own tail while it searches for my shares.

I’m looking for any help available. I’m willing to redo things I’ve already tried just to rule them out again if it means someone can suggest something new.

Thanks in advance.


Based on the information you have provided i recommend you contact support directly for assistance with your issue.

Contact WD

did you call them? I’m interested to know what they guided you to do as I have been having the same problem for past few months. I’ve tried everything!