Network Sharing Issues - Win7 x64


#1

Yeah, it seems there are eleventy billion threads about issues like these, but none seem to have helped as they mostly seem to be concerned with username/password problems.

I have gone through all this with WD support and replaced my original unit once already and I am at the end of my rope over this one.

Basically what is happening is: When I select ‘Network Shares’ for any media type, nothing happens at all it just sits there and does nothing at all, at first I thought this was a shared folders issue, but as others can get further than me I would imagine this is some kind of issue with my PC not showing up on the device? Or should I get SOME response at all when i press the shares function?  

I am using Windows 7 64bit, and trying to share from both my local pc hard drive and a USB drive attached also.

The shares I have always had are accessible from other pcs,macs, xbmc etc witrhout any issues whatsoever and shared to EVERYONE via share with specific people.

I have Homegroups turned off as suggested by WD support staff and have tried with media sharing on/off. Also tried local guest black passwords disabled in admin settings just in case. None of this seems to have given me any joy. 

The first unit I had i did both firmware upgrades to the latest and this one I have not done any just to see if it made a difference. 

Currently my sharing settings on Home network are:

Network Discovery ON

File Sharing ON

Pub Folder Sharing ON

Media Streaming ON

128 Bit

Password protected sharing off 

Windows manage connections

Any help with this would be hot as I am getting real sick of this seemingly simple issue real fast.


#2

This exact issue happens when there is NO MASTER BROWSER on your network.   

This is how to find possible problems with the Master Browser on your network, which will affect when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:


C:\Users\Tony>net view
Server Name Remark


\BIGNAS1 Big Freakin’ NAS Server 1
\MARS
\NEPTUNE
\WDTVLIVE WDTV LIVE
The command completed successfully.

In my example, there are four active devices that Windows has discovered.

Now, for EACH of those, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [10.0.0.157] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status

BIGNAS1 <00> UNIQUE Registered
BIGNAS1 <03> UNIQUE Registered
BIGNAS1 <20> UNIQUE Registered
…__MSBROWSE__.<01> GROUP Registered
WORKGROUP <1D> UNIQUE Registered
WORKGROUP <1E> GROUP Registered
WORKGROUP <00> GROUP Registered

So, we got lucky here, the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.

You need to find out WHICH system is your master browser. If none of these steps work as described, then the issue is likely on your PC itself, and that will require substantial additional troubleshooting.


#3

Ok I have followed what you suggested and these are my results

C:\Users\Michael>net view

Server Name            Remark


\CEILINGCAT

The command completed successfully.

C:\Users\Michael>nbtstat -a ceilingcat

Local Area Connection:

Node IpAddress: [0.0.0.0] Scope Id: []

    Host not found. (assuming this is due to not using ethernet on that machine right now)

Wireless Network Connection:

Node IpAddress: [192.168.1.3] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name               Type         Status

    -------------------------------------------

    CEILINGCAT     <00>  UNIQUE      Registered

    WORKGROUP      <00>  GROUP       Registered

    CEILINGCAT     <20>  UNIQUE      Registered

    WORKGROUP      <1E>  GROUP       Registered

    WORKGROUP      <1D>  UNIQUE      Registered

    …__MSBROWSE__.<01>  GROUP       Registered

So yeah, hope that helps diagnose the issue. 


#4

Is CEILINGCAT the ONLY computer on your network?

If so, then the issue would appear to be that the WDTV cannot see it through the network.

Does the MEDIA SERVER function of the WDTV see the PC?


#5

Currently that machine is the only PC on my network and yeah the WDTV can see media servers just fine, its only network share that seems to have a problem.


#6

Try this;   go into the SETUP screens on the Hub and TURN ON File Sharing, wait a few minutes, then repeat the NET VIEW command and post here.


#7

Ok, dont technically have a hub as such, its a modem with the single ethernet cable going to the WDTV and my pc running over wifi to same modem. But I will have a look for something like that.


#8

Sorry, I got confused.   I thought you had a WDTV Live HUB.    Just a regular Live/Live+.

Does the WORKGROUP name on the Live match “WORKGROUP?”


#9

What kind of Router / WiFi do you have?


#10

It is as it was when i got it WORKGROUP, same as the name of workgroup my pc is using.


#11

Hail Mary attempt:   Make sure all other PCs are shut down.   Reboot your Win 7 box.   Wait until it’s booted and up for a few minutes, then turn on the WDTV.   Give it a couple of minutes after the UI comes up and then try to select Network Shares.


#12

No dice I’m afraid. I am completely stumped by this i really am. Are there any ports I should be forwarding or anything? Just that i use UPNP for everything normally.


#13

Also, I can see the WDTV in my network devices in windows too.


#14

One other possibility is the name of the SHARES themself.

The WDTV will ignore certain characters.

On your PC, issue the command

NET VIEW \CEILINGCAT

and post that output


#15

Share name  Type  Used as  Comment


Anime       Disk

Downloads   Disk

Movies      Disk

Music       Disk

TV Shows    Disk

Users       Disk

The command completed successfully.


#16

Hi,

I also have the same problem. I have a WDTV Live player with Windows Vista 32-bit.

I would like to add that I had the player working fine since I got it, even after the latest firmware upgrade. Suddenly, when I click on network shares, nothing happens!

I should note that I can access the internet from the WDTV Live player. I can go to Youtube, Facebook, etc. The network settings are fine. And I can see the player in my network in my PC.

What could have happened that made it suddenly stop working!!??


#17

I would recommend both of you roll back to the prior release.


#18

I am using the out of the box firmware currently and its doing the same as the latest. I could try the forst update but ignore the second tho?


#19

It was working with the latest upgrade. But just in case, I did downgrade it…and upgrade it again. The problem presists on both FW releases.

I wonder what happened that made it stop working!!!

It can’t be from the PC because I have many PCs in the home network so it can’t be that all of them stopped showing up. I can’t be the network setup because I can access the internet just fine.

I don’t understand why it does not give an error message!!!


#20

As always, most of these issues come from a flaky Master Browser on the network…  

Without being able to dig into a packet capture, it’s not always possible to figure out what’s going wrong…