WD TV Live Network Shares Issues

I purchased this about 2 years ago I think and I went through a lot of troubles and tutorials to finally get my TV Live working. I know of the Youtube video, I’ve followed a lot of Mike Kelley’s posts on here too and I’ve tried all the solutions to no avail. About a week ago, I updated my WD TV Live. During that time, I also changed my Network from “Public” (not sure why it was on that when I am part of a home group) to “Home Group.” I’m not certain which is the cause, but I do know it refuses to see my network shares now.

I’ve redone all the past information I gathered from here and other sources and it still doesn’t work. The computers my network ALL can see my network share. The WD TV Live sees the other WD TV Live in my house upstairs (this one is wireless), but doesn’t see my computer.

At this point, any suggestion would be helpful. I’ve tried disconnecting it 5 minutes. I’ve also uninstalled Live Sign-in Assistant, and I’ve also turned off my Windows Firewall in addition to all of the sharing/advanced network settings.

“Homegroups” are only supported by Win7.  Even a Vista or XP PC will not be able to connect to a “Homegroup” share – the WDTV certainly can’t.

Try a “Home” or “Work” profile instead of “Public” for your sharing.

Within the sharing settings, all I have is:

  • Turn on network discovery
  • Turn on file and printer sharing
  • Turn off public folder sharing (I don’t use the “Public” folders/libraries)
  • Media streaming is on
  • Use 128-bit encryption
  • Turn on password protected sharing  (because personally I share my shares with the “WDTV” user, and have the WDTV set to log in as the “WDTV” user with the correct password… although certainly this isn’t necessary for sharing to function-- you can share with “Everyone” or “Guest” or whatever, and have the WDTV just connect anonymously)
  • Use user accounts and passwords

I’ve never had issues with these settings.  They’ve always worked, once I got everything set up in the first place, through every firmware update.

Other than sharing the actual folders properly, as far as I can tell, this is all it takes to get sharing to work – in both directions.  There doesn’t seem to be much “magic” to it, from what I can gather, as long as the network is working properly and as long as the shares are shared to whatever the WDTV is logging in as (either anonymous, or a specific user).

EDIT:   Actually, let me amend that.  On my Win7, the “Guest” Account is “off”.  If I were not connecting the WDTV using a specific user name (whether “WDTV”, or my main admin user, or anything else) and instead wanted anonymous connections, I believe I’d have to turn the “Guest” account on in the User settings.

Hi Roofing, I’m a bit confused by your explanation. You first said Homegroups don’t work but that I should try Work or Home profile.

Did you mean Work or Public? I have every one of those settings that you mentioned on or off respectively.