WD TV Live not detecting Windows 7 Network Shares


#1

Issue:

WD TV Live not detecting Windows 7 Network Shares. When you go to WD TV Live -> Video-> Network Share The windows 7 PC is not being detected.

Setup:
Window 7 Ultimate
WD TV Live 1.01.11
Firewall disabled on WIndows 7

Configuration:

Home network setup as:
-    Turn on network discovery
-    Turn on file and printer sharing
-    Turn on sharing so anyone with network access can read and write files in public folders
-    Use 128 bit encryption
-    Turn OFF password protected sharing
-    Allow Windows to manage homegroup connections

  •      Enabled File sharding with Eveyone as the pemissions for the directoies I would like to use.

This is details under WD support site Knowledge Base #3787

  • I have confirmed that my Windows XP box works fine under WD TV Live. I was able to susessuly share using Windows XP.
  • My Windows XP PC can map and connect to my Windows 7 share.

I have called the WD support. At this time they are at a loss. I am waiting for a call back from a higher support Tech.


#2

If your workgroup name is not already named “WORKGROUP”  try changing to that.  Note that it is all caps though windows is said to not be case sensitive on workgroup names WDTV Live may be case sensitive.  There is still debate on if the workgroup name needs to be this.

Also, see this post here: http://wdtvforum.com/main/index.php?topic=3251.0  thanks to TheTooleMan for finding this.


#3

Already set to WORKGROUP.

Tried both Caps and not caps.

No Go

Thanks


#4

Try this: http://community.wdc.com/t5/forums/forumtopicpage/board-id/tv_live/thread-id/1604


#5

Thank you for the reply.

I original tired this post.

Look at the 4th last paragraphs on this page. I have that biger issue.

*****

Now go back to the main menu and then go to VIDEO and down to NETWORK SHARES. Under NETWORK SHARES you should see your computer ( if you don’t you have a bigger issue than this guide is meant to cover ). Click right or hit enter on the remote and it should bring you to a login screen.

*******

Thanks

Dan


#6

My WD TV Live does the same ; does not detect any Network share in Windows 7 in any service video, photo, music . It detects my Laptop drives under the selection servers for all services. I suppose the problem has to do with firware bug since I am not able to perform Network setup in automatic mode but only in the manual mode providing manually the IP address  . WD TV Live is not included in my router’s DHCP table . WD should fix the problem.


#7

It’s not a configuration issue on the PC end. 

I have Windows 7 64-bit machine that it OCCASIONALLY finds.  I have other DLNA compliant devices that find this PC each and every single time, and stream from it flawlessly.

The idea of altering my entire network configuration, or worse yet, telneting into the device to overcome its obvious bugs seems ridiculous to me.


#8

I tried both static and DHCP. Niether works.


#9

Try following the instructions in the article below:

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=3787&p_created=1255389287&p_sid=sG3xegRj&p_accessibility=0&p_redirect=&p_srch=1&p_lva=3850&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MTMwLDEzMCZwX3Byb2RzPTAmcF9jYXRzPTAmcF9wdj0mcF9jdj0mcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9mbmwmcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1zaGFyZSB3aW5kb3dz&p_li=&p_topview=1

Particularly look at the section titled " Allowing a Folder To Be Shared On Windows 7" I followed those instructions and it showed right up for me.


#10

I have the same problem as Bill_B. My Windows 7 Network Shares only show up sometimes - and that is from two separate Windows 7 Machines. Either both are there or neither - so I absolutely expect it is a WD TV Live box issue. I have not seen my network shares for a couple days.

Sigh!


#11

After posting yesterday, I copied some video files to a USB thumbdrive and tried that in the unit. Magically, the wd unit started to discover all of my network shares. I think it woke something up in the WD unit. Anyway, I only tried this once, but it may help others that have the network share issue.

Cheers


#12

Hi,

I have exactly the same problem as you, I have 2 PC and 2 laptop at home, each  computer can detect all other computers in the network (all computer are under windows 7), I can even detect the WD TV LIVE.

However, the WD TV LIVE detects randomly my computers, some days it could spend hours without detecting any computer and sometimes it detect all my computer when I turn it on.

I followed this tutorial  http://www.youtube.com/watch?v=EQstgQ4eJCM but it changed nothing.

If you have any ideas… just share