WD TV Live Streaming Wi-Fi sharing folders issue with Windows 7 x64

Hi everyone. I’ve recently bought this media player and I wanted to stream video from my PC via Wi-Fi or LAN. I’ve turned on the player, connected it to my Wi-Fi router, connection was successful. Player received IP address, the internet was working, everything was fine until I decided to play movies from my PC. WD TV just couldn’t find my PC’s shared folders and I think it couldn’t even find my PC actually. So I decided to upgrade my firmware to the latest version 1.11.14, but that doesn’t help. When I’m choosing Windows Shared Folders from the menu, the device is just trying to find any folder in my network, but unsuccessful, it keeps refreshing all the time.

I’ve tried to do the same thing with my laptop (with Windows 7 x86), but result was the same. Does anybody know how to fix this problem? My laptop and  the android phone (with ES Explorer program) don’t have this issue, they can use shared folders from my PC without any problem. My PC doesn’t have any restrictions or passwords, it is completely unsecured for my local network.

As temporary decision, I’ve installed Home Media Server to my PC and it works fine, WD TV finds it without any problem. But the point is, that I want to use shared folders, instead of additional server application on my PC. Can anyone help me with this?

PS Sorry for my English. I’m from Russia.

Have you put your WD TV Live Streaming in the same workgroup as your home network workgroup? 

Make sure you put the same name, check your Network Setting on your WD Tv device.

Yes, they are in the same default group “WORKGROUP”.

Make sure  on WD TV network setting : Network Share Management  :  Windows Share Server = ON

If these setup has been set, can you see WD TV Live on your PC? 

Double check WORKGROUP name is identical.

I bought my WD HD Live last week, and I have the exaxt same problem (I use 1.11.14). My WD HD does not recognize my shared folders on my laptop.

It works fine (sort of) when i use a media server software on my laptop (right now I use PS3 Media Server & VUZE Media Server), but it doesn’t work with Windows shared folders.

I CAN see my WD HD appear on my laptop, but I can’t see my laptop appear on my WD HD. My Wi-Fi is otherwise fine.

By the way, I can’t play MP4 or ISO over wi-fi (using media servers), but it works beautifully if I play from a USB memory-stick.

 Windows Share Server is ON. WORKGROUP name is completely identical. And yes, I can see WD TV Live from my PC and access its storage without any problem.

If your PC can see your WD TV Live and HDD/USB disk that you hooked up to it, that’s a good thing, means you’re in the same network and I take it you also can transfer files from PC to your WD TV. 

Now, on your device, Select Video, you may see your local storage, now press B button ( red one) on your remote, you’ll see option to choose which Content shares, choose : Network shares and choose Windows shares, at this time you’re supposed to see your PC or any other connected device on your network.

If you still can’t see it, then its another problem that I dont know of, I also have the latest firmware (1.11.14) and I can see all my connected PC in my network from my WD TV.

This is exactly what I was trying to do, when I choose Windwos Shares I can only see the circle with arrow, it just keeps circling all the time and nothing else happens. Also, after several minutes of circling, the device starts freezing and doesn’t react on my remote.

I am guessing it may be a “Permissions” issue.  Right click on the folder on the PC that you want to share.  Click on the “Sharing” tab.  Now click on ‘Advanced Sharing’.

Now as you work your way through this ensure you give all permissions, read, write etc for this folder.  After you click on ‘Share this folder’ click on the ‘Permissions’ button.  Allow Everyone to Read, Change, and Have Full Control.  On the way out remember to click on “apply” each time.

I would then turn my WDTV right OFF, (Remove Power).

Now let it restart and follow the directions given earlier re Red Button etc to access files from your PC…

I play very little from my PC.  I have everything on a 500GB drive attached to WDTV Live SMP.  As I get a ‘new’ file, I transfer it wirelessly from my PC to the drive attached to the WDTV Live SMP.  It is a $100+ little box and does a sensational job playing back files.  When I have ‘watched’  a file, I delete the file from the add on drive via the “Options” button on the remote.

I have installed Tinwarble’s Mojo Theme and I have great movie sheets for all my video files which I have created using ThumbGen.

I see what you are trying to do as an added feature by playing files from your PC via the WDTV Live SMP.  I have no network problems the way I use my media player.

There is no “Permissions” issue. My other devices can freely access shared folders.

Thomfam,  you may be right about permission, but as helcoder said he managed to shares with his android and laptop, so I think the WD TV could’ve access the PC.

helcoder, you may wanna test it on different network (your friend) or rename your workgroup into something else. if this fails too, then you may wanna take it to the shop you bought and ask for a replacement.

Solved. The problem is that I was using Cyrillic symbols in my PC’s name, instead of Latin symbols. Now everything is working, but not so stable, sometimes it takes too much time to start playing a movie.