Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit


#1

I authored this tutorial in the attempt to aid anyone who was having issues connecting network shares over Windows 7.  I’ve been told this works for both the x64 and x86 versions, however, when I wrote it I intended it for x64 since that is what I use.

Hopefully this video can assist others.  Pardon the mic issues.  Batteries were dying I found out later.

http://www.youtube.com/watch?v=EQstgQ4eJCM


Unable to connect to Windows 7 PC
Unable to connect to Win 7
#2

Thanks for this.  This actually works!

Now, the only issue I have and I know that a few others have mentioned this, is that when I turn on the WDTV Live, it takes anywhere from 10-45 mins for it to actually “wake up” and see the Network Shares.

Does anyone have a clue as to why this is happening ?


#3

Tried this, it does not work in my case, still get invalid user name and password. …But if , in the network advanced sharing screen, you disable media streaming ,as instructed in the video, you loose the media shares. Are you suggesting of using network shares instead? I’ll give the part with folder sharing another careful try tonight but I don’t think you take media shares out as that causes the media library, the folders you see in the library section of the windows explorer or windows media player, to disappear.


#4

It’s abnormal for the WDTV to take more than several minutes to access the network shares.  My box sees the shares (win XP, Vista and Win 7)  in less than 3-4 minutes.

I would check the cable and/or connections - if the connection is flaky it will cause lots of errors in transmission which results in repeatedly retries…


#5

This was another thing I was going to change, the network cable that is, which is spliced using a network cable extender.

That could be a reason why the wdtv sees the wireless computer just fine in both, the media shares and network shares while the wired computer is only visible in media shares, less music library which is sometimes  is on sometimes off. Thanks for suggestion, I think this is the only thing I didn’t try. 


#6

Fantastic video!  Thank you!  The information there helps for the folks who are having problems with understand this whol business about “shared”.

One quick question, I made my “WD Live” directory (instead of  Tutorial.  How come do I also see the USERS folder listed there?  I never turned it on to be shared and in my PC setup, I only have one user, without any password login.

It’s not a big deal, but wondering why  my WD TV Live has access to that folder (and it’s contents) besides the one created specifically via your suggested ways.


#7

serge wrote:
Tried this, it does not work in my case, still get invalid user name and password. …But if , in the network advanced sharing screen, you disable media streaming ,as instructed in the video, you loose the media shares. Are you suggesting of using network shares instead? I’ll give the part with folder sharing another careful try tonight but I don’t think you take media shares out as that causes the media library, the folders you see in the library section of the windows explorer or windows media player, to disappear.

Try this > on the WD TV Live go into Network Settings and change and Auto login to network share > On.  Reboot the device by pulling the power, waiting 15 seconds and plugging it back up.

Let me know if this works.


#8

mystiky wrote:

Fantastic video!  Thank you!  The information there helps for the folks who are having problems with understand this whol business about “shared”.

 

One quick question, I made my “WD Live” directory (instead of  Tutorial.  How come do I also see the USERS folder listed there?  I never turned it on to be shared and in my PC setup, I only have one user, without any password login.

 

It’s not a big deal, but wondering why  my WD TV Live has access to that folder (and it’s contents) besides the one created specifically via your suggested ways.

I’m happy it worked for you.  Love hearing about success stories.  To answer your question about why you see the USERS folder;  you have Password Protected Sharing turned off per my guide.  WIth that setting turned off you have something of a Windows Simple File Sharing going on. 

Try the following:
First, un-share the Users folder:

  1. Open the C: disk.
  2. Right-click the Users folder.
  3. Click Properties (not Share).
  4. Click Sharing.
  5. Click Advanced Sharing.
  6. Un-check “Share this folder”.
  7. Click OK.
  8. Click Close.

Then, share the desired desktop folder:

  1. Right-click the folder.
  2. Click Properties (not Share).
  3. Click Sharing.
  4. Click Advanced Sharing.
  5. Check “Share this folder”.
  6. Click OK.
  7. Click Close.

Thanks to Steve Winograd, MS-MVP for this solution.  Googling save us time :slight_smile:

http://www.vistax64.com/vista-networking-sharing/149437-when-i-share-desktop-folder-c-users-all-subfolders-sha.html


#9

Hi Computer guy!

Well, I spoke too soon.  Really need help now:

http://community.wdc.com/t5/Networking/I-changed-my-router-and-now-I-can-t-even-see-my-Network-Shares/td-p/7094

If you have any ideas, please reply here or there…


#10

Out of desperation, I once again tried to reconnect the WRT300N router back on the system, and guess what? Everything is working like a charm again. I did not have to touch any settings on Windows 7 … So this tells me that WD TV Live has incompatibility with the Linksys WRT610N v2 router and therefore, I am returning it back to the store. Funny enough, I watched 45 minutes of 1080i video yesterday without any “skipping” from my WRT300N, on a mixed signal using 20Mhz.


#11

im using the  Linksys WRT150N v1.1 with DDWRT firmware, ive found that about 50% of the time, the wd wont pull an ip address. furthermore, if i set a static address it still wont work. 

I have media servers working, shows everything shared in windows media player, however, id like to get network shares working properly.

I like others have the problem of invalid username and password, even following your guide. I havent tried the auto login thing yet, will be giving that a try tomorrow.


#12

Hi, so I have been scouring the forums and tried everything multiple times and still cannot even access the network share option on my WD TV. I was wondering if there was anybody else who had this problem and was able to get it working and what you had to do.


#13

I have the same issue, keep getting invalid username/ password.  I have followed ur video exactly, also rebooted the device and still the same issue.


#14

Hi -

When the link that WD said they would send to me didn’t come…

I found this on Utube abd it worked.

FYI TY - Mitch

http://www.youtube.com/watch?v=EQstgQ4eJCM&feature=player_embedded#


#15

I tried following all of the suggestions here to be able to access my windows 7 network shares from by WD TV Live. I am sure that many of the suggestions got me partially there but I just could not get passed the invalid user name/password prompt. I then ran accross a suggestion that seemed odd but I tried it anyway. Once i did that I no longer got the invalid user prompts anymore. It doesnt mean i didnt have other problems but that one went away. The suggestion was to uninstall from Windows 7 something called ‘Windows live ID sign in Assistant’. Apparently it was causing the problem with the login process. This may not work for everyone but i felt i should reiterate this suggestion in the hopes that it might save someone some time.


#16

@ADPINE

Absolutely amazing…i uninstalled Windows Live ID ■■■■ and it works now. Rock on!!!


#17

Many thanks for your suggestion.

I finally got network share working on WD TV Live by uninstally Windows Live ID Sign-In Assistant. I just log in as Anonymous with blank password and finally is able to access my Windows 7 network.


#18

OMG after 4 hours of reading every article on the internet on how to share files with Windows 7 and the WD TV Live, I edited registry settings, tons of folder permissions, went into home group and neutered my security settings. 

Every time I went to Network Shares then to my PC on the WD TV Live, it wanted a user name and password.  I would just hit okay then it would say invalid name and pass.  I had no idea why it was doing this…I don’t have any name and pass on anything.

Then I read in this thread to uninstall Windows Live ID Sign-In Assistant, I went to control panel, remove programs, uninstalled it and BAM, I just log in as Anonymous with blank password and finally able to access my Windows 7 network shares.

How did somebody figure out that Windows Live ID assistant was causing the problem?  Whoever mentioned to uninstall it, thank you!!!


#19

I did this and i still cannot get access :frowning:


#20

“I did this and i still cannot get access”

If you are using Windows 7, did you disable password protected sharing from the advanced homegroup settings?

Follow this guide, I did and it worked for me, I am using Windows 7 Ultimate.

http://www.avsforum.com/avs-vb/showthread.php?t=1194088