Can't access network share feature consistently


#1

Hi folks,

My WDTVLIVE had been working right out of the box with windows 7100 without a problem for about 3 weeks. For the 3 weeks after that it gradually began to not see network shares, disconnect, etc. Now it consistently doesnt access the network share feature at all. If I hit the arrow or push enter, nothing happens. Occaisionally its nice enough to tell me it can’t connect to the network. Despite the message, every other network based feature works fine. Like youtube for example. I am currently working with support to get this resolved, which is proved very frustrating. I got more angry with them than I feel like I should have. Since this apparently is a widespread issue, i’ve tried every lil “resolution” possible.

-Disabled homegroups (including its services)

-Registry Hacks

-Renaming PC

-Tweaking Advanced Network Options in dozen different ways.

-Restarting PC while WD is still on.

-Resetting device.

-Resetting router. (that was the biggest pain)

-Resharing all folders.

-3rd Party Softwares.

-I’m sure I left something out.

Is there a way to get the network sharing feature to work consistently? There are times that due to mysterious fairy magic it begins to work for a brief amount of time. I turn it off when I leave. I return home all giddy and excited about watching a movie. Nope, doesn’t work.

I have people surrounding the TV ready to watch a movie and I embarass myself by trying to get the cursed thing to work. And no. Here I go start firing up the old DVD/VHS player.

Help.


#2

i have the same problem.i usually have to turn off network discovery,dis- able  adapter settings,enable adapter settings and turn on network discovery.usually works for me i think its a wdlive- windows 7 flaw…


#3

I have an idea that the problem may be related to packet size handled by the networks and network adapter to WDTVL.  In particular if you usually use gigabyte and the WDTVL is ethernet.  If you search the BOARD for “packets”  you will see my previous replies to other users.  If there is anyone who can verify what I have suggested then I would appreciate it.


#4

I have the same problem.And many more seems to have the same problem

WHen are WD going to address this probelm?


#5

Well, from what I’ve seen in the last weeks with my WDTVLIVE I think the networking flaws are more related to dumb details rather than control panel tweaking, which isn’t at all necessary in many cases.

At first I also thought the WDTV had more issues with windows 7 than other OS’s, but that was until I noticed that my brother’s account on the XP box was a simple username with no password, whereas my windows 7 box had a complex password, which drove the WDTVLIVE crazy (and myself). However, I reinstalled windows 7 on a different partition and right after the welcome screen, and without messing around with the control panel at all I had it working within seconds, but this time after creating an account with a  username/password that didn’t contain any special characters. Until then with the prior win 7 installation I had to enter as guest, the network would drop in the middle of a video/song, etc… just like ppl are reporting. That’s why I think the myriad problems I’ve read about network drops on this board are more related to the especific setup of each network and its complexity, rather than the OS tweaks, that I guess can help with certain problems, but are not needed if you find the real cause of the problem.

My recommendation for the ppl who have network problems is that they forget for a moment about the tweaking, and try to change stuff in your rig/network to see if it makes any difference, anything from the NIC in your PC to the router/switches, PC’s connected to the network at the same time, PC’s changing IP’s due to DHCP etc… Perhaps if you temporarily remove other PC’s than the one with the network shares from the network, or configure your PC’s (and the WDTV) with static local IP’s instead of relying on DHCP you might get lucky.

Ofc this doesn’t take from the fact that the WDTVLIVE’s firmware could do with a lot of improvement, but for the time being doing some tests with your HW rather than your OS could pay off in the short term.


#6

I have experienced similar problems. All my data are on a NAS disc (Synology, running Linux/Samba). When music is playing on WD TV Live from this disk over shared folder access and I try to switch to video, it does not work. WD TV Live does not connect to the drive anymore and the only solution is off/on by switching off power.

However, when I stop playback and then try to switch to the video (or vice versa), everything works and I get the connection. It seems to me that the problem is actually in the firmware of WD TV Live.


#7

Hi everybody,

had the same problem and was driving me crazy.

I solved it changing the ethernet cable with a better one (cat5).

Now it’s working like a charm.

Hope it can help.


#8

Don’t know if you guys know this, but Vista and 7 do have permission issues with Samba sharing.  You will need to allow the WD TV Live to access the folders you want to share.  You can also put your movies in the public folder on you pc’s.  That should allow the files to be shared without setting permissions.  WD has an article on how to set permissions in its knowledge base if you need it.  Sorry, I was too lazy to go look for it for you.


#9

tech support says they are working on the problem, maybe 3 to 4 weeks before a fix. seems odd that it was working sometimes before and now it isnt working at all


#10

Mine had been accessing network shares (Vista x64) without any issues up until a few days ago when it refused to connect one time (button simply had no effect when choosing Media Server or Network Shares).  It seemed to right itself after a reboot but, starting last night, it steadfastly refused to connect to shares regardless of anything I tried (rebooting WD, rebooting PC, checking shares, etc).

Got things running again today after restarting my AT&T 2WIRE gateway (2701HG-B).  Had been connecting wirelessly to the WDTV using a Linksys AP.  Realised it wasn’t the WD at fault when I couldn’t even ping the Linksys AP.

Weirdest part is that the router would still let the WD go online (YouTube worked fine), just not see the rest of the network.

Reboot and the network is again visible, plays files fine.  It was billst69’s post above that made me think of trying it.

So in my case I can’t blame this one on WD, which is good, because on top of the needlessly quirky codec / container support, network issues would have been the final straw on a media player that’s main new feature is network connectivity!


#11

I’ve done all the meddling I could with networking. I am so very sure its got nothing to do with networking. As for you PixelPower, not being able to ping your router is a dead giveaway to a router issue. But by and large the majority of the community have perfectly fine routers, gateways, switches, etc.

Personally I tried it with 2 different routers, wired and wirelessly(dear god, never again).

I don’t find technology scary in the slightest. When I say i’ve done everything. I mean everything short of writing my own firmware. I might have saved time by doing so -_-.

But unless WD wants to pay me 180,000 a year. I’m not writing anything for them.

WD already has lots of issues, lots of issues. None of which I care to pick up the phone and call support. None of which I care to rant about. None of which I care to mention by name.

I just want networking. Just that. That is all I want. That’s all that’s not working. If i didnt want it, I’d have gone with WDTV1.


#12

I think after the .17 update we should mutiny. Or perhaps its to pave the way for newer things? Iono. All I know is that my heart skipped two beats after I saw the update.

And that support has yet to get back to me after a week. Case/ticket is still open. And network shares still fail.


#13

while i may be unhappy about any disfuncionality of my wdtv live, i still appreciate the overall usefullness of this machine. i remember the days of  moving files to my laptop to utilize my HDMI port so i could watch movies on my LCD tv. i think this technology is in its earliest stages and eventually will blossom into a home media solution.  think of having all of your home media available to you from anywhere in your house from any device. if you could see all of the cords running through my house, you would understand my concern.

   with that said, i am anxious, but patiently waiting for a fix on the networking problem, but more importantly i want to see the future developments of this technology.


#14

I don’t disagree with you flyboy. Truth be told? I want to buy 4 more of these devices. Stream media to every TV. But without these issues resolved. I am considering other resolutions. This is by nooooo means the only resolution to this “problem”. It just happens to be the “easiest” one.


#15

I would say that lot of the problems of  “missing” computers on the network are related to the odd way how Windows file sharing works. Computers need a master browser computer on the net. That then looks after telling other computers in the workgroup “what is where”. Windows machines on the subnet elect which one of them will do the job (if you don’t have wins server). (Btw, it works in such a way that the newer version of windows you have the higher is the chance that this particular computer will become the master browser.)

Rebooting anything actually does not help much in this case. It makes things worse. Especially when you reboot machine which “won” this master browser competition :slight_smile:

My NAS drive is hooked up to the network all the time and I also always see it with WD. Samba in it is setup so that it always wins the master browser election. However, even then it takes a while to see other computers when I connect them to the network.

Generally a good idea is also to reserve IP adresses for each computer on the net, so it always gets the same address when it’s connected. Do it in your DHCP or just simply use manual IP configuration. You can connect your shared folders using IP addresses (i.e. \10.0.0.1\share) instead of browsing computer names. It’s actually a pitty that this cannot be done in WD TV Live. It would also relieve lot of pain.

Nevertheless, I’m worry that WD engineers cannot fixed most of these troubles with sharing. There is another (MS) company to be blamed :slight_smile:


#16

My network was working perfectly with WD HD Live until the .17 upgrade

But now its unconsistent and randomly loses the shared computer.

Sometime if i reboot the host machine it will work again… for a limited period of time.

Very annoying, and it makes this box completely useless for me this i only use it to watch movies located on the network.


#17

That’s intersting. Is it possible that DHCP gives your computer diferent IP address? It can actually change it after while.


#18

after fw update i cannot connect to computer at all, both network shared files and media servers fail.

bad bad bad …


#19

Same problem here. Network share was working fine, then I upgraded to 1.01.17 firmware 2 days ago and now no more share no matter what I do…to the WDTVLIVE, to my PCs, to my router…nothing. I even tried going back to 1.01.11 firmware, but now network share won’t work with that anymore either. Very frustrating and maddening.

BTW the symptom is that nothing happens when I press/select NETWORK SHARES on the WDTVLIVE. And yet I can connect to the internet. All my PCs are running Win7.


#20

Ta 4 that. I’ve tried every thing I can think of and other peoples ideas but still can’t share files-works ok to internet but bought this to view my pc files, GGGGRRRRR.Windows XP with sky router.Not sure which box to take the sledge hammer to next!!!