Windows 10 Fix

Okay, I understand that Windows to will no longer show my “My Cloud” because of some security updates. Are there any fixes or work arounds.?

@PreacherAl

Get My Cloud to show in Windows 10 File Explorer Network - My Cloud OS 3 Personal Cloud Storage / My Cloud - WD Community

Yes enable SMB1.0/CIFS.

Tried it still a no go

Also check that the Network Profile in Windows 10 is set to Private and not Public.

Check any third party security or firewall programs. Disable them temporarily and see if the My Cloud is reachable on the local network.

Can the My Cloud Dashboard be reached? Is the front LED on the My Cloud blue? Can you reach the My Cloud Shares in Windows File Explorer using the IP address of the My Cloud in the File Explorer address bar?

I run a number of Windows 10 PC’s, all can see the My Cloud in Windows File Explorer provided I have SMB1.0/CIFS enabled and the Network Profile set to Private.

You need to enable SMB1 first. Windows polls the network every so often. The NAS won’t show up until after it polls the network. Sometimes this is quick, sometimes very slow.

Sometimes you can map the drive as \\wdmycloud\public and it will find the drive.

so - enabling SMB 1.0 is important. . … but make sure you click “SMB1 client”.
SMB1 server I think is optional
SMB1 automatic removal. . . .DO NOT select that. It will nuke SMB if you don’t use it for (I think) 15 days.

FWIW: I find that getting devices to show up consistently as a computer in the network tab - - is a bit problematic. At this point - - - after looking for a fix about every 3 months for the last few years - - -I have simply given up.

Typing “\\DeviceName” or “\\ipadress” always works - so that is what I do.
I suppose you could always map devices/shares to a Drive letter will also work; but I am not a fan of drive mapping.

Edit: Typo

1 Like

So far none of the recommendations have solved my problem. I enabled SMB1 but not the auto function. I checked my firewall for anything that might be blocking the app or the ipaddress but nothing seems to work. The drive works just find for my Android tablet and my Chromebook by my windows computer continues to block it in some manner. The problem cropped up only recently (December?) so I can see how it was a Windows 10 update. I am using AVAST for my anti-virus/firewall. I tried disabling AVAST for 10 minutes but the ipaddress still keeps coming up “Address not found”. I tried mapping the ipaddress to a drive letter but no go there either. I am sure it is some simple problem that i have overlooked. So until we can figure out what that might be. No MyCloud on my PC

As previously mentioned, can you access the My Cloud Dashboard using a web browser? Either by it’s name or by the My Cloud’s IP address?

https://support-en.wd.com/app/answers/detail/a_id/15104

If you cannot even access the My Cloud Dashboard by it’s IP address then there is likely a networking problem or the My Cloud isn’t obtaining a proper IP address or you previously configured the My Cloud for a static IP that it different from the local network’s IP address subnet range. If one previously set a static IP address for the My Cloud in the My Cloud Dashboard, one can perform a 4 second reset via the reset button on the back of the My Cloud unit which will reset the My Cloud DHCP setting back to default.

https://support-en.wd.com/app/answers/detail/a_id/24022

Okay, before I do a reset, is the IP address default for most WD My Cloud devices? As far as I know the IP address was established when I first purchased and installed it using the WD software. Even trying to use the WD discover or similar apps provided by WD, the drive cannot be seen
Like I said earlier the problem only cropped up in the past few months. Probably after a Windows 10 update. How will the reset affect my Android and Chromebook apps? Will it just be a matter of rediscovery or will there be other issues to navigate?
Thanks,
Alan

There is no default IP address for the My Cloud. In it’s default setting, the My Cloud will attempt to retrieve an IP address from the local network DHCP server which is typically within the local network router.

If one changed the default setting for the My Cloud so it has a static IP address that will cause problems if one changes their local network router and that router uses a different IP address subnet range. For example if one sets the My Cloud IP address to 192.168.0.10 within the My Cloud Dashboard Settings and they change their network router (or the router’s configuration settings) and the new or changed router uses an IP address subnet range of 192.168.1.x, then devices that are using an IP address from the 192.168.1.x range may not see the My Cloud because it’s on a different IP address subnet range.

A 4 second or 40 second reset do not erase any user data. The 4 second reset only changes these settings back to default:

  • Admin Password (No password by default)
  • Network Mode (Default = DHCP )
    Note: The 4 Second Reset will only reset the Admin Password. It will not reset the Admin User Name. In order to reset the Admin User Name perform Option B - the 40 Second Reset outlined below.

A 40 second reset will reset the following settings back to default:

  • Admin User Name (default = “admin”)
  • Admin Password (No password by default)
  • Device Name (default = “WDMyCloud”)
  • SSH (Secure Shell) on Firmware 04.xx.xx-xxx, User Name and Password (default = “root” and “welc0me”)
  • SSH (Secure Shell) on Firmware 2.xx.xxx, User Name and Password (default = “sshd” no default password, new password enforced)
  • Remove all Users except Admin
  • All Share permissions (default = Public)
  • Automatic Firmware Update (default = off)
  • Network Mode (default = DHCP)
  • Remove all Alerts
  • mycloud.com account association (default = not configured)
  • Mobile app account association (default = not configured)
  • WD Sync association (default = not configured)
  • Backup jobs (default = not configured)
  • Safepoint jobs (default = not configured)

I was all set to give your recommendation a try when i checked my File App in Windows and lo and behold I could see the My Cloud drive under network connections. When I double clicked on it, this time it opened to a webpage and I had full access there. But when I attempted to use the FTP location of the drive to assign a drive letter it couldn’t find it. Maybe I need to run the discovery software for WD when I get home later tonight.

Off-topic, but why are you not a fan of drive mapping? I have two folders on My Cloud mapped to drive letters and everything works well.

Thanks.

Do you install all updates on Win10?

You use last firmware on you NAS?

Ya I am a big fan of mapping my Cloud Drive, but alas Windows 10 is making this so difficult.
It works like a champ on my android devices, so I know it isn’t a server issue. Something has changed in windows and restoring the SMB 1.0 setting has failed to resurrect my former mapped drives

Saturday, I took my computer to work with me and now that it is home again, it is not seeing MyCloud drive. Still not seeing it this morning. It is like there is something blocking it, but I don’t know where else to check. I have looked in the virus software and Firewall. For a while I was able to see the dashboard via Chrome but that has gone away. As far as the Firmware, the dashboard (while it was working) was up to date. I considered switching over to OS 5.0 but I wasn’t impressed with the reviews on Google Play.

Most likely I am being naïve. . . . . .but if a HD is not mapped on a PC; then I imagine it is just that much harder for ransomware to find the drive.

Not if I can help it. Win10 always worked pretty well. HOWEVER; Win10 Updates have a tendency to install themselves. . .and they often change some aspect of functionality. MOST annoying to see change for the sake of change.

I did have one case where an update rolled through unannounced on one of my PC’s. . . it had been down for awhile and I was firing it up to run a specific program and not tie up another machine. BLAMO. update. BLAMO. . O/S corrupted… …BLAMO cost me several unnecesary hours to do a fresh Windows reinstall.

I rarely update firmware on the NAS’s. I try to be at least one full version back. I let others find bugs.
I will AVOID the final OS/3 updates to my OS/3 drives. . . .don’t trust WD to not have put some advertisement or other incentive to do an OS/5 update.

I have ONE NAS on OS/5 as an experiment and to play. Based on this experience; I am content to not update my other OS/3 drives.

Malware/ransomware can search out other network devices on the local network even if one doesn’t map Shares. Obvious methods of trying to prevent or mitigate such attacks is to keep everything up to date with the latest patches and updates. Of course that only works if the manufacturer is on top of fixing vulnerabilities quickly. When it comes to the My Cloud, well… we’ve seen how often (or rarely) security vulnerabilities are fixed across the My Cloud line. The first gen single bay is end of life and not receiving any additional firmware updates (for over a year now).

Other methods include incremental or rotational backups of the NAS regularly, so if the NAS is infected one can restore an uninfected version of the backup. Of course lower end NAS units (like the single bay My Cloud) won’t have advanced options/features for it’s backup option.

Not mapping shares. Not keeping the NAS access credentials stored on the computer (example Windows Credentials Manager). Limiting write access on NAS Shares. Closing down options like NFS and similar that may allow unrestricted access to the entire drive outside of Samba and other file server options that use username/password based access. Obvious issues with the single bay are the stupid Public Share that cannot be set to private without hacking/modifying the firmware. This is a very long running complaint that WD refuses to deal with. Other issues are the NFS. Some My Cloud models (like first gen single bay) may not have the ability to disable it through the Dashboard, user has to resort to hacking/modifying the firmware.

Run malware/AV scans often on both the local computer and NAS. If the NAS supports it, add an AV package (if nothing else, like ClamAV) to the NAS if possible. Usually the mid/upper level NAS devices will include AV apps to scan the NAS. Not sure if it’s even possible (easy or otherwise) to install ClamAV or similar to a single bay My Cloud running WD firmware. Downside is NAS based AV packages tend to eat up the processor/RAM when in use that can bog down the NAS.

And above all, lock down the local network, disable My Cloud’s FTP and Remote Access, use strong WiFi passwords, put IoT devices on guest WiFi networks with no intranet access and enable client isolation on the guest network. Turn off all unused features on the NAS. Close all ports that are not used on the NAS if possible. Among other things.

Various articles (many more out there):

https://www.ubackup.com/anti-ransomware/nas-ransomware-protection-4348.html

All good stuff.

For my money; my “main data” lives on a standard external drive. . .which is backed up to the NAS.
Every year or two; I buy a new drive and copy the data over.

  • Old drive goes into a drawer as a “archive backup”. Sure. . .ransomware might get the NAS. . .but much harder to get my old-drive-thats-been-offline-for-two-years. Even harder to get the four-years-ago drive.
  • Less likely a fresh drive will wear out before it is replaced by next year’s drive
  • 10 years ago, my “annual drive” was 750gb. Two years ago it was 4TB. This year 5TB. Capacity is keeping up with my ever expanding travelling archive :wink: Still only paying about $100 per drive. That’s without considering inflation (i.e. storage is cheap)

In addition, when I am away from home for extended periods (more than a day); the NAS drives tend to be powered down. Don’t need them running 24/7. Although I have configured VPN access to the drives; I don’t often access them in this manner. And I have gone through periods of time where internet access to the drives are completely blocked at the router.

Yep air gapping everything is one extreme measure to avoid/limit files from potentially being encrypted by ransomware or being infected by various malware/viruses. Of course this limits features and options of certain devices like being able to remotely access one’s home data. Of course one workaround is to carry around a hard drive containing all one’s data, but that comes with the potential of having said hard drive being lost, stolen or compromised.

There have been a number of discussions over the years of single bay My Cloud units getting infected, somehow, by ransomware. One example from last year:

Not clear in that case how exactly their unit got infected. Opening up any network device to the internet potentially runs the risk of possibly (how remote) being attacked by malware/ransomware/viruses.

The main problem with the single bay units is the first gen is no longer having security vulnerabilities in it’s firmware patched. And the second gen is currently on limited support despite getting the OS5 firmware. The single bay units don’t include (officially) any method of scanning itself for malware/viruses so one has to rely on a computer or other device on their local network to perform such a task. Most I’d wager don’t bother scanning their NAS for malware or viruses. There are probably some who don’t even scan their computer for malware and viruses.