Windows-10 cant see MyCloud drives?

I know there was a problem with SMB being turn off but I checked my setting and it is turned on.
I turn SMB off and reboot and then turned it back on just to make sure.
But I still cant see my MyCloud drives.
The drives show up in Twonky and I can access the drives setup login screen.
I just cant see the drives in file explorer.
They should be where the red circle is.
I can see the drives from my other computers just not this one.
So something must be wrong with the settings.
I have a NEW clean install of Win-10-Pro with the latest updates applied.

With SMB1 on, have you tried to shut down your computer and then do a reboot/start of your computer?

Yes , I tried that. I also enabled Netbios over TCP/IP for WiFi and Ethernet adapters.

If you haven’t already done so, see the other recent discussions on Windows 10 File Explorer not showing the My Cloud to see if they may hold solutions to your issue.

It appears some who are using the OS5 firmware are having issues with the My Cloud not showing up properly in Windows File Explorer.

Other troubleshooting steps.
Make sure the Windows 10 Network Profile is set to Private and not Public.
Temporarily disable any third party security or firewall programs and see if the issue continues.

Just map the drive - it will be accessible from file explorer (vs network explorer) in Windoze 10.