Wdphotodbmerger process on WD My cloud


#1

Hello,

Just like its predecessor, it looks like the “wdphotodbmerger” is keeping the drive from going into sleep.

All content scans are disbaled from the GUI interface. Yet this process is running.

I cant seem to stop it from ssh command line:

/usr/local/wdmcserver/bin# ./wdphotodbmerger stop
./wdphotodbmerger: error while loading shared libraries: libwdmcutil.so.0: cannot open shared object file: No such file or directory

Any ideas? Thanks


My Cloud disconneted itself from network
#2

Drive goes to sleep for me properly.  Are you running any software that might be backing up to the drive?


#3

thanks for the reply. 

Nope no software running. I dont have a lot of pic in one of my folders in the share…

I’ve modified the “Getvolume.py” so that it only returns that folder for the process to scan… Im not sure if that is working at this point.

Also the “transcode” process runs forever. I guess it could be running for this a this is the first run. I just go the drive yesterday.

i wont be using its itunes server, DLNA etc…

For now im goin to try to comment out the various transcoding related config in the  wdmc.xml and see if that helps.


#4

Forgot to mention, when the drive goes to sleep, the LED is still blue, it just has a “breathing” style so you’ll have to look closely to see if the LED slightly fades when it sleeps.


#5

yup i know… Actually its not even for the sleep issue… the “Convert” , “wdmcserver” and the “wdphotodbmerger” process take about 90% of cpu…

i’m a bit crazy when it comes to squeezing every possible resource from these drives… i dont want anything extra running on them… As these then affect regular file read/write to the drives from my home computers.

So thats why im playing around with these settings. I do need to be able to use the “wd photos” app to remotel access pictures but from one specific folder. hence the mods im making.

I had this stuff figured out for the mybook live drives as they used “media crawler”. The my cloud seems to be using something different.

thanks


#6

Based on what the convert process is doing, it is creating scaled thumbnails for mobile/etc browsing. Is there a way to disable this fuctionality? I have over 250,000 images I plan to store on the device and I don’t have a need for the thumbnailing to occur. 


#7

You can add the following in  crontab -e

works for me

@reboot /bin/sh /etc/rc2.d/S85wdmcserverd stop

@reboot /bin/sh /etc/rc2.d/S86wdphotodbmergerd stop