My Cloud disconneted itself from network

Hello WD Mycloud unhappy users,

I have the same problem, more or less; my internet connection at home often fails (at least once a day) and after that happens I cannot access wd mycloud from the outside (pc in my work) or even from my own pc in the same network/router, at home.

Led stays steady blue, but no access to dashboard or folders thru windows explorer, although I can ping it thru cmd by ip… this is a situation that cannot happen to me, since i usally loose isp connection thru the day I’m condemned not ever accessing mycloud from exterior, and while at home always having to unplug/plug it??

Any more ideas about this? I’ve not tried to use static ip option but I think that will do nothing…?

Thanks in advance.

I had the same problem , so i replaced the network card and the problem is solved .

After disable ipv6, please unplug and plug to restart the device.  

So far, my box has been working for over 72 hours without problem.   

soaptrail wrote:


illiniwek wrote:

For novices like me…

 

So I originally reported several failures with my drive, including the familiar “drive disappearing from network”.  It’s been over 2 weeks now, and I can happily report that my drive has been up and running nonstop with no issues.  Static IP, sleep mode off, etc.  I have a couple recomendations and a theory…

 

…Okay, now to my theory… Once I finally got the drive up and running, I copied about 700GB worth of data, using a wired connection.  Music, movies, documents, everything.  This was a long process, but I took my time.  I noticed that the “content scan” never seemed to finish and was bogging down the drive.  I assumed because i just moved thousands and thousands of files to the drive that it would eventually catch up after a few hours.  Not the case.  It took many many days.  And throughout that time the drive would frequently disappear from the network.  I tried resetting, factory restoring, etc.  Nothing helped.  To get the drive back i’d have to unplug and plug back in.  Then it would be up for a few hours before losing it again.  So I got frustrated and just let it alone…

 

After about 4 days of this the drive just… works.  Content scan is finished.  Files are all there, accessible, and no more disconnecting.  I assume this content scan is cataloging the files for faster file sharing, and if you throw a billion files at it all at once, it will take a LONG time to complete.  And in the meantime, the drive will be slow and possibly unresponsive. 

 

Maybe one of the more expert networking guys on this forum can comment on this?  The content scan seems to be at the root of the problem, unless you have a hardware failure of course (in which case you need to ruse that warranty).  Does this have something to do with the IPv6 thing someone discussed?  I thought I saw someone else mention something about a stopping a windows background process that conflicted with the drive’s content scan, can’t seem to find that message now…

 

Good luck everyone!


You might be on to something since I too had disconnects after copying 700+ GB last thursday and now the last 2 days i have not had any disconnects. The only setting i did change was to put this NAS as a static IP of 192.168.1.2.  With a dual core scanning the media should not cause an unresponsive box, but for several days the light was blue but i could not connect without a reboot.  And now i can connect without issues.  But 2 days is short so we will see if it continues to connect.

3 days later and I still have not had it disconnect, so I think for my instance it had to do with twonky scanning the drive after copying an enormous amount of data.

I have tried almost all proposed solutions outlined in this thread. 

Nothing resolves the problem. MyCloud 3TB frequently disconnects itself from the network and enters “deep sleep”. IP v6 is off, Drive Sleep is off, it has a static IP, even content scan is reported as finished now.

The only thing that prevent concurrent drive disconnecting (for now) is to disable several processes via ssh ( http://community.wd.com/t5/WD-My-Cloud/wdphotodbmerger-process-on-WD-My-cloud/m-p/605609/highlight/true#M252) but in this case I suppose DLNA and WD Photos won’t work.

I have remained connected continously for a week using a modified version of the crontab posted by Pavel in Message 71.  Pavel’s original crontab did not work for me for some reason but since I modified it to run a command every minute (rather than at 5 minute intervals), I have experienced zero downtime. When I removed the crontab as a test, the device disconnected after 3 hours. I reinstalled the crontab and have had no disconnects since.  

SSH into the device

crontab -e

#*/5 * * * * { /bin/date; export COLUMNS=300; /usr/bin/top -b -c -n 1; } >>/DataVolume/shares/Public/top.txt 2>&1
#*/5 * * * * { /bin/date; /bin/ps -ef; } >>/DataVolume/shares/Public/ps.txt 2>&1
#*/5 * * * * { /bin/date; /bin/netstat -a; } >>/DataVolume/shares/Public/netstat.txt 2>&1
*/1 * * * * { /bin/date; /sbin/ifconfig; } >>/DataVolume/shares/Public/ifconfig.txt 2>&1

 I simply commented out 3 of the 4 lines of Pavel’s original crontab, then changed the timing of the last line to run every minute. 

Just wanted to add my experience. I purchased a My Cloud about a week ago, and had the same issue. In my case, when the My Cloud did show up on my network it was by IP address only. So in Windows Explorer I could only browse to it by IP. I started moving files to it, and it would disappear from the network after about an hour.

After reading this forum, I gave the device a static IP on my router (Netgear WNDR3700v3) and reset the router and power cycled the MyCloud. Since then, I’ve been up for about 36 hours now without disconnecting. I can also browse to the drive by name now instead of just IP.

I also disabled IPV6 on my desktop machine. I doubt this had anything to do with fixing the issue, but thought I would include this just in case.

This seems similar to a problem I had with a Samsung wireless laser printer that kept disappearing from my network. I gave it a static IP and that solved its problem as well.

I hope everyone else is finding a fix for this issue on their network. I did log a ticket with WD, and then told them I was able to fix my issue by browsing here.

Yesterday I returned after being away for 4 days, with all computers on the network turned off. The WD was still connected. For me the problem seems adequately resolved. Now onto figuring out how to get direct remote access. :slight_smile:

The changes I have made since it last disconnected is:

  1. Turn of the HD disk sleep.

  2. Set up a once a minute crontab:

            • { /bin/date; export COLUMNS=300; /usr/bin/top -b -c -n 1; } >>/DataVolume/shares/Public/top.txt 2>&1
            • { /bin/date; /bin/ps -ef; } >>/DataVolume/shares/Public/ps.txt 2>&1
            • { /bin/date; /bin/netstat -a; } >>/DataVolume/shares/Public/netstat.txt 2>&1
            • { /bin/date; /sbin/ifconfig; } >>/DataVolume/shares/Public/ifconfig.txt 2>&

I faced this issue as well and created a script that checks local connectivity and restarts networking if it looks down. Scheduled it to run every 2 minutes, and no problem since 48h. Let’s wait and see in the long run

#!/bin/bash
up=`ping -c 1 192.168.1.1|grep "1 recei"|wc -l`
if [$up -eq "1"]; then
echo up
else
echo down
/etc/init.d/networking restart
date >> /nfs/Down/restarts.txt
sleep 120
fi

Well, after a few days without problems, an hour ago, when copying files from my PC to mycloud, I got an error message in the middle of the process (copied about 5 gb of 40).

So I went and check and voilà no access to dashboard or folders thru win explorer. Rebooted drive by the plug and I now have access to dashboard BUT NO access thru win explorer… in the configurations settings it says “no internet connection”.

So… I can access mycloud by dashboard but cannot use it by any other way.

Bravo WD, I have to say that you have disappointed me very much and I’ll definitely not recommend you in the future.

PS: Went to sleep and left mycloud disconnected; today morning after 8hrs… It’s working like this never happened. This is just ridiculous. Oh and it can’t be a temperature issue since I have it in a room at 15ºC/59ºF and it’s on top of a a TV table with nothing covering it, so go figure.

I am having the same problem from a My Cloud 4TB which started 3 days ago.  It has stalled/gone to sleep twice since then and is not pingable on the network IP is static, DNS set with A record. Recovery is via unplug/replug.  This unit is only four days old.

Firmware:  v3.01.04-139

Sleep: Off

Network summary:

Cisco Cable Modem

Netgear Router

1 Windows 2008 R2 Server

1 Ubuntu 13.0.4

2 Netgear Gigabit switches

1 MyBook Live 2Tb

4 WD TV Live Plus

3 Dell Laptops (windows 8 and 7)

1 Mac Book Pro (OSX)

1 Homerun TV

2 Nexus 7

4 Android Phones.

oh, and 1 WD (4TB) My Cloud as the new addition.

Never had an issue with anything else.  Seriously considering returning this unit.

I just want to add that I tried the cron job solution with it running every 5 minutes or every 1 minute, it doesn’t work for me. If you did not load much data returning it is the best option.

I am disappointed that with such an obvious problem affecting so many people nobody from WD said anything, or indicate a future fix.

Yes, I am receiving emails about other WD devices are on sale, good marketing, but no more!!!

Every morning I wake up, I find MyCloud disappeared from my network. The only way to get it back is unplug the power cable, detach MyCloud from router and then plug and attach again. If I have to do this every morning then it is not really a ‘Cloud’, better I could have gone for a traditional hard drive which would atleast be accessible(not over the internet) if connected to my laptop. I have made it static ip and reserved that IP in router DHCP. Let’s see how it goes.

I am surprised on how can WD be not concerned about this issue even if so many users are facing this.

I was having the same daily network disconnect problem until I manually re-installed the latest firmware (the same version it was already running). The drive has now been up for over 2 weeks without any issues.

DHCP IP address.

Drive sleep on.

Firmware download link:

http://www.wd.com/wdproducts/updates/?family=wdfmycloud_s

Update - 3 hours after static ip change, MyCloud disappeared again! WTH!!!

I had a my book world dropping from the network so I thought maybe it was getting old so I bought My cloud and now having same problem with it. Thinking of returning it and giving up on WD. Anyone have suggestions on a better network hard drive?

Thanks to you all, as I’ve had the same problem, and been following the posts. I spent the better part of 4 hours with WD help folks and I have to say they really hung in there to help me with the situation.

Bottom line, while they didn’t find anything in my network that was set incorrectly the “FIX” that has been working for me (the WD MyCloud hasn’t disconnected for more that 5 days) follows.

Determine the MAC address that shows for my cloud in your router settings (cmd prompt then type in arp -a. Find the IP for MyCloud IP and record the MAC address.)

Plug in your WDMyCoud direct to your computer…Not through the router.

Find out the assigned IP address (cmd prompt then type in arp -a will show the MAC address to compare and then look up the assigned IP address) the WDMyCloud is on and type that into a browser (It likely is a 169.x.x.x IP address). You can determine the IP by comparing the previosly recorded Mac address that showed on your router setting and seeing what IP has been assigned…something like 00  90  A9  X   X   X

After typing in the IP into the browser The MyCloud dashboard should come up.

Check and corrrect, if necessay, all the orginal set up intructions that were requested in the original set up instructions.

Go to the Settings tab; click on the Utilities box: Select Shutdown.

When the drive completly shuts down reconnect it to your router and unplug MyCloud. After a few seconds replug the drive back in and wait for it to start up and reboot (blue light comes on).

Hopefully this will be the complete fix as it was on my drive…

Let me know if this helps any of you out there that are having trouble.

1 Like

I noticed a new firmware update today that claims it “Resolved issue of drives randomly losing connection to the network.”

http://www.wd.com/wdproducts/updates/?family=wdfmycloud_s

Anyone give it a try? Is this problem finally resolved?

I’d be facinated to know what the cause/fix was.

Today is the first day since I got the device (~1 week ago) that it stayed on the network beyond 24 hours and I thought I should comment.

I found that on my home LAN the router (netgear and 2nd netgear AP) was allowing two devices to get the same IP.  In my case it was an android phone and the WD MyCloud server.  I think the phone had it first, went to sleep and it got assigned to WD.  When the phone reconnected the server had trouble.

The change I made was to assign a fixed address to the WD server that was at the high end of the range  of DHCP addresses where the router basically never assigns to anything else.  Hopefully that will prevent the double assignment and avoid the problem.  I’m not sure anyone else’s disconnects were caused by this but it seems plausible.

I will update the firmware tonight as well.