My Cloud disconneted itself from network

I thought I had the system up and working fine.  Win 7 (64).  It was on my wired network and I was able to access it remotely from another computer at a different site.

That was last evening.

In the morning, I tried to access it from the remove site and it could not be found.  At the wired site, when I bootup up that computer, it was disconnedted from the network.

I turned My Cloud off and restarted and it then was availalbe on the network again.  I have just update the firmware to the new version.

Anyone know why My Cloud should just go off line? (blue light was still on on wired computer).

Also, when accessing remotely, I was forced to install JAVA, and kept getting JAVA error warnings.  Using WD’s software to access worked fine.

this problem seems to be associated with the ipgrade. see the other threads. Is power cycling without shutting down safe??

Same problem here.    

Have been using the My Cloud about a week.  Use is light, a hour or two a day over a wired network.  The “disconnect” has happened twice.   Latest time today.     The indicator light shows a steady blue.  The My Cloud is not accessible for data from Windows  or for control (“dashboard”) by IP.

What to do?   No way to talk to the My Cloud.    No power switch.

So…  I pull the power and then power it up again. 

Comes up to “blue” status in a minute or so. 

My Cloud appears “as normal”…     until the next time it happens.

The My Cloud won’t be usable by me unless it can go 24 x7 indefinitely.

Thanks for any light you can shed.


Having the same problems.  I had an issue yesterday with a USB drive not being recognized for 3-4 hours (it finally showed up after I spent 2 hours with support, only to be transferred to WD’s “Level 2” support, after which it suddenly and mysteriously appeared).  Then, the WD My Cloud (WDMC) disconnected completely.  It randomly disconnects from the network.  And, most of the time, when I hover over WD Quick View, it shows the drive but shows 0% used (not true) and temperature “unknown.”   This sporadic behavior - in addition to the incredibly slow transfers - have me on the verge of returning the unit.   I wanted it to work, but there’s only so much frustration I can take.

I find turning off the sleep function keeps it live - must be an issue with the new firmware!

Is it possible to wake the unit from sleep remotely?   Now I can’t access it out of the office.  I get an error message - “cannot connect to the device.”

Don’t let the sleep function confuse you.   The Sleep function doesn’t put the whole system to sleep – it only instructs the disks to spin down.

It’ll be interesting to see what turns up on this issue – mine has been online since the day after the last firmware launched and hasn’t disappeared… 

 08:28:07 up 17 days, 21:16,  1 user,  load average: 3.04, 3.35, 3.62

I just went back to the office, opened Dashboard, and disabled Sleep.  Dashboard indicated that everthing was ok.  Quick View would still not show the % used or temperature.   At home, however, I still get an error message when I try to connect.  I hope WD is monitoring this, because the ability to access the drive outside the office is is kind of important to a cloud drive.  Right now, it’s just a very slow performing external hard drive.

I rebooted the router and the My Cloud device to get it back online.  Then I went into settings on the browser and disabled sleep mode and it’s been up ever since.

I also disabled the sleep function and it made no difference as it shut down after about 6 hours. I now have problems with the USB. USB2 hard drive no problems. USB3 Western digital drive cant copy files to or from it as it says access denied. password required (none set up though) USB3 Hitachi drive recognised but size given as zero with zero free.

sorry but I have now totally given up and returned the drive. Very dissapointing as always had good devices from WD in the past.

Yep you’re right - it did disable itself again after a few hours even with the sleep function off!  Are WD going to fix this issue or shall I return it?! I only bought it on Friday!

Did you try accessing the Dashboard via IP? 

I did.  Doesn’t work.

FYI, apparently you can’t access the Dashboard remotely.

I thought my error message might be attributable to upgrading to Windows 8.1.   I uninstalled the drivers and WD software, and reinstalled WD My Cloud.  I also created a new user account for my laptop.   I was able to log into the new user account on My Cloud, but still get an error message when I try to connect to the device.   I’d love to spend another 2 hours on the phone with WD tech support, but my flight boards in 20 minutes.  Anyone else having this problem, or any success resolving it?

The only way you can access the drive remotely is through

You have to be on the same network if you want to access the Dashboard or the shares locally.

Hi BuzzLS, please check your private mesages. 

My unit just started doing the same thing.  Have you found any solution?



Well, hmmm. Mine just did the same thing for the very first time.

Wouldn’t ping, no SSH, no UI, no nothing…

I have no solution but can relate my experience.

I’ve had the My Cloud for a month.

In the first week the disconnect happened 3 times.

Since then, no recurrence.  No disconnects.

After the first week, WD opened a ticket, but…  has provided no help or information.

Since things have been OK, I haven’t pushed.

My guess.   It’s a DHCP issue. 

Somehow the router or the My Cloud doesn’t renew the IP address assigned to My Cloud .

Once the router “loses” the IP address, no way to talk to the My Cloud.

It’s a guess.

Why did the problem go way for me?    Don’t know.

I had the same problem and tried several things.  Now I THINK I have eliminated the problem.  I directly assigned the IP address rather than DHCP.  I think perhaps my wireless router lets the address drop out if I let it rest a while unused and then it is no longer seen by my system.  Really not sure what I am talking about but after days of issues everything now seems to be fine.  I no longer lose contact after a brief idle period.  It worked fine all day yesterday.

I gave it the same IP address the system had assigned to it, I just changed it to static.