iPhoto MyCloud Fail - Any ideas?

I really want to like my 4TB WD Mycloud, I really do.  

It doesn’t seem to work, It doesn’t seem to work for me and it doesnt seem to work for most of us on this user forum.

I haven’t owned it for that long, but one of the things I wanted to do was to create a copy of my 150 GB iPhoto library in a share on the MyCloud drive.   I have tired connecting my Macbook directly via an unfettered GB Ethernet connection as well as a directly USB drive attahced to the MyCloud.   No matter what, the copy process is brutally slow and it always fails after 5+ hours and only 4GB later.  Yet I’ve copied the same150 GB to a USB drive in about 30 min.  

Ive tried using SSH terminal to do a direct copy in linux, tried reformating the machine, tried trouble shooting with the WD techs (total failure) etc etc ec -  Like many other customers, I have wasted a considerable amount of time trying to make the value proposition of this product come true.  I wish I had read this forum before I put my money down.

I wonder are there any options to extract  some better value here?  Anything I can do to hack this thing and use the drive as plain jane storage?  

Any ideas?




Are you copying files from open iPhoto application to the MyCloud share?

I also had issues with the speed on MyCloud 4TB system, I was also getting the same issues you have where it freezes almost.

I removed everything , then did a FULL factory restore, then copied everything back.

I now get speeds from MacBook Pro 2012 of 30MB/s if I copy photo albums from within iPhoto to the MyCloud share.

On Windows 8.1 over gigabit I get copy speeds over gigabit lan of average 60MB/s up to 90MB/s since the Factory restore.

In an SSH session run the commands below, this will stop the thumbnail and photo indexing

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable