WDMyCloudEX2 in Windows Explorer Issue

My Win7 desktop is now showing our WDMyCloudEX2 only under the Storage section in Explorer, where it used to also show under the Computer section.  My mapped shares still work, tho I don’t want to have to map a drive for every share on the NAS.  Looking in the Device Manager the NAS is under Other Devices, identified as ‘2-Bay Personal Cloud Storage’, with the typical “!” icon, and device status of no drivers.

Any thoughts as to why I no longer see the NAS under the Computer section in Explorer?  I’ve tried rebooting the NAS to no avail, and I still see the NAS correctly from other PCs in the house. I’ve removed the NAS from the Device Manager/Other Devices, but it just comes back after rebooting


Hello there,

Try to verify if there is any firewall software that could be making the unit not show on windows explorer, you can also try to setup a static IP on the unit to see if this helps. You can also try to reset the unit by pressing the reset button on the back for 3 to 5 seconds.

Here is a link that might help with the reset process:

Here is a link that might help you setup a static ip:

Hi ArMak,

Thanks for the suggestions.  I have already tried resetting the NAS, and I’m also running a static IP.  I’ll take another look for configuration or software that might be interfering.