Everything working except WD My Cloud not showing in Windows Explorer

Hi all

I have an odd circumstance where everything works with my WD My Cloud except it showing under the Network area of my Windows Explorer.

As I said everything else works, so the shortcuts on my dashboard work, it shows up under “This PC” in Windows Explorer as a Media Device, my sonos speakers can play music off it, etc.

I can put in the IP in Windows Explorer and it then shows up and I can use it as a normal network drive folder but then it never stays after a computer reboot. I can’t seem to map it either as a drive, only lets me map sub folders.

I’ve tried standard troubleshooting, re-booted everything, read what I can on this forum but the odd thing is everything else works!

Thanks for any help you guys can give!

Hi, welcome to the WD Community.

Have you checked the network services and file and printer sharing?

Hi, thanks for the welcome!

Everything is on as normal default settings apply (assuming you were meaning going to advance settings of the network in windows and make sure file and printer sharing is ticked to on, etc?).

Any other thoughts?

Thanks for your help!


Sorry for the bother, rebooted the router last night and this time it worked, unsure why it didn’t before.

Thanks all.