"WDMyCloud is Missing" in WD Sync -- Won't Synchronize

I just installed WD Sync today in hopes that I would be able to use it to remotely synchronize my laptop with MyCloud. To be clear, my laptop is with me in one state, and my MyCloud device is at my home in another state (so they are not on the same network).

Yet when I specify sync folders, and then look at the menu for WD Sync, I see the message below indicating that WDMyCloud is missing, and it does not appear to be syncing (even though I have the option to pause).

Does anyone know what’s going on? Is WD Sync able to work remotely? It seemed to recognize my MyCloud (that’s how I was able to specify which folders to sync), so I’m confused as to why it wouldn’t be syncing as expected.


“WDMyCloud is missing” generally means the device cannot be reached by the laptops current network location.


From your laptop, are you able to connect remotely from wd2go.com (My Cloud - Web Files) using a network browser?
What about your mobile device using MyCloud mobile app?

If not, the local or upstream network (antivirus, malware, firewall, ad blocking, end point protection software or router, ISP) could be filtering or blocking port traffic.

Samuel Brown
If not, the MyCloud could be offline.

Yes, I am able to connect and browse my MyCloud files via wd2go.com on Chrome. I can access MyCloud via my mobile app as well.

I’m running Windows 10 with the latest updates, if that’s helpful.

The device is clearly online. I’ll check firewall settings, but since I have no problems accessing the device other ways, I doubt this is the issue.

I have checked firewall, antivirus, and malware settings, and there should be no issues there. I can’t say anything for ISP issues, but given that I can access MyCloud other ways, I don’t think that should be a problem.

I’ve restarted my computer and disconnected and reconnected to MyCloud in the WD Sync app. I can at least get that far. It’s clear that the WD Sync app is able to recognize my MyCloud, it just doesn’t seem to connect when trying to sync – I’m still getting the MyCloud missing message above.

Is there anything else that could be causing an issue?

Same problem for me…


1 Like

I just tried on a different network to no avail. What’s going on?

I’ve had this MyCloud for almost two years now, and it has been nothing but frustration since the beginning. I was really hoping that WD Sync would finally make the device function as advertised (remote backups), but apparently not.

1 Like

I concur with your feeling @Jeff_Hart I too have had a lot of problems with my NAS drive. I have to constantly rebuild my content database, but that only lasts for a few hours.

@SBrown my unit is online and can be accessed via the mycloud.com site, android app (tablet and phone), plus the WD My Cloud windows app (v I’ve already ruled out (antivirus, malware, firewall, ad blocking, end point protection software or router, ISP) since I rebuilt the database before leaving for my office. I was able to sync between three devices from 07:43 to 11:13. I waited until 1:43 PM to update my test document from phone, then was unable to sync to laptop.

Currently displaying “WDMyCloud is up to date”

Windows 8.1 Pro
Norton Internet Security with rules to allow WD software

A follow-up question:

Since it’s clear I’m not the only one having trouble, could it be that it’s just the latest version of WD Sync that is causing issues? Did anyone have success with remote syncing with an earlier version?

I fixed the “WDMyCloud is missing” in WD Sync by going to WD Sync settings, removing my device and adding it back afterwards. Perhaps, I simply got lucky, but I had tried a number of other approaches (resetting, etc.) and nothing had worked

@Miguel_Leon I tried that a few times already with no success, but I just tried again, and now I seem to be experiencing a different problem.

When I configured the folders after disconnecting and reconnecting my drive, I added a test folder with one file on my laptop and had it sync to another newly created test folder on my MyCloud. The status menu says that the MyCloud is connected, but it says MyCloud is up to date. However, when I check the folder via the MyCloud webpage, the folder exists (so I know WD Sync was able to connect to create the folder), but no files have synced. I also added a file to the WD Sync folder, and that failed to sync as well, even though WD Sync seems to think MyCloud is up to date.

If I close out of WD Sync and restart it, however, it just gets hung up on “signing in” – it’s never able to sign in and start syncing again.

Since I did what I described in my previous post, I have created folders, shut down the drive and restarted it again, etc. and everything, as I write this post, seems to be OK. Given my experience with this piece of junk however, I am just bracing up for the next problem. Bottomline, this piece of equipment is totally unreliable.

1 Like

Finally got it working (for now)!

I had to disconnect the device in WD Sync, power down and restart the device, then reconnect it in WD Sync. I’m hesitant to quit WD Sync and open it again for fear that it won’t connect again if I do that. But for now, it’s working.

This worked for me too! I was getting the “WDMYCloud is Missing” from WD Sync and after reading this post, I did what @Miguel_Leon suggested. I removed the device from WD Sync, restarted my device and then added it back to WD Sync and it seems to be syncing now. Thanks!

I’d like to know if 6 hours later the same thing happens. This is what is the message from the device to the client. Notice in the date it is just over 6 hours between. I was sleeping in that time so nothing was being done by me.


HTTP/1.1 200 OK
Date: Wed, 18 Nov 2015 07:02:35 GMT
Server: Apache
Vary: Accept-Encoding
X-Orion-Version: 2.7
Content-Length: 248
Content-Type: text/plain; charset=utf-8
Content-Language: en

            "path":"/{userName}/WD Sync",


Failure when you get {deviceName} is missing

HTTP/1.1 400 Bad Request
Date: Wed, 18 Nov 2015 13:13:38 GMT
Server: Apache
X-Orion-Version: 2.7
Content-Length: 125
Connection: close
Content-Type: text/plain; charset=utf-8
Content-Language: en

      "error_message":"Error in DB file location"

I’m having the same problem once again as well. I’m not sure how much time elapsed between success and failure, but I was at least able to back up my most important files.

While backing up, an error did come up with some files indicating that I would need to rebuild the content database.

When I checked a few days later, I saw that WD My Cloud Missing message again. I haven’t tried restarting the device or rebuilding the content database since then. I suspect that when I do, the error will go away for a time, but then come right back.

Thanks for the junk software, WD!

1 Like

Just a suggestion… WD Sync isn’t the only free sync tool in town.

@cpt_paranoia I would, but that won’t work with WD MyCloud, will it?

My whole aim is to do remote backups to MyCloud. I expect it to function as smoothly as Dropbox and similar cloud services–chose what folders you want to back up, and leave the rest to the program. If the tool you shared can do this, I’d gladly use it instead of WD Sync.


@cpt_paranoia I think the point is this. WD is claiming to have a cloud drive, but lacked true syncing features like DropBox, OneDrive, etc. The WD Sync is promising to fill that role, but is not doing that effectively.

There is always the push from leadership to deliver. It sometimes doesn’t matter if your release is ready. Case in point Adobe’s release last month with Lightroom that they had to do two quick releases to address major bugs.

Even WD had the same issue after rolling out the OS3. You have to release stable software and not have major bugs. Since we are humans, nothing we create will be perfect.

@snakedoctorunit Yes, I think you’re absolutely correct.

My complaint against WD is that I expected genuine cloud functionality from MyCloud when I first bought it nearly 2 years ago. Here I am 2 years later still waiting for the product to function as advertised. That’s simply unacceptable service.


Sorry; I was simply suggesting an alternative for some users. I don’t use it for remote backup or sync, but I note that it supports SFTP, and appears to be able to use this to operate remotely. It may be worth investigating (I won’t be, as I have no need for remote backup).

It can certainly allow you to specify which folders you want to backup/sync/mirror/version and where.

As for WD’s failings; yes, I accept that the MyCloud doesn’t live up to the advertising headlines, and the software isn’t robust, and I’d like to see them fix it. But I’ve given up waiting, and have looked elsewhere for solutions for my needs. It’s not as if I’m a WD apologist…

The only WD software I use (other than in the device) is the Android MyCloud app for remote access. And that’s not working properly for port forwarding mode for one of my devices. Relay mode on pre-OS3 device; yes. Port forwarding on an OS3 device: no. Still trying to get to the bottom of that.