WD Sync not syncing chosen folders


I am using WD My Cloud in Mac OS X (Yosemite). Trying to use WD Sync to actually sync selected folders within my username folder. It does not sync or upload anything at all.

It only uploads data when during installation I select one of the default folders as: Documents, Pictures, Movies… in the given options. When after installation I try to add new folders, it does not work

Anyone having this issue? any solution?


1 Like

You are probably experiencing the same issues as I.

Try to launch Console application and click on ‘All messages’ at the left side, and then enter WD Sync in the search box on top of the log window. 

If you see messages like ‘Error requesting metaDBInfo’ you need to rebuild your content database.

Log into the admin interface of your MyCloud device and there should be an option in Settings/General/Cloud Access/Configure to rebuild the content database. At least on EX2 (dont’ know about other devices). That fixed it for me, but not for long - looks like the database is very unstable and breaks every day. Unusable until they fix it. Support has already passed my data to the development team, hopefully they will release a new version soon.


Thanks a lot for your answer. 

So I understand WD Sync is not usable yet until official notice. 

Well, it may be usable for you. My feeling is that it depends on the number of files in the folders you synchronize. I sync fairly large folders with all my documents and photo library - as far as I remember those folders combined have more than 50,000 files. It may work fine for smaller folders.

Thanks for this - rebuilding the Content Database fixed this problem for me. Good shout.

WD Sync is also not working when applications wdmcserver and wdphotodbmerger are not running on WDMyCloud device.

I noticed after 6 hours the content database has to be rebuilt again. Is yours still working since 10/24/15?

@snakedoctorunit Mine has been successfully running now for probably a month now, not missing a beat. I consider myself one of the lucky ones.

I’m jealous

I chip in my 2 cents…
I had the same issue with WD Sync not doing its job… I have been testing it since beta stage, so I know the guy, and I must say it rarely failed me… but today it did!
I tried to think what I did wrong… I have just updated windows 10 to build 1511, so I though that was the problem… but it was not.
Just few minutes ago I realized that today I turned ON the option “Make USB content available” in Cloud Access (under settings-general). I went to turn it OFF, and voila, WD Sync was back to normal business!

1 Like

Ok, still seems like a bug they are not able to trace down fully. I have that setting set too. The WD Sync app on Windows communicates to the NAS via the RESTful API. Here is a good transaction followed by a bad. It has nothing to do with the operating system since this could be replicated with other development tools.

My tracing shows it is consistent in the metadb_info resource. Notice the six hour difference.

HTTP/1.1 200 OK
Date: Wed, 18 Nov 2015 07:02:35 GMT
Server: Apache
Vary: Accept-Encoding
X-Orion-Version: 2.7
Content-Length: 248
Content-Type: text/plain; charset=utf-8
Content-Language: en

            "path":"/{userName}/WD Sync",


HTTP/1.1 400 Bad Request
Date: Wed, 18 Nov 2015 13:13:38 GMT
Server: Apache
X-Orion-Version: 2.7
Content-Length: 125
Connection: close
Content-Type: text/plain; charset=utf-8
Content-Language: en

      "error_message":"Error in DB file location"

I believe my issue has to do with the content in my public and user share. I have a mix of photography (jpg, nikon nef, psd, and tiffs), videos (mp4, mov, etc), documents, archives, iso images, source code (java, c#, html, css, xml, xsd, json, etc), software development tools, program downloads (exe included), and os level backup images.

I’ve noticed there is some file type that is corrupting the database. I just have not isolated yet.

Hello nicolazippa,
perfect solution, which you described. I had the same issue, which you had: WD Sync stopped doing it’s job at 31 of 35 GB content. After turning ON the option “Make USB content available” in Cloud Access (under
settings-general) and then turning it OFF again, WD Sync was back to normal business!
Thanks a lot for your clue :-))

Do I need to do anything else but rebuild database and turning off USB content availability? I rebuilt database and USB function was off, but WD Sync is still not working. I wonder if I need to restart or reinstall anything.

Try removing access via the “Cloud Access” under the profile. Delete the existing device access where you see “WD Sync”, then setup the connection from the client on your computer.

Make sure you’ve updated the firmware and WD Sync software if you have done so recently.

It seems it’s working. When I tries con connect through WD.com i does not work properly.

Thanks a lot

It works for me! Thank you very much for sharing your experience!

I am facing the same problem but on my Windows 10? Any ideas please?

Thanks! The rebuild seems to allow the sync to start working again. However, the solution doesn’t seem to “stick” for me. Does anyone else have to do frequent rebuilds to keep WD Sync working?

HI I tried it it didnt work , so i called the WD support and they he told me that they only support one way sync(whatttttt?) , its too bad.