WdMyCloud device not responsive

I have a single drive 4tb mycloud device. It was functioning just fine until recently. The last thing I did was transfer ~5gb files to it over wired connection. I believe the transfer stalled without finishing.

After an inability to access I powered down the device then the front led turn solid yellow. It eventually turned blue after 10+ hours but I could no longer access the device in any reasonable amount of time.

I performed a 4 second reset and a 40 second reset but still have trouble accessing it. I tried a different cable (known functioning) but still nothing changed.

When the led finally turns blue, I try to access it through it’s IP address. After entering in the IP it spins for 10 minutes before bringing up the default page saying “Reading configuration information…”
Sits there for 10 minutes.
Then brings up the set up page. I enter a user in and after a bit it finally updates.

I’m able to get to the settings but most of them are greyed out and non-editable. Changing something that is editable, such as “Drive Sleep” to off, changes it but sits at Updating for as long time. 5+ minutes.
I’ve tried rebooting. Sits at “Updating…” and never finishes. Gave it 2 hours.

The device also says “Offline” when signing in through files.mycloud.com
It does not show up through Windows Explorer.
The windows application shows the device found in my network. But after selecting connect, it brings up the sign in menu. I cannot enter a Name, nor select one. Clicking Sign In does nothing.

How can I get this device back to functioning normally?


The WD Desktop application no longer works with the My Cloud units and has been rendered end of life (back in 2016) by WD. Recent firmware upgrades to the My Cloud over a year ago broke access to the My Cloud using the Desktop application. WD Support Knowledgebase articles on the Desktop app:

Has any change been made to the local network? New equipment/hardware added, new or replacement router, new broadband provider, etc.?

Couple of troubleshooting steps. If using Windows 10, ensure SMB 1.0/CIFS is enabled.

Make sure the My Cloud is directly connected to the local network router. Avoid using powerline or similar devices to have the My Cloud in some other location that is not directly connected by Ethernet wire back to the network router.

Access the network router and see if it lists the IP address that it has handed out to the My Cloud. Use that IP address (if you haven’t already) to try and access the My Cloud Dashboard.

Disable any web browser add-on’s and third party software security programs as a troubleshooting step when attempting to access the My Cloud Dashboard. Try also using a different web browser.

Another basic troubleshooting step (if you haven’t done it already). Turn off all network equipment including computers, My Cloud and local network router. Then turn on the network router and wait for it to fully boot and establish a network connection. Then power on the My Cloud all by itself and wait for a solid front blue LED. Then power on one computer and after it finishes boot up attempt to access the My Cloud Dashboard and see if issues of access persist.

Thanks for the information and troubleshooting steps.

I will no longer try to use the Windows application. Not that I did before, this was more of a last chance to connect…

No new equipment or hardware has been added. ISP has not changed either. However I was transferring over wifi from a laptop, let the transfers finish, then switched to wired for the laptop and did the other transfers.

SMB 1.0/CIFS was not enabled for the laptop. I have enabled it and restarted the machine. The MyCloud now shows but same issue. Inability to view anything.

Currently the MyCloud and the laptop are the only devices connected via ethernet directly to the router.

The router lists the IP address for the WdMyCloud and I am using it in a browser to connect.

Firefox/Chrome/IE/Edge all have the same issue. Still persistent after disabling all extensions.

Powering down all devices connected to the router and letting the mycloud boot up alone did not seem to work either.

How were the file transfer’s being made to the My Cloud? Using Windows File Explorer or some other method like WD Sync or similar program?

Has any “unofficial” mods been made to the My Cloud firmware that are discussed in various other discussion topics here?

If one previously enabled SSH in the My Cloud Dashboard > Settings > Network then they could try using an SSH client (Putty, WinSCP, etc.) to access the My Cloud and temporarily stop the scanning services the My Cloud uses (or services that block the unit from entering sleep mode) and see if that changes anything. Example services to stop using SSH:

wdphotodbmergerd stop
wdnotifierd stop
wdmcserverd stop
restsdk-serverd stop

The files were being transferred using Windows Explorer. Going to use FileZilla in the future if I ever get this functioning again.

I’ll see if I can get the SSH enabled. I don’t believe it was but I cannot access Settings or update anything right now.

Windows Explorer is general often used as the term for Microsoft’s web browser (that has been replaced by Edge). Do you mean Windows File Explorer?

FileZilla is an FTP (and similar protocol) application. One may need to have FTP enabled through the My Cloud Dashboard > Settings in order to use it to transfer files to the My Cloud. One may not see the same (lower) transfer speeds using FTP than they’ll see using Windows File Explorer. Windows File Explorer is the default method for accessing the My Cloud on a local network. FTP is an insecure protocol (login information is not encrypted and can be intercepted) and is generally (in teh past) used for remote network access to a NAS like the My Cloud.

I was able to access the Settings and run some commands. Needed to add more to have them recognized.

/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd stop
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

Then after powering down and back up, the device was seeming to run fine. Everything was quick and seemingly back to normal. I updated some settings (turned off scans and itunes), Windows File Explorer had access and could jump through folders. That lasted maybe 5 minutes.
But now hit a crawl again, accessing through IP in a browser took 19 minutes to load the initial page.

Pulled up the twonky server page (http://wdmycloud.local:9000). And saw Rescan In Progress though.

image

Any other thoughts to get performance back?

The single bay/single drive My Cloud often will be sluggish as the media server (Twonky) scans media files. Especially if one has a large number of media files for the media server to scan. One can try disabling the Media Server and the iTunes server within the My Cloud Dashboard > Settings > Media.