WD My Cloud Randomly Stopped Working

Hi all. I can’t seem to find something specific to my issue in the forum.

I’ve been using my WD MyCloud device without any issues for the last couple of years. Over the weekend, I was watching some shows on my TV that are on the MyCloud device and I was uploading some new shows to the device too. Then, for some reason, it just stopped working. I’ve tried multiple power-down restarts where I’ve been able to log into WDMyCloud/ briefly, but then the page seems to freeze and WD apps show the drive as being ‘Offline’.

I have a solid blue light on the front, which seems like a good sign! I also have a blinking green light on the ethernet port. So everything seems to be working as it should and I haven’t made any network changes, but it just decided to ghost me! Can’t connect via my computer either. I upgraded to OS5 a few months back. I tried connecting it to a switch and plugged my laptop into the same switch too, but to no avail. Any suggestions as to what might be wrong?

Can you access the My Cloud Dashboard? If you can, what firmware is the unit running?

How to Access the Dashboard on a My Cloud Device

If your My Cloud device has been updated to OS5 there have been (many) reports of some My Cloud devices becoming inaccessible for periods of time due to the indexing the OS5 firmware does. WD’s suggestion is to disable remote access and Twonky to see if the indexing issue corrects itself.

My Cloud OS 5 Cloud Access Content Indexing FAQ
Best Practice for My Cloud OS 5 Cloud Access and Indexing

1 Like

AMAZING, thank you!! Disabling cloud access appears to have resolved the issue. I’m assuming that I should just leave this disabled for the foreseeable future?

It was a bit painful, I could only access WDMyCloud for the first 30-60 seconds of powering back on again before it froze. I was able to get a screenshot of the dashboard, just FYI, then the second time around I was able to disable cloud access.

Thank you again for the suggestion! I wasn’t expecting the resolution to be so simple :slight_smile:

Perform a reset of the WD My Cloud via the steps at this link. **Disable any software firewall applications on the PC Turn off all network devices. Connect one PC directly via Ethernet wire to the same router that the WD My Cloud is connected to.


If you don’t need remote access then you can leave it disabled if you want. Since you are using OS5 you should inquire in the OS5 subforum for any future issues you are having since that firmware is newer than the OS3 firmware that this subforum discusses. And you may want to read, if you haven’t done so already, the two previously posted links on OS5 indexing to understand what it does on your device and suggestions to dealing with indexing issues that are prevalent in OS5 firmware.

OS5 My Cloud

1 Like

I have the same problem - my MyCloud device randomly stopped working about a month ago - however I cannot access the MyCloud dashboard nor does my MyCloud device show up on my network. I’ve rebooted the drive, one of the ethernet lights is blinking. I believe the firmware was set up for automatic updates. I need to access my files, but cannot. How do I fix this?