WD TV Live Streaming Media Player, Windows 10, SMB v1 network protocol

#1

With the Windows Fall Creators Update (Windows version 1709), Microsoft is starting to phase out the SMB v1 protocol due to its security issues. Is SMB v1 being used by the WD TV Live Streaming Media Player to access media files on Windows hard drives (LAN sharing)? If so, without a firmware update supporting SMB v2 and/or V3, a Windows update to 1709 would brick the media player for me.

I am running WD TV Live Streaming version 2.01.86. The only media player function I use is playing media files on Windows 10 ‘servers’ using LAN file sharing. The media player at that firmware level has successfully processed all media files for many years with only one exception. The player does not map the surround sound channels of an audio file to the correct speakers. A workaround I use is remapping the original media files so that when they are processed by the player, the channels are directed to the correct speakers. I have not found another media player that will play as many varieties of video and audio files. I am sad that the device is no longer developed or sold and regret the day that my media player no longer does it’s job.

1 Like
#2

My main use of WDTVLive is for storing & playing back my pics, music, DVD & BluRay files without having to first fire up a computer. That function remains solid.

I have Wi-Fi / Ethernet issues which turned out to partially resolvable (re-terminated the Ethernet cable). Alas, I also have to disable Wi-Fi on my router to get an Ethernet connection (it always connectsWi-Fi even tho I manually enter the wired parameters.

Facebook is dead for me as is my YouTube logon. However, NetFlix still works - which was my main concern for firing up WDTVLive again (I finally bought a Rii8+ keyboard). Not sure if I will keep NetFlix.

Thanks for the insight…
Dieter

#3

If you don’t use the computer for accessing your media files, where are they stored? Are they on a USB stick, a USB attached hard drive, or a NAS drive. If the files are on a NAS drive, the WD TV Live Streaming may be using SMB v1 to access the drive. That relationship would not be affected by other operating systems dropping SMB v1 support.

Does anyone know what network protocol and version the media player uses to access LAN shares and a NAS drive?

I was happy to see that Western Digital did offer a firmware upgrade last year, the first in two years, in spite of the fact that the device is now ‘legacy’. The reason I am bringing up the fact SMB v1 is being dropped by many operating systems is in the hope that WD will add another supported protocol (SMB v2 or 3?) and offer another firmware upgrade to avoid their media players becoming bricks.

#4

I transfer all my media files to a USB drive attached to the WDTVLive. Thus I can play them back immediately without first firing up the computer (and I also have backup).

I am still able to log onto NetFlix - which means I can continue to use the unit for a while longer (I also had ae ethernet cable plug intermittent (which didn’t help). Although WiFi had been disabled for WDTVLive, when powering on it ignores my wired connection & goes for the Wi-Fi. To get around that, I have to temporarily disable Wi-Fi before booting up WDTVLive.

The best part? I had opened up a case to explain my problem. Seems they are unaware that you can’t log onto Facebook. What else can I say?

#5

Hi, I have the same issue, I have contacted WD support, they’ve said is Microsoft’s change.
I must say, there is SMB 1 in Windows features even after the last update. It is activated, but doesn’t work with WD anymore.
I can access my shares with an Android system if I instals SMB 1 feature only. I couldn’t find a solution so far. Still looking.

#6

Hi Everyone,

I too am now having a problem with my WD Live unit since my desktop computer updated to MS Windows 10 Fall Creators. I have tried everything to have my WD unit see my external drives with no success. It does see my computer and the files on it when I go to video media servers, however when I go to video network shares nothing happens.

I have gone through everything and checked shared files and made sure everything is as it should be, still no network shares.

Another thing that is odd, when I go to update device I get a msg stating device fails to check for new firmware.

Has anyone been able to find a solution or a jury rig fig fix to allow there WD units to see network shares?

I am surprised that WD themselves has not addressed this issue as I a sure it is effecting everyone.

Regards

Dave B.

Windows 10 won't run SMBv1 in My Passport
#7

Hi Everyone,

After trying endless ways around the windows 10 update problem when trying to see network shares on my WD Live, I just reverted back to an earlier windows 10 build. The WD now works as it should. I also stopped Windows 10 from updating itself until I hear and see on an update that repairs the WD issue.

Regards,

Dave B.

#8

When I discovered that the installation of Windows 10 Fall Creators update version 1709, could/would remove SMB v1 support, I came to this forum to determine what experience other WD TV Live Streaming Gen 3 and NAS owners had with this Microsoft update. Surely, I wouldn’t be the first and only WD customer whose Windows 10 was force updated by Microsoft. Searching the forum, I was unable to find any mention of WD customers who associated their sudden loss of LAN sharing function with both the Win 10 update, and the removal of SMB v1 support. There were reports of the ubiquitous issue of the WD TV media player no longer being seen on the LAN, but there are many configuration and operational reasons for that, the fixes for which have been documented in this forum for years. I tried to interpret the lack of WD customer concern and lack of problem reports. Did the WD media players support SMB v2 or 3, and my concern was a non-issue? Did the WD customer misinterpret the loss of connectivity as a simple LAN sharing configuration error or maybe a Windows computer browsing service error, that they would eventually fix? Or maybe the WD devices that I am interested in are legacy, WD doesn’t care if the will work or not, the customer accepts the failure, does not post in the forum, and has moved on.

(An aside: The Windows Computer Browser Service relies on SMB v1. If SMB v1 is turned off or not installed, the Explorer Network can no longer display Windows computers on the LAN. So… no SMB v1, the media player sees no Windows computers! No amount of configuration changes or Windows fixes is going to change that.)

Not finding a solution here, I emailed WD Customer Support. The WD TV Live specifications and device’s configuration menus make no mention of SMB and there are no options to turn of SMB v1 and turn on SMB v2 or 3. So ‘does the media player support v2 or 3?’ was the question. Surely the support staff had access to the player’s base operating specs and could identify if it included the SMB v2 or 3 APIs and whether or not the player automatically switched to whichever protocol was present. Their response was, and I paraphrase, WD hasn’t tested the player with SMB v2 or 3 and I could perform those tests if I wanted to. To the best of my knowledge, since there are no controls in the media player itself, to perform a meaningful test I would have to turn off SMB v1 in Windows 10 (run the risk that with Microsoft’s determination to protect us from SMB v1, it may never turn on again) and then use a network analyser to monitor the media player communication with the ‘server’ to see if the player makes any attempt to commect with SMB v1 or 2. I don’t really have the tools to do this effectively, and don’t think I should have to. WD should be forthcoming and tell their customers if their NAS and media players will turn into bricks with the Windows upgrade or provide firmware upgrades to avoid the problem.

Some history for those who are interested: SMB v1 was superceded by v2 in 2006-2007 and implemented in MS Vista. The WD TV Live Streaming Media Player 3rd gen was introduced in 2011, four years after v2 was introduced! SMB v3 was introduced in 2012 with Windows 8. Due to security risks inherent in v1, Microsoft publicly depreciated SMB v1 in 2014. The WD media player was discontinued in 2016. WD had five years to implement SMB v2 and 3! The had two years, since Microsoft depreciated the protocol, to include the protocols in the firmware upgrades! Since WD customer support hasn’t clarified whether or not the API for SMB v2 and 3 are in the base OS, let’s assume hypothetically that they aren’t. Then, why not? I welcome correction from the reader of the following ramble… I understand that the base operating system of the WD TV Live Streaming media player is Linux with an open-source implementation of SAMBA (SMB). I also read somewhere that an open source implementation of SMB v2 and 3 was not available until 2017. That shouldn’t have stopped a for-profit company from developing their own solution in order to implement a secure network protocol for their customers’ protection. They had five years to do it!

Another response that I have seen in this forum from WD customer support when confronted with LAN sharing failures, and I paraphrase, it’s not WD’s fault, Microsoft made a change in Windows!. Let’s put things into correct perspective: I did not look for the most versatile media player around, buy the WD TV Live Streaming, and then ask myself, hmmmmm I wonder which operating system should I install that is compatible with the media player? If WD wants to sell me a NAS or media player, they have to accept the fact that, for a reasonable period of time (e.g. until they discontinue the product line) they will have to update their firmware to maintain compatibility with Windows, not the other way around! In particular, if to address a serious security issue that Microsoft has publicly announced in 2014 they would address by removing SMB v1 from Windows, two years before the WD product was discontinued.

So for all those WD media player owners (and maybe NAS owners too) who are afraid their device will become a brick after the Win 10 Fall Creators update, consider Microsoft’s guidelines under which SMB v1 will be turned off/not installed:

https://support.microsoft.com/en-ca/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

In a nutshell, unless you are running Windows 10 Pro, you already have SMB v1 installed, and the wind is blowing NNE, installing the Fall upgrade, you run the risk of SMB v1 turned off/not installed/uninstalled after a time of unuse (flip a coin and pick a consequence).

Can you avoid this calamity. Well, if you have Windows 10 Pro, you can go into the bowels of the OS and turn on a setting that postpones the Fall update for a while, but eventually that will bite you in the ass. And for that duration, you accept that your computer will be at risk.

(This post has been edited to correct lousy paragraph formatting due to composing the post in a text editor and cut and paste into here.)

#9

Sorry, I got lost in all the details of this last post. Nonetheless, I have Win 10 Creator, and rhe install crashed my laptop in such a way that I was locked out of using my password to get in. On quite a few hour long plus occasions I had three different levels of support people from MS helping to remotely fix my laptop. After about 12 total hours during the week it finally was fixed, and as it turned out the fix was a rather simple one. So, I too am mighty ticked off at MS over this update as well. But, this is not the point of this post.

The point is, I do not have an issue with SMB1 or playback on my WDTV, because none of my media files are on the Win 10 – they are all on my WD NAS or on drives connected on the WDTV or on a drive connected to the Win 10 USB port. It’s not been made clear if people who are having issues are accessing media files ON the Win 10. If so, that could be the problem. All I can say is I do not have this SMB1 issue. Sorry you folks are having it.

#10

Hi, I have a dual OS installation, having at least one common share.
One OS is Windows 10 Pro Fall Creators Update, other is Linux.
While under Linux, WD TV box accesses fine the shares. Under Windows I have two scenarios:

  • The initial connection was established when the PC was booted under Linux, so, when I restart the PC to boot Windows, the WD TV box will stop playing. But I can go to the main menu, chose Music, for instance, and it goes automatically to the previously chosen PC ~ WD TV box does not ask to chose a new source ~ and displays the shares, playing the music with no issues.
  • The WD TV tries to connect to the network shares and the PC is already under Windows - then it could not initiate the connection. IMHO, this is the failing point. Other devices could access the shares, even Android phone having SMB v1 only. Could be some Windows/Third party firewall blocking. Can’t tell. Or could be only the SMB v1 connection initiation only…? Any ideas?

Note: I have Avast Firewall, I see there the rules allow the SMB connections. Also, media streaming is activated (I know it’s different protocol, but MS support site says that activating it will change firewall rules - I have successfully streamed before without activating this anyway… it’s crazy, isn’t it?).

#11

Update: I have looked in the Avast firewall network connection and I think the issue is related to the fact that WD TV needs to display some computer name to choose. I see lots of scans for the shares, it seems the computer responds to WD TV box, so WD TV tries to identify it and asks for the netbios name, that fails, so it tries again and again. I see lots of “netbios-ns unreplied” messages but I don’t know the reason yet. Keep looking…

#12

WD support suggested that I should feel free to do my own tests, which I have. The results of the tests suggest that the WD TV Live does not support SMB2 or 3 and therefore will no longer be able to access shares on a device without SMB1. For those faint of heart you can avoid my explanation and wait for the movie to come out. Others may persevere and stumble on tools and ideas that will shed light on other WD TV Live connectivity problems they may have.

An important consequence of the Windows 10 Fall Creator update is the loss or failure of the SMB1 master browser function. It is the master browser function that keeps track of computers/devices in the network neighborhood. It is the function that the WD TV uses to identify in the “Network Shares” window, those devices that are sharing files and folders. If the function is not working properly or not available, the WD TV cannot identify device names to select in the “Network Shares” window. If you can’t select a device in the “Network Shares” window, you can’t access the shares!

What I refer to as the “loss” of the SMB1 master browser function, is simply a result of SMB1 being deactivated or uninstalled from the device that is sharing files. The “failure” of the SMB1 master browser function is not as simple to explain. Some posts on this forum have reported that, after the Windows 10 Fall Creator update, in spite of the fact that SMB1 was not deactivated or uninstalled, the browser function did not appear to be working properly, that the updated code was somehow buggy and that if we waited long enough, Microsoft will fix the code. I haven’t been able to confirm that conclusion.

My LAN environment consists of two Windows 10 Pro desktops, a test pc that is also an audio media server, and a home production pc that is also a video media server. Both are are up 24/7. I also have a Windows 7 laptop that is turned on occasionaly. Any of these devices, when turned on, could potentially become the SMB1 master browser, keep track of the devices on the network and provide the WD TV with the device name and address. In the SMB1 network, in simple terms, when a device is turned on, the device announces its existence by broadcasting its name and address across the LAN. A pre-existing active Master Browser (say another Windows PC) will pickup and retain that information and make it available to the WD TV when you ask for source from a network share. To complicate things, if there are multiple Windows pcs on a network, they will negotiate periodically to determine which of the Windows pcs will take on the master browser function. If a master browser pc is shutdown, the responsibility is picked up by another Windows pc. To complicate things further, the WD TV Live can act as the master browser. (I understand some routers can also as master browser.)

Based on personal experience, I have learned that not all devices are created equally in performing the master browser function. Over the years, network connectiviy problems with the WD TV Live that I have experienced, had nothing to do with pc file/folder share permissions, firewall blocking, configuration errors, etc. It was simply as a result of the master browser function being passed to another device. For example, the most stable master browser is my Windows 10 Pro test pc, it has the longest up time. I have set parameters in the Windows pcs to default all negotiations for the browser function to the test pc. In spite of this, on occasion (e.g. a planned or unplanned shutdown of the test pc), one of the other devices becomes the master browser temporarily and when the test pc is restarted and becomes the master browser again, it does not have a complete list of all devices in the network (maybe the devices haven’t announced their existence). When I turn on the WD TV Live and scan for network shares, one or both of the pcs will be missing. The way I typically resolve this is by turning off all the pcs and the WD TV Live, turn on the test pc (my preferred master browser), turn on the production pc (to force an announce broadcast) and then the WD TV Live.

Now that I have demonstrated my understanding of how the SMB1 browser function works (and I welcome correction of any misunderstanding), I can explain my tests and what I think the results mean with respect to WD TV Live SMB1,2,3 support or lack thereof.

I decided that I was going to remove SMB1 from my Windows 10 home production pc with the video media shares. The test machine was up and acting as Master Browser. The WD TV Live was off. I turned on SMB1 auditing using the Windows Power Shell command “Set-SmbServerConfiguration –AuditSmb1Access $true”. Microsoft included this tool to help identify any devices on a LAN still using SMB1. A system log entry is created when a device tries to access shares on the pc with SMB1. The log entry identifying the device name and an explanation of sorts, can be found at “Computer Management : System Tools: Event Viewer : Applications and Services Logs : Microsoft : Windows : SMBServer : Audit / Operational”. I unchecked SMB1 in “Programs and Features”, and SMB1 was removed. The production pc was rebooted.

Observation one. Connections setup for auto connect between the production pc and test computer shares (and vice versa) were not effected; however, as expected the “Network” neighborhood function of the Windows File Explorer no longer displayed the test computer in the “Network” tree.

Observation two. The WD Live TV was started. The “Network Shares” menu initiated a request for device names on the network and the master browser was still aware of the production pc and its location (a more accurate way of putting that is that the master browser had not forgotten the name and location in spite of the SMB1 uninstall and reboot). Selecting the device name in the WD TV Live “Network Share” menu resulted in a user name / password error. This suggested that the WD TV Live was able to locate and communicate with the production pc but met with a rejection. The “Operational” log entry indicated “A client attempted to access the server using SMB1 and was rejected because SMB1 file sharing support is disabled or has been uninstalled.” Since Microsoft did not provide a means to log an SMB2 or 3 event, their is no evidence that the WD TV Live attempted a retry using SMB2 or 3. What this does prove however is that in spite of Windows rejecting the connection on the basis of SMB1 not installed, the WD TV Live mistakenly interprets the rejection as a userid / password error, and if it has SMB2 and 3 somewhere in its bowels, instead of doing a retry with the alternate SMB, prompts the user for an alternate userid and password.

Observation three. Both the test pc and the WD TV Live were powered off. Since SMB1 was uninstalled, the production pc did not become a master browser. The WD TV Live was powered on again. At this point, neither of the pcs are master browser and so the WD TV Live has the opportunity to become master browser. Unfortunately, the Windows production PC no longer announces itself to the master browser and therefore when you enter the WD TV Live “Network Share” menu there is no device name displayed to select. And that’s the end of that!

dbglobal, mike27oct and msdobrescu, thank you for your input.

dbglobal:
From the description you have given of your circumstance, it is not clear if SMB1 was deactivated/uninstalled during the update. Without an indication of the status of the “Program Feature” settings for SMB1 after the update, the version of Windows 10 (Pro or not), and clean install vs update, any conclusion is speculative. Although Windows 10 Creator Update went smoothly on my test pc, a subsequent update on my production pc was a disaster and I had to go back to the previous version.

mike27oct:
Sorry about detail. Congratulations if you have gotten this far. You indicated having WD TV access to a drive connected to a Windows USB port. If I am right that the media player only supports SMB1, that would suggest SMB1 was not removed during the update, because the share process is similar for a USB attached device. Also, if I am right, that the effect of removing SMB1 from Windows is not restricted just to the WD media but could potentially impact their NAS product line, you might want to explore other forum members experience.

msdobrescu:
Your scenario is very interesting. The fact that you are running Windows Pro and that SMB1 is still checked in Windows feature after the update suggests that SMB1 has not been removed. I am going to hazard a guess here. You didn’t indicate whether the Linux pc was up before the WD TV was turned on. From your description it appears that the WD TV live was the master browser. The Linux pc announced its name and address to the WD TV in a network broadcast. The WD TV live saw the pc name in the Network Shares and you were able to access the Linux share using SMB1 and play the music files. When you rebooted the pc and started Windows, the WD TV Live was still master browser, “remembered” the pc name and address, displayed the pc name in the “network shares” menu and successfully connected to the pc shares. Subsequently, you turned off the WD TV Live and the Windows PC became the master browser. This is where the process gets sketchy. I assume that when the WD TV Live was turned on again, the PC continued to be the master browser. Did you use a network scanner to monitor the WD TV communicating with the pc? Are you able to determine which of the two devices are acting as master browser? Have you tried shutting off both the PC and the WD TV Live, starting the media player first, and then the pc and comparing results? As I indicated above, some have reported an actual bug in the Windows Creator Update browser code that results in SMB1 connectivity issues in spite if SMB1 not being deactivated or uninstalled.

You mentioned that you have an Android device that can access the pc shares while the WD TV can’t. I have a similar situation with my iPad. I have two media player apps that have SMB support that no longer can access the video files on my production pc. I have a third app that has no problem playing the video files and my only explanation is that the third app must be using SMB2 or 3.

#13

Hi, I confirm, I have re-installed SMB1 in Windows 10, because I know it is removed if not used, but left there after re-installation (as Microsoft stated).

Linux PC was up before WD TV was turned on.

I did not use a network scanner.

My presumtion is there is a different implementation or bug in SMB1 on the latest Windows 10.

My Android device uses SMB1.

Things were nice for me if I would have had Windows 10 with linux shares support, but Pro version has a client support only.

UPDATE: in my scenario, starting with Linux, rebooting to Windows, without closing WD TV (just stand by, no powerdown completely), the Windows 10 machine becomes the master browser. Checked twice.

#14

As I mentioned, nothing has changed for me, I can still watch movies streamed from my WD My Cloud NAS on my WDTV/TV. It very well could be because none of my PCs are the master browser. My Asus router is the master browser

Many routers have a setting for making the router the MB. Surprisingly, the Asus does not have this feature, but when I was doing the setup of a drive connected to the USB port of router, it magically made the router the MB, permanently. If anyone has an Asus and wants to know the settings that made this happen, just ask me and I can add the info here.

If anyone wants a free program that explains the MB and can determine what device is the MB on their system, click on this link below:

#15

Indeed, one solution would be to avoid Windows 10 PC to become master browser.
In my case, I have plugged a thumbdrive in my ASUS router, that starting a Samba server that is a candidate for being a master browser.
I have set some registry values in my Windows 10 PCs.
On Microsoft tech site, they say to set \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList to ‘No’, bnut was not the solution, or I misunderstood something.
Adding a new string registry value helped: \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\IsDomainMaster = False.
Now, I can see Windows PC in the servers list under WD TV.
As I’ve said, this was the issue, the direct connection to it would have worked anyway (after WD TV box displays the available Samba servers).
Well, this is not something to be considered a solution, just an workaround, IMHO, as any new Windows 10 PC coming in the network might become a master browser and break it again.

#16

Yes, a thumb drive might do the trick, as it is the router, not the drive that sets up the MB. There was NO need to get into the registry and possibly screw things up. I set all this up using a Win 7 and since then have added two newer PCs that were Win 8, but now running current Win 10. In no case did the additional PCs take over as MB, like I said, the router is the permanent MB.

I had set the following settings in my Asus router and router became the MB:

— in USB applications tab/Media Services and Servers I clicked ON both Enable iTunes Server and Enable DLNA Media Server. I then clicked into Network Place(Samba) Share above and clicked ON Enable Share.

— in AiCloud 2.0 main menu tab I clicked ON Cloud Disk and Smart Access

Not all affected the MB, most likely the first settings did,

#17

In my case, without the registry hack, Windows 10 manages to take over always.

#18

Have you installed the Lan Scan program to check what is MB; before and after.? Does it change?

#19

My Android device (Amlogic S905X) and Raspberry Pi 3 both use SMB2 & SMB3 … thanks to LibreELEC installed on both devices :slight_smile:

#20

How did you install smb1