WD TV Live Streaming Media Player, Windows 10, SMB v1 network protocol

#21

I have used LANScan, or a script in command line, same results. These confirmed my statement. The behavior was as described.
SMB1 can be re-installed from Windows features. look here:

https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

and here:

https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

#22

Microsoft Technet post has list of devices affected by SMB1 removal at
https://blogs.technet.microsoft.com/filecab/2017/06/01/smb1-product-clearinghouse/
The WD TV Live is on the list, probably as a result of posts in this forum. Interestingly, there is no mention of the WD NAS.
After a week of booting, rebooting my master browser pc which still supports SMB1, I have to update some of the conclusions that I came to in the Jan 5 post. In the Jan 5 post I indicated that the after the uninstall of SMB1 on the production pc, the test computer was no longer in the “Network” tree. Also from the WD TV Live point of view, the production pc was also no longer in the “Network Share” menu when the master browser pc was turned off. I concluded that this supported what my research indicated was a requirement for the SMB1 browser function to be available in order to see resources in the “Network” lists. From a strictly Windows point of view, that is not 100% accurate. What I learned subsequently is, that Network Discovery in a Windows system is not dependent on a specific network protocol, eg SMB1. There are several Windows services, including “Function Discovery”, that contribute to identifying the resources on your LAN. That would explain why after the reboots, I can now see the shares of each pc in the opposite pc in spite of the fact that one of them does not have SMB1. The WD TV Live now also consistently shows the Production PC name in its resource list, but is still rejected when it uses SMB1 to try to access the shared resources on the PC. What this means is that probably removing SMB1 from both PCs probably isn’t going to be as big an issue trying to see and share files between the PCs; but it doesn’t change the fact that the WD TV Live will not be able to participate in that.

msdobrescu:
If WD does not recognize its failure to implement SMB2,3 in the WD TV Live, when the writing has been on the wall for 10 years, and provide us with one more firmware update implementing these protocols, I am not confident in making recommendation to use their current NAS products in a corporate or home environment. Although their NAS products are not in the technet list yet, what’s to stop them from ignoring security upgrades in those platforms.
From yours and mike27oct posts, I am looking at a temporary workaround. Since Windows 10 updates are likely to result in random reboots which are likely to screw up the Master Browser function, I like your idea to use the router as a more stable/available Master Browser device. I also have an Asus router and I am familiar with the process you have described. Since my test pc is not as great a security liability as my production pc, I all my media to that pc and will continue to run SMB1 on that pc. I will ensure that port 445 and ports 139 are blocked in the router from the Internet, either in the NAT/Firewall by default or explicitely. This is not the most desireable scenario, but without WD cooperation, I am not prepared to deep six the WD TV Live. In another post I may explain my inability to find a WD TV Live replacement.

mike27oct:
I am not surprised that you can access the WD NAS from the WD TV. What I was hoping to determine was if the NAS was accessible from a Windows 10 without SMB1. That would would show if SMB1 was the only protocol supported by the NAS. I have been using the LanScan program that you identified, for many years to check the master browser status on the LAN. It’s a useful program. Unfortunately, it has to be executed on a PC that has SMB1, or else it fails on a system error. That means in my scenario it will not run on my production pc that does not have SMB1 but will run on my test pc that does.

#23

Indeed, ASUS router is a solution, but you must plug something in it in order to make it run Samba and become a master browser. This made it hotter and seems to affect its wifi performance too. I would have liked it to run Samba without a thumb drive, but I couldn’t set it this way… Now, I am depending on a router with this feature… I also run Linux a lot on my machines, instead of Windows,whenever possible…

#24

I use 5 WDTV Live devices for streaming files to 5 locations in my house via home network. I trusted WD when I purchased these units to supply customer support, It’s irrelevant if this is a legacy item. A upgrade from WD is all that’s required to resolve this SMB issue. I also own several WD external and internal hard drives, I have trusted them and given them business they were always my first choice. medved is totally correct, if this is their response to their customers [return customers who keep them in business] a total boycott and consumer awareness is the best and most appropriate response. don’t give them any business.

#25

Yes, my DL2100 NAS is accessible from my Win 10 File Explorer I also have this setting under Network Settings of NAS: Max SMB Protocol SMB 3

#26

mike27oct:
I have reviewed your posts and if I interpret them correctly, you are saying that you are running Windows 10 at the Fall Creators Update level, but nowhere do you explicitly say that SMB1 was removed in the process. The crux of the issue is whether or not Windows 10 without SMB1 can still access the NAS. So in your case, if SMB1 was not removed in the upgrade, I would not be surprised that you were able to access the NAS. One way to check if SMB1 is installed on your Windows 10 is to check your Program Features to see if SMB1 is unchecked.

The fact that there is a network setting in the NAS that gives you the choice to support the max SMB protocol of SMB3, suggests that that WD NAS supports SMB1-3. That is what I was trying to establish. If the WD TV Live supported, SMB1-3, I would have expected to see a similar option in the media player. The fact that there is no such an option, strongly suggests that it doesn’t support SMB2-3.

#27

My Win 10 Creator install was a disaster, as was the original Win 10 install.; I had issues I fixed but one new one with Creator, and that took THREE levels of MS tech support and over 10 hours of remote work on my HP laptop until problem was resolved. So, Creator was installed twice. So far all is working OK. again

I have no idea what went on with SMB1. You say to check my Program Features and I say: HOW and WHERE, do I do this?

Anything I can do regarding SMB1 on my Win 7 I can do with Win 10. All aspects of using my WDTV and NAS (KODI etc) are operational. I don’t know why, but I ain’t complainin’.

#28

mike27oct:
I can sympathize with you. Both my initial desktop Win 8 to Win 10 updates in 2015 were disasters. The only reliable way to proceed was to perform clean Win 10 installs rather than using the update process. This then resulted in over 3 weeks of trying to duplicate the previous working system configuration and reinstall all programs. The pc was only semi-usable during that period. What I also learned was that since the original cause of the disasters (likely some unique hardware configuration) was not identified nor fixed by Microsoft, subsequent major upgrades like the Fall Creators Update 1709 last year repeated the same failure symptoms. I am resigned to the fact that Microsoft will not fix the problem and I will be forced to perform clean installs in the future.

The simplest way to check if SMB1 is installed hit the Startup icon on the Windows task bar and then follow the following screens:
Startup : Settings :Apps & Features : Related Settings Programs and Features Turn Windows features on or off
Scroll down the list of features and look for SMB 1.0 / CIFS File Sharing Support. If the entry is checked, SMB1 is installed.

#29

royallaser:
Good point. I personally have purchased many WD internal and external hard drives. The fact that the WD Live firmware had not been updated in its 5 year life cycle to support more secure communication protocols, in spite of the fact that Microsoft announced that it was deprecating SMB1 two years before end of life, leads me to question if WD is taking customer security serious enough for me to recommend their product in a corporate environment. Also, the fact that their Customer Support, which has access to resources to identify in short time if SMB2&3 was built into the WD TV live, instead sends me on a month long journey to perform my own tests to answer my question, suggests that even in a home environment, I will have to give their products a wide berth.

I really believe that the WD TV Live was an exceptional and uniquely designed media player at a good price point. And WD support in providing frequent firmware updates to fix problems (and including an update after the device was discontinued), was exceptional. But not including an upgrade to the security of the network protocols in 5 years and preventing the media player from eventually becoming a brick, is mind boggling. I agree that a firmware upgrade to provide SMB2&3 support would go a long way in restoring my confidence in WD which would then result in more money being thrown in their direction for other products.

1 Like
#30

I checked for this on my Win 10 and did not find SMB (any version). Is there a way to check for SMB on a Win 7?)

I did see a lot of programs I installed when I checked the WIN 10, such as VLC. I have never installed any apps on the Win 10.

#31

Well, this problem is obviously still existing. I’ve been reverting the Windows update for a time, but that is unsustainable and not secure- as others have mentioned. Is there really no other way to get WDTV to see the Windows machine?

I’ve even attempted reenabling SMBv1 in my Windows machine, but it didn’t appear to take, perhaps a faulty or inaccurate article. This is incredibly annoying, it use to work so smoothly and now the box is useless.

#32

mikr27oct:
The ‘Program Features’ option switch for SMB1 was probably added to Win 10 to address simplifying turning off the SMB1 feature for security reasons and, I assume, to maybe turn it on again if the Microsoft customer was not happy with the feature being removed without their consent. I have not tried turning it back on again with this option so I don’t know if that even works. timbeaudet’s post suggests that he wasn’t able to reenable the feature.
As for Windows 7, the option was not included in the ‘Program Features’ to simplify SMB1 disable/reenable, I assume because at the time of Windows 7 support, SMB1 removal was not a hot issue. Therefore there isn’t a simple way to confirm the status of SMB1 support in Windows 7. There is a convoluted process of viewing the Windows registry and determining the values of certain esoteric entries. I am not posting this process because even though I am somewhat computer literate, I don’t fully understand what to look for. Monkeying around with the Windows registry is not something that I recommend. If you are bound and determined to look into the registry, you can Google and find the instructions.

timbeaudet:
The Windows 10 Fall Creators Update v 1709 has been a disaster on both my PCs. On my production PC, the disaster was immediate and I was forced to rollback to Windows 10 v1703. Luckily the rollback worked (they didn’t work in 2015) and because I was running Windows Pro, I was able to postpone the update for a year. Only about two days of time lost in troubleshooting. I turned off SMB1 deliberately, in order to test the WD TV Live.
My test pc appeared to update without any issues. About a month into the update something was modified by another update (maybe a security update), and the pc started blue screening every couple of days with ‘a boot device unaccessible’ error. I have googled forums, some having over 30 pages of posts with corporate and residential pcs being impacted. Although there are numerous esoteric instructions how to make the pc boot, since nobody including Microsoft, appears to have a clue what is causing the problem, the fix is only temporary. That is the PC will blues screen inevitably in a few days. Luckily I had a drive backup of my Window 10 v1703 from Oct. last year that I was able to restore and immediately turned off feature updates for a year and security updates for a month. The total time to troubleshoot this disaster was over two weeks of work.
I mention this only to let you know that your decision to postpone the update for the SMB1 issue may be a blessing in disguise. The paranoia around the insecurity of Windows PC not being at the bleeding edge of Windows operating system currency is overrated. In the thirty years that I have built and maintained my home pcs, the only disasters that I have encountered were directly as a result of implementing Windows 10 in 2015 and the Fall Creators update in Oct. 2017.
My recommendation to anyone considering applying Windows 10 feature updates, do the following:

  1. If you have Windows 10 Pro, turn off Feature Updates for 365 days, and security updates for 30 days.
  2. Reboot the pc to prove that the pc is rebootable.
  3. Do a Volume hard drive backup using a trusted/proven third party hard drive backup program (I use Paragon). Run the backup from a bootable cd or USB stick. (I don’t trust Microsoft Windows restore feature and image backup, they have failed me too many times. Use them but don’t expect them to work when you need them.)
  4. Reboot the pc and turn on the Feature and security updates. (The reason that you turned them off for the backup is to ensure if you were forced to restore the drive from the backup because of a monumental failure as a result of the upgrade, you don’t have Windows going into update mode on your first boot after the restore.)

I have been looking into alternative ways to use the WD TV Live without SMB1 on the PC. I will post what I have determined shortly. But I expect it to be a lengthy post and I am not able to proceed right now.

1 Like
#33

muse2u:
Yea I realize the rollback is waiting to become a disaster, I’ve actually been looking into setting up a Linux box with the same needs. It wasn’t too hard to get SMBv1 working on Ubuntu, though I don’t have the same read/write file access from all machines, at least the WD grabs from it as expected. I’d prefer using Windows as the windows share just works and I don’t need to set anything up, but I haven’t found a way - even when enabling that SMB1 feature, it wouldn’t take. I tried restarting the entire network after doing that.

It really would be great if WD could just release a small patch for this fix.

Windows 10 update - Network Shares problem
#34

I’ve been having the exact same problem and I think I found a way to re-enable SMBv1 on Win 10.

You type in the win box :Windows features
There’s an option called “Turn Windows features on and off” - click it
you then get several different options - towards the bottom is SMB 1.0/CIFS File Sharing Support

  • if you click the plus symbol to open the options: there are three
    SMB 1.0/CIFS Automatic Removal (do not enable this!)
    SMB 1.0/CIFS Client (check this)
    SMB 1.0/CIFS Server (check this)

it will then prompt a re-boot and then after that voila I can see all my devices again as “computers” in the network.

Hope that helps!
cheers
Deepbluefunk

#35

This post was flagged by the community and is temporarily hidden.

#36

Hopefully this can help everyone out:

  1. Go to control panel
  2. Select Programs and Features
  3. Select Turn Windows Features On and Off
  4. Scroll down to where you see SMB 1.0
  5. Select the plus sign to expand it out
  6. Select (place a check mark) in the last two (not the first one) in the list (Note: you will now see a the main box has a blue square (in the expanded list the first is empty, and the next two have a check mark).
  7. It should run, and say looking for files, the files updated (when its completed)
  8. Save changes
  9. Restart you computer
  10. Navigate to the SMB (steps 1 through 4 above) and ensure only the two boxes are checked

Now you your WD should be able to browse and access your computer / shared files / saved drives, just as before.

*Note: Make sure you have read any other posts related to files sharing, to ensure both your network and WD are set up correctly.

#37

Unfortunately messing with smb does not fix my shares this time. A few windows builds ago it worked and 2 out of the three boxes were ticked before i started this time. I can see the wdtv from the pc but just not the other way around.

I have an asus router and have tried changing the settings mentioned above but i have not been able to restart the pc or router yet. The setting change alone has not worked.

Next i will be trying a pc reboot, the usb stick in the router i s’pose.

#38

Well between the reboot and plugging a usb stick into the router she is working again. Thanks for the info, i thought it was time to retire my 3 wdtv boxes.

#39

Maybe this will help someone.

I also had this problem with my WDTV Live after reinstalling Windows 10. I have an external harddrive attached to my WDTV and access the files on there via the SMB share I created on the WDTV Live. I first tried the solution posted by therich1 but this did not work. The SMB 1.0 feature is simply not listed and cannot be selected… So… It turns out that Microsoft removed the SMB 1.0 feature entirely in the Windows 10 Fall Creators update. After some more digging I found a solution to install the SMB 1.0 feature again:

  1. First you need to open an elevated PowerShell prompt. To do this search for powershell in the start menu / taskbar. Now see the result Windows PowerShell which appears on the top. Right-click on it and select Run as Administrator.
  2. Type the following command at the command prompt: Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol Press Enter and choose Yes (Y) when prompted.
  3. Let it install the SMB 1.0 feature and let it restart windows when prompted.

After doing this I could connect to the network share again!

More info: https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and