Windows 10 won't run SMBv1 in My Passport

Tried to install My Passport thru Netgear router to home network with desktop running Windows 10. Got a error message stating that My Passport was using SMBv1 network protocol and it is no longer supported by Microsoft because of all the security issues. Says that I need to install SMBv2.02. Can’t find a work around for this. Need some way to go around this or install later version of SMB protocol. Anybody run into this?

See this recent link;s last comment.

I do not have this problem, since my network was set up with a Win 7, my Win 10 is not even on much of the time. Not sure what people are doing to cause this issue. but I want to see if I can replicate it on watching videos from my WD My Cloud NAS. So far, not an issue.

I also have a “SMB1” problem with my MyPassport Wireless Pro, and whilst I can connect to the dashboard I can’t read/write the data on the drive from Windows via Wifi. The error message from Windows 10 Fall Creators is:

"You can’t connect to the file share because it’s not secure. The share requires the obsolete SMB1 protocol, which is unsafe and could expose your system to attack. Your system requires SMB2 or higher. For more info on resolving this issue, see https:/go.microsoft.com/fwlink/?linked=852747.

This link, in a nutshell, says WD need to update the My Passport Wireless Pro firmware to use SMB2 instead of SMB1. Earlier versions of Windows allowed use of SMB1.

I’m having the same issue with my newly purchased My Passport. I bought it specifically to connect to my router, so this is a bad purchase for me unless WD updates the firmware.

This is odd. It seems to work for me.

I have two PC’s at home. . .One of them updated (more or less against my will) to the fall creators update this week. The other is on the older Creators update version.

After reading this thread, I fired up the two PC’s, and two passport wireless units (one is a wireless pro and the other the older “non-pro” model). I am able to access both units (in other words . . .read directories and stream video) from both PC’s using windows explorer. I am accessing by typing the IP address assigned to the device from my router into the address bar.

I also logged the PC with the fall update directly onto the MPWP “server” using WiFi and was able to access the files by typing the MPWP router IP into the address bar (default 192.168.60.1).

Windows 10 upgraded from Windows 7 will have SMB 1.0 Enabled, if you disable and reboot, then you will run into this KBA.

I agree. WD should support the better SMB2 protocol. I do not want to enable SMB1 on my Win 10 systems

https://www.us-cert.gov/ncas/current-activity/2017/01/16/SMB-Security-Best-Practices

Am I correct in think that the recent v1.04.17 firmware does NOT fix the SMB1 security hole? There is no reference to it in the release notes.

If so, when can we expect firmware that does address this issue?

What is going on here? I have a email out to WD now asking about any new firmware. I attempted to disable or enable SMB1 in the windows features controls. restarted the computer. and am still having issues

I have a windows 10 surface pro 3— Passport IS accessible from the router
And a HP Spectre running ( I’m guessing) a new version of windows 10— Passport Not Accessible. SMB1 Protocol error

OK, but this is only a security hole for the wireless device. The fact the wireless device has no password authentication except for your wifi password is another issue that’s bigger than this.

If you want to, you should enable SMB1 client on your Windows 10 PC so you can browse to the drive via UNC path. Don’t enable SMB1 server. If that doesn’t work, hook the drive via USB to your computer or hook it into a Synology NAS or equivalent. That will probably get around that hole.

The mentioned solution to enable SMB1 again, is just a workaround which may only be possible for private usage. And even in this aera enabling SMB1 is not the best choice.
Due to the current security recommendations, reenabling SMB1 is not an option. SMB2 is actual the world wide standard at this point . Most of the companies have disabled the usage of SMB1 via policy and the default settings of Win10 and newer versions are SMB2.
Even the newer Pro version of the MyPassport does not support the actual standard of SMB2.
In my point of view, it is part of WD (as a global company) to update the Firmware to support the actual Security standard of the IT world. BTW: I have to return my drive as without SMB2, it is complete useless. :frowning:

These devices support SMB1, SMB2 and SMB3.
Windows 10 disables SMB1 by default which also disabled Network Browse which is tied to SMBv1
So if you want to SEE network devices on Windows 10 under “Network Browse”, then you have to enable SMBv1. If you want to access the network share in Windows 10, you an still do this using //MyPassport or //IP-ADDRESS

https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows