My Passport Wireless Pro does not show up as a 'Network Share' storage in Windows 10? Here's the solution

I was troubleshooting why the My Passport Wireless Pro drive does not show up as a Network share on Windows 10, while it does on Windows 8 and older OS?

I came across a possible reason, which is that the SMB 1.0/CIFS File Sharing Support is disabled in Windows 10 by default now. This is to prevent the likes of WannaCry ransomware attack, which spread on the network through the old SMB v1 protocol.
So, be careful, you might be at risk.
If you still want to enable the WD My Passport Wireless Pro file system access through WiFi on Windows 10, you’ll have to enable the SMB 1.0/CIFS File Sharing Support through ‘Turn Windows features on or off’ option. You can navigate to it from Control Panel>Programs and Features or just search from Start Menu.

Restart the computer after enabling it. Connect to your Wireless Pro’s WiFi network, then you’ll see your Wireless Pro as a network share.

Hi Tech-Freak

Thank You for your valuable response and providing this troubleshooting steps. It will definitely help other users in resolving such issues.

1 Like

The essential setup of @Tech-Freak is missing in the WD Manuals.
Sorry @Peter.g

this is just a temporary solution, microsoft is intent to get ride of old samba protocol,

the correct solution is WD get the samba update,
as they use an pretty old version 3.6.25 released at 2015-02-23 inside the Wireless Pro

Got same issue on Windows 7.
Is there a way to check windows 7 smb ?