WD TV Live not showing Windows Shares from WD My Cloud

Hi Guys,

I have WD TV Live, which I have been using for a number of years, watching Windows Shares from my WD My Book World NAS. I do it this way so I can play videos from the NAS and delete them after watching.

Just bought a new WD My Cloud, and have connected it up. (alongside My Book World).

It is doing it’s “back up” thing, no problems, from two different PCs on my network.

When I try to “Select Content Source” then “Windows Shares”  the option is there to pick MYBOOKWORLD but the My Cloud doesn’t show up.

A new option has appeared since I installed My Cloud, but it’s called MSHOME (the name of my work group) and after logging in as anonymous **bleep** says “there is no media available for playback”.

I can access all the Media on My Cloud by using the “Videos” option on the WD TV Live main menu, BUT I can’t delete what I’ve watched this way, so I would prefer to use the  “Files” option if possible.

Any help would be appreciated, I’m sure it’s something really silly that is stopping it.

Looking forward to hearing from you.

Regards,

Paul

Just check on your WD My Cloud is also set as DLNA Media Server?

If it is, than you are seeing files over DLNA and therefore you cannot delete them, just stream them.

Also check you network share folders on WD My Cloud if you are not using preconfigured Public network share folders for media.

PaulRichardson wrote:

A new option has appeared since I installed My Cloud, but it’s called MSHOME (the name of my work group) and after logging in as anonymous **bleep** says “there is no media available for playback”.

You’re saying the WD TV is showing a device named “MSHOME” in the list?  But MSHOME is your WORKGROUP name, not the Cloud’s name?

If so, well, “that ain’t right.”

Double check your My Cloud’s configuration and ensure you didn’t mistakenly change the DEVICE NAME to “MSHOME” instead of the WORKGROUP name, because the WD TV will not show systems that are NOT in its own workgroup.

Hi Foetus,

Thanks for your suggestions.

I have looked at the settings and it was set as DLNA Media Sever, but I turned that setting off, and it hasn’t made any difference.

I am using the PUBLIC network share, with media serving and public access both ON.

Regards,

Paul

Hi TonyPh12345

Thanks for your suggestions.

I have checked the settings and the device name is WDMyCloud with a device description of WD My Cloud.

The workgroup name was definately MSHOME.

I tried changing the workgroup name to something else but the MSHOME option in Windows Shares is still there, so I am not sure what that is?

I have changed the workgroup back to MSHOME but still no WDMyCloud in the Windows Shares option on WD TV Live. 

I am so confused.

I have compared the setting on my MyBook World drive and as far as I can see they are the same, but that one still works fine.

Regards,

Paul

Sounds like whatever device is acting as your Master Browser for the workgroup is munged.

This is how to find possible problems with the Master Browser on your network, which will affect when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:


C:\Users\Tony>net view
Server Name Remark


\BIGNAS1 Big Freakin’ NAS Server 1
\MARS
\NEPTUNE
\WDTVLIVE WDTV LIVE
The command completed successfully.

In my example, there are four active devices that Windows has discovered.

Now, for EACH of those, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [10.0.0.157] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status

BIGNAS1 00> UNIQUE Registered
BIGNAS1 03> UNIQUE Registered
BIGNAS1 20> UNIQUE Registered
…__MSBROWSE__.01> GROUP Registered
WORKGROUP 1D> UNIQUE Registered
WORKGROUP 1E> GROUP Registered
WORKGROUP 00> GROUP Registered

So, we got lucky here, the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.

Once you find your master browser, reboot it.

1 Like

Hi TonyPh12345,

It looks like you were SPOT ON.

I cheated a bit, I couldn’t get a “command” window open, (but that’s a whole other story, the little box in my Windows start menu has NEVER worked).

What I did was shut down my entire network (sounds grand but there is only a couple of PCs and two NAS drives.

Then turned it all back on one item at a time…BINGO!!!

Both WD drives appear in my Windows Shares (so I can choose which I watch).

Fantastic, Thanks very much for your help.

Regards,

Paul