WD TV Live Hub - It can't see shared drives


#1

I had just bought the Live Media Player a week ago. I was able to stream from a NAS drive no problem. Saw the Hub at Bestbuy today so I picked one up. I unplugged the Live Media Player and plugged in the Hub. It immediately updated the firmware. I can stream Pandora and others no problem. The Live Hub cannot see the same NAS drive as before. It does not show up on the network for some reason. I can use the web interface - not real useful, wish I could use the web interface to enter Pandora account info etc. but can not. Anyway, what can/should I do so the WD Live Hub can access my NAS drive? I thought the Hub would act the way the Media Player did.

Thanks


How to change master browser in windows 7
Live Plus, Live Hub and Network Shares
WD TV Live won't find my network share from Synology DS 213+
#2

The only thing different about the HUB and NAS that I’ve noticed is that the HUB will NOT find devices that are on a different Workgroup name.    The WDTV Live and Live+ will.

Does that apply to you?


#3

Thanks for the reply. I have the NAS, Hub, and all machines on the same Workgroup.

As mentioned, I can access the HUB GUI from any machine or my iPhone - no problem.

I turned on The Hub’s iTunes server and can play (from the Hub) to any of my machines with Itunes.

The Hub can’t see any shared drives or the NAS and it does not appear in ‘Network Neighborhood’ the way the Live box would.

Frustrating - I want to use this thing - What am I missing here?


#4

This is how to find possible problems with the Master Browser on your network, which will affect when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:


C:\Users\Tony>net view
Server Name Remark


\BIGNAS1 Big Freakin’ NAS Server 1
\MARS
\NEPTUNE
\WDTVLIVE WDTV LIVE
The command completed successfully.

In my example, there are four active devices that Windows has discovered.

Now, for EACH of those, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [10.0.0.157] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status

BIGNAS1 <00> UNIQUE Registered
BIGNAS1 <03> UNIQUE Registered
BIGNAS1 <20> UNIQUE Registered
…__MSBROWSE__.<01> GROUP Registered
WORKGROUP <1D> UNIQUE Registered
WORKGROUP <1E> GROUP Registered
WORKGROUP <00> GROUP Registered

So, we got lucky here, the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.

You need to find out WHICH system is your master browser. If none of these steps work as described, then the issue is likely on your PC itself, and that will require substantial additional troubleshooting.

Once you find out which system is the master, we’ll need to go from there.


#5

Ok - found that. My NAS - NASSERVER - is also the Master Browser…

I’m ready for the next step…


#6

1>  First, please specify the exact Make and Model of your NAS.

2>  Does the HUB see ANY other computers on your network in the Samba screen?

   (the computers will need to be sharing something in order to show up)

3>  Have you tried re-starting the NAS?


#7
  1. The NAS is a Linux Ubuntu box with no permission restrictions. This is the same box that The little WD TV Live had no problem finding and streaming from.

  2. No - when I press Network Storage as a Source on the Hub, it immediately says ‘No Storage Present’ and this is what makes me think there is a problem with the Hub or Hub settings… but there really aren’t any ‘settings’ other than Network Connection…

  3. Yes - Just restarted it again. The NAS can stream to my Windows machines and my iphone as well.

I also shared folders on my Windows machines but they don’t appear on the Hub either.

fyi - I am on my 3rd ‘specialist’ with WD support. They keep transferring me to their manager to try to help.

Thanks for your help - by the way…


#8

Because it can’t see your computer, this indicates there may be something wrong with either the Hub itself, or with your network.

Do you have a spare router you can use (or a friend who will let you borrow one)? - A good test is to connect the NAS and the Hub through a second router to rule the router out as a possible issue (I know other devices can see each other, but a failing router can work for 95% of devices, but some might not be seen)

Are you connecting wired or wirelessly? If wirelessly try using an ethernet cable.

Have you made sure the box has access to the network at all? What happens when you launch youtube? Can you see the NAS built into the Hub from your windows machine or your linux box? Can iTunes see the iTunes Server?

Does your router have a firewall built in? If so what happens if you disable it (just as a test)?

Lots of other stuff you can try, but that should be a good start.

Oh yeah, what firmware version are you running (there was an update available when I got mine this morning)?


#9

…  I would try the following:

Shut off EVERYTHING in your network:  The HUB, your PC’s, your NAS…  Everything but your Router.

Reboot your router.

Start your PC’s, but NOT the NAS.

Start your Hub.

Do your PC’s now show up?

If so, then the problem is your NAS… Try upgrading to a more recent version of Samba.


#10

This weekend, I will try all of the suggestions mentioned - here’s a little more info.

I called WD and after they tried their best, said they will look at it over the next week or so and see if they can duplicate the issue. I exchanged the hub at BestBuy for a new one to rule out a defective unit - essentially the same result.

This new one I have not updated the firmware so it is still at: 2.01.05 and the update is 2.02.06

I hardwired/Ethernet the new one again as before.

There is one slight difference - when I choose a source, it says Local, Media Server, and Network Shares (Samba).

It never had (Samba) before.

From the NAS and every machine and iPhone on my network, I can successfully navigate to \WDTvLiveHub and copy/delete/stream files no problem.

It must be the router at this point… I will post back the results.


#11

Network Shares is still Samba whether it says (Samba) or not.  ;)


#12

Just to add some more fuel to the fire, my Hub won’t see my NAS if a WIn 7 box is on at the same time on my network (nothing to do with Windows Live assistant).  If I turn off everything BUT the NAS, the Hub sees it just fine.

Just one more thing to try.


#13

apologies…ive a few questions regarding network shares…

  1. is it still necessary to have a folder.jpg, movie.jpg and movie.mkv in a folder with 1 movie for it to display a folder thumbnail when viewing your shared network video collection in thumbnail mode?

  2. does it still display multiple /extra images (folder.jpg & movie.jpg) when you press “enter” to view the folder?

  3. does it crash when there are more than say 500+ thumbnails (movies and/or folders) that need to be displayed in network shares?


#14
  1. well, yes and no. You don’t have to have one movie per folder, you can have as many as you want, but the naming convention for the files to be used as thumbnails is the same.
  2. No, because the media library is stored locally on the HD.

#15

FuGGer wrote:

  1. does it crash when there are more than say 500+ thumbnails (movies and/or folders) that need to be displayed in network shares?

 

 

I’ll check this out today for you (normally I don’t use the Hub on my movie NAS, but I’ll see if it still has that “hang-up” when browsing that many files/images.

My guess would be no – as Tony says, it stores the information differently than the Live does, and there isn’t a “thumbnail view” per se (there’s a very poor substitute.  Tony himself has created a much better one, and I’m guessing he’s probably shared it or would share it for all if asked.  However, you will have to give up another of the views to have it).

If you don’t hear back from me by the evening nag at me again and I’ll check.


#16

Problem Identified.

My Setup:

I have a ATT Uverse Gateway/Router and plugged in to a 24 port 3Com-4226T (3C17300) switch.

I have all my computers - NAS, Windows XP, Win 7, Vista, Network Printer - and of course the WD TV Live Hub (firmware 2.01.05), plugged in to the switch.

Also plugged in to the Uverse router is a NetGear GS108 Switch that was provided by ATT when the Uverse service was installed. All my TV set top boxes are plugged in to the NetGear.

What works:

The network is up and running all the time and allows me to VPN in to work, access the internet on all machines, network printing/scanning, etc. The NAS and every other computer on the network can see the WD Hub and copy to/from it no problem. Also, with this configuration, my previous WD Live streaming box worked flawlessly, seeing and streaming from the NAS without issue.

What doesn’t work:

With this setup, the WD Live Hub cannot see the NAS or any other machine on the network. After testing, I also discovered that my Uverse set top boxes will not work through the 3Com switch either.

The solution:

Replace or upgrade the 3Com switch. I plugged the NAS and the WD Live TV Hub into the Netgear switch and the Hub was able to see the NAS and worked great. I need to figure out if the 3Com can be upgraded via firmware, because other than this issue, it works just fine.

Lessons Learned:

This probably won’t affect many people as my network setup may be somewhat unique. I did not realize a switch would be less than 100% compatible with a network - it must be due to a certain protocol that the 3Com switch does not support…? Also, Western Digital has changed something between the WD TV Live and the WD TV Live Hub since one worked and one does not - probably the protocol thing…

Thanks all for your comments and help.


#17

Maybe this helps: The network name seems to be case-sensitive. I changed cases now it works here. Good luck…


#18

Same problem, only I am running a Netgear Ultra 4 NAS, with the latest firmware.

This is what my network looks like: http://oi53.tinypic.com/scb66f.jpg

I have tried every permutation of options on the Netgear NAS, and have turned off Samba on the Linux box to prevent a browse master issue. If only WD would trust us to type in a share path, and provided NFS support!

Question: Once I get the Live Hub to see the shares on the NAS, will I be able to use the media library functions on the networked storage? I am very happy with the way the unit works with media on the internal drive, but DLNA has given me nothing but problems.


#19

Your picture is confusing.    What I’m seeing shows multiple devices connected to multiple subnets?

… and your  NAS is connected to both the E3000, and a switch, and then that switch is ALSO connected to the E3000, which to me looks like a network loop (a/k/a a VERY bad thing)


#20

The NAS does have 2 interfaces on the same subnet, but each has its own IP. I think you are thinking of a routing loop, which is layer 3, this is all layer 2. Each interface on the NAS has a unique IP and MAC.

The inent of having both interfaces of the NAS on the same subnet is traffic from the Linux box goes down one path/interface, and traffic from the NAS to the WDTV goes down another.

This is an older drawing that may be easier to read: http://i54.tinypic.com/1zmjuzd.jpg