WD MyCloud Stuck in safe Mode


#1

So i have a WD MyCloud that is stuck in safe mode.
It is requesting for the firmware version 1.0.1.007 and I cant find any existence of said firmware.
I have tried emailing WD support multiple times and have proven to be terrible by barely ever replying and when they actually do they have replied with a link to a guide which i had already said doesn’t work and then the second time they replied they told me they will call me but they never did.
Which is how i ended up here.
Please Help.


#2

What type of My Cloud do you have?


#3

I have the WD My Cloud 4TB


#4

I’ve never heard of a ‘safe mode’ for the MyCloud. Or of a firmware 1.xxx.

I would suggest downloading the latest firmware for your device. But you will need to know if it is a gen1 device (firmware 3.xxx or 4.xxx), or a gen2 device (firmware 2.xxx).

If you have had it more than two years, it will be a gen1. If you have had it less than 18 months, it is likely to be gen2.

The serial number should also help. Gen1 have a part number ending -01. Gen2 have a part number ending -10 (IIRC).

Gen1 devices came in an almost cubic packing box (as pictured above). Gen2 devices come in a narrower box.


#5

There are references to it, though, including the version number you’re seeing. Safe mode appears to apply to both gen1 and gen2

https://community.wd.com/search?context=category&context_id=105&q=Safe%20mode

#6

It appears to be a gen2 My Cloud as the P/N ends with -10.
I downloaded the “My_Cloud_GLCR_2.30.165.bin” firmware file and tried uploading and applying it to the My Cloud using the screen I posted up above, after i click apply it uploads the file but then it just gets stuck on 0%


#7

I’d suggest reading some of the previous threads on ‘Safe Mode’ on the Gen2. A quick scan did suggest others had seen the 0% progress problem.

Have you tried resetting?


#8

Yeah, I have tried doing a 40 second reset but it doesn’t elicit a response.


#9

Well, I assume a 40-second, power-up reset does something… Does it just come back to the ‘safe mode’ screen?

The alternative is to go for a full unbricking. Plenty of threads on that, for Gen1 & Gen2


#10

@JaydenKable How long have you left it on 0% to see if it would eventually install?


#11

I’ve had it like that for about 45 minutes


#12

The 40 second reset doesn’t do anything nothing changes at all when i let go of the reset button, it just keeps it on the safe mode screen.


#13

@JaydenKable How long have you owned this My Cloud? If you just bought it I would take it back and request another one to replace the one you have.


#14

I got it about a year ago, so i think that might be the plan.


#15

That’s not a 40-second reset. A 40-second reset requires removal of power, pressing & holding the reset button, applying power, holding the reset button for 40 seconds, then releasing. See the User Manual for details


#16

Hello JaydenKable,
Did you solve the problem with the safe mode? I have exaxt the same problem. It would be nice if you can help me.


#17

@JaydenKable could you solve this issue??


#18

Después de intentar recuperar mi WD MyCloud (Gen2) con diversos tutoriales, finalmente conseguí resolver el problema de la siguiente manera:
(Tutoriales que he probado hasta el momento “https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXF4aFpYS2dzMEE”, por cierto hay mucha información útil para dispositivos MyCloud)

  1. Descarga las imágenes de las diferentes particiones de mi WD MyCloud (Gen2).
    https://mega.nz/#F!GfYHjaiY!iGohNb1NhDES0HpjIslsHw” - En este caso es el “WD.zip”
    Nota: Para saber si nuestro WD MyCloud es de la 1ª o de la 2ª generación, debemos buscar el P/N: WDBCTL0030HWT - 10, estos 2 últimos dígitos, nos indican si el dispositivo es de genreación 1 o 2.
    Generación 1 = 00, Generación 2 = 10.
    Aclarado esto, seguimos con el procedimiento de recuperación de un WD MyCloud (Gen2).

  2. Debemos arrancar con un LiveCD de Linux, yo he usado Ubuntu 18.04, lo podeis descargar directamente desde ubuntu.com
    ftp://ftp.cesca.cat/ubuntu/release/18.04.1/ubuntu-18.04.1-desktop-amd64.iso

  3. Procedemos a particionar el disco, se perderá toda la información, actuad bajo vuestra responsabilidad.
    ·Iniciamos un terminal de linux, el equivalente a “cmd” de Windows, la tipica pantalla negra con letras blancas.
    ·Elevamos los permisos a super usuario.
    sudo su
    ·Determinamos el dispositivo que hace referencia a nuestro disco duro, aparecerá una lista con todos los discos o unidades de datos detectadas “/dev/sda; /dev/sdb; etc”.
    Junto al dispositivo, indicará la capacidad, así debeis buscar cual és el vuestro y sobre ese realizaremos las particiones necesarias, en mi caso “/dev/sdb”.
    fdisk -l
    ·Limpiamos todas las particiones y luego reparticionamos el disco.
    parted /dev/sdb
    rm 1
    rm 2
    rm 3
    … (Nota: repetimos el comando “rm” hasta que no queden particiones, para saber si hay alguna más, ejecutamos el comando “print” para mostrar el particionado del dispositivo selecionado)
    mklabel gpt
    mkpart primary 1049kB 2149MB
    mkpart primary 8591MB -1MB
    mkpart primary 7517MB 8591MB
    mkpart primary 2149MB 3222MB
    mkpart primary 3222MB 4296MB
    mkpart primary 4296MB 6443MB
    mkpart primary 6443MB 7517MB
    quit

    1. Damos formato a alguna de las particiones.
      mkswap /dev/sdb1
      mkfs.ext4 /dev/sdb2

    2. Recuperamos las imágnes de disco sobre las particiones creadas.
      (Nota: El archivo que hemos descargado “WD.zip”, lo debemos descomprimir en la carpeta descargas, en español la ruta es la siguiente “/home/user/Descargas”, si no sabemos la ruta exacta, una vez descomprimido el ZIP, le damos a propiedades sobre la carpeta WD y nos indicará la ruta)
      cd /home/user/Descargas - Tened en cuenta que esta es la ruta en la que yo he descomprimido el archivo, debeis acceder a la carpeta donde lo hayas descomprimido vosotros.
      dd if=/sdb3.img of=/dev/sdb3
      dd if=/sdb4.img of=/dev/sdb4
      dd if=/sdb5.img of=/dev/sdb5
      dd if=/sdb6.img of=/dev/sdb6
      dd if=/sdb7.img of=/dev/sdb7

  4. Ahora ya podemos apagar el sistema, conectar el disco y esperar a que arranque, pasados unos 5 minutos, accedemos a “http://files.mycloud.com/setup”, en caso de que no consiga entrar, puede deberse a 5 razones:

  • No hemos esperado tiempo suficiente.
  • Debemos buscar la ip del dispositivo y acceder directamente por la ip.
  • Algunos de los pasos de particionado o copiado no se ha realizado correctamente.
  • El disco duro tiene algún problema físico.
  • Nuestro WD MyCluod no es de 2ª Generación.
  1. Usamos el asistente de WD para realizar la configuración del almacenamiento y después act. el FirmWare a la última versión.
    He dejado una copia del mismo en “https://mega.nz/#F!GfYHjaiY!iGohNb1NhDES0HpjIslsHw” - En este caso es el “My_Cloud_GLCR_2.31.163.bin”

Un saludo :wink: