My Cloud recent firmware update Rapid Flash Blue light and gone from network (Gen 2)


#1

I started the recent update it got to 100% and that is the last I saw of the device. Its now entirely gone from my network with a rapid flashing blue light. I let it sit more than 24 hours and it was still in the same mode. I tried the 40 second hard reset and its still in the same mode. Is the firmware corrupted? Is there a way to reinstall the firmware without GUI interface? or does it need a new controller board? I searched around, but I cant find specifics to not having GUI access or firmware. EDIT: Scroll down for the fix I used.


After upgrade firmware my WD cloud dont work
#2

I think that I may be having the same issue, unable to reboot/reset and am unable to access the device. I didn’t manually start the firmware update, but may have it set to do so automatically.


#4

On the single bay/single drive My Cloud (subject of this subforum), the firmware is stored on the hard drive.

First troubleshooting step is to try a 40 second reset to see if that clears the issue.

For the single bay/single drive My Cloud one can use one of the “unbricking” methods to try and restore the firmware to one’s My Cloud. Note that some of the unbricking methods may erase one’s user data on the My Cloud hard drive. One can always remove the My Cloud hard drive from it’s enclosure and attach it to a computer to access the user data files on the My Cloud drive. One would need to use Linux or have a driver installed on their Windows computer to read Linux formatted hard drives since the My Cloud hard drive is formatted for EXT3/EXT4.


#7

Mine has done the same thing, Im guessing mine was on Auto update too. Ive also tried all the above to no avail. are you sure its not a violet light thats flashing?
i have put a support case in.


#8

Please let us know what your result is. People solve problems then we never hear from them again. Thanks for posting… :slight_smile:


#9

I would be csreful putting the drive in the second bay? If that NAS is setup for raid it might overwrite your disk. What you could do is connect the disk to the USB port with an sata to USB adapter. That
way the device won’t make changes to the disk.


#10

Its not set up for raid. I just looked at it. There are 2 options. Mirror and Single drives. I have it set for 2 separate single drives. no raid. So as to my other questions. Do I just need to replace files if the drive reads up okay?


#11

Not sure what files to change. What version of My Cloud is your device Gen1 or Gen2?
What are the leds on the back doing? If you pull the network cable does the front led change color?
On a gen1 it will change to yellow. On the gen2 it will change to red. If the light changes then the My Cloud is running. A blue flashing led on the gen2 is supposed to indicate updating firmware or loading the OS. See page 7 of the gen2 manual.


#12

Here is what WD posted for blinking blue led.


#13

I read that, It also says in another post they made that there is a rapid flashing if its an error. They should elaborate in this post you linked to re-affirm the speed of the flashing for this boot process, because 7 days is a long! time to wait if it’s just sitting in error mode the whole time. Some people would like to use that time getting it working. This is not a slow pulse I have its flickering rather quickly.


#14

If and when I find out from support what the issue is I will repost the info.


#15

Have you checked the router to see if it is handing out an IP address to the My Cloud?

If the router has handed out an IP address to the My Cloud can you access the My Cloud Dashboard using that IP address in a web browser?


#16

Thank you for posting, Yes I tried everything I know how. I know some people post willy nilly, I am beyond the basics, its not in the dhcp anywhere either. MyCloud was great for spreading itself around the network (you knew it was there), They did a great job with that. I hit a wall on this one im positive the update fudged it, it’s goners everywhere like it never existed. If it weren’t sitting on the rack plugged into the network I wouldn’t know I had it.


#17

If it’s not even pulling an IP address or isn’t even showing up on the local network then you might have to use one of the various unbricking methods to push firmware to the unit to try and fix the firmware issue. Just note that certain unbricking methods may result in loss of user data.


#18

I have everything backed up including the config so I can afford to lose the data. I learned about 5 years ago how hard it is to lose everything on a nas so I started backing up everything since. Which un-brick method do you suggest to use (if you know) What would you consider easiest or the fastest? Thanks!.. :slight_smile:


#19

For me, the last update (2.30.196) f.cked up the iSCSI and mediaserver connections…
rebooting and hibernating did not work…
so “unplug” was the “first step” solution… (i did not want to do hard reset… then setup)
and it works…

opetrik


#20

I have been told to return my cloud as it is under warranty, I was given a contact of a data recovery company who will give a fee quote. I rang them 1st before sending and they said it would cost anything from a couple of hundred upwards!!

So all in all your home based my cloud hard drive ain’t the good idea it seems. Should have just stayed with drop box and paid for more storage.


#21

That was the same with mine. Then the power and everything has gone. It’s not even a year old.


#22

Does any one know how, or have they tried removing the drive and recovering data themselves?


#23

Hi.
I have the same problem as you.
https://community.wd.com/t/after-upgrade-firmware-my-wd-cloud-dont-work/228817/10
Data from the disk could be saved, on the web has instructions to change the disk partition from linux (ext4) to win to make the disk readable. Because my ability is poor, I gave this operation to make IT man.
unverified information:
The disk should be readable in any ext4 format NAS. I ordered Synology, then I’ll know.