WD My Cloud - Blue light flashing

Hi all,

New here, and really hope you can support me. Upfront, I apologize for the long first post.

My issue:

I own a WD My Cloud 3TB. Now all of a sudden I cannot access it anymore.

When checking the device I noticed the blue flashing LED at the front of the device, so I immediately started to investigate what this could be.

I found that the Western Digital webpages state that the device is either booting up, doing a firmware update, or performing a file check.Booting up the system is unlikely, as it is in this state for many days already. Performing a file check can be (it is making some noise) but is going on for many days as well. Considering the many days I don’t expect a Firmware update either as II don’t think this is normal behavior?

What I tried / found out already is:

  1. Both the 4 and 40 sec reset don’t work to resolve this behavior, the blue light keeps flashing. According to the 40 sec reset instructions, the device starts booting again after releasing the reset button. In my case I think it starts booting up immediately when plugging in the power cable, however not sure if it reboots again when the reset button is released. Not sure if this is correct?
  2. The WD My Cloud does not seem to connect to the network. It is not showing up in my router and it is not showing up in the app Fing either.
  3. UTP cable I used to connect the device to my router is working, I tried different other UTP cables, different other machines, and different ports on the router which all work perfectly in all combinations. So it’s really the device that can’t seem to get on the network.
  4. I tried powering it on before plugging the UTP cable and visa versa, which makes no difference.
  5. DHCP was set enabled before this behavior, and is reset to enabled by doing the 40 sec reset, so to me this means that the WD My Cloud does not has a static IP that is causing this error.
  6. I tried removing the firewall settings from my router, which did not help either.

Some facts:

  1. WD My Cloud 3 TB was purchased end of July 2016, serial starting with # WCC.
  2. To the best of my knowledge the Firmware updates were not pushed automatically, but I am not sure if that’s true.
    3 .Latest firmware version according to the My Cloud IOS app, is 2.30.193, but I am not sure if that is correct as I don’t have access anymore using the app either, with some luck I could find a tab that still listed this version.

What I have not tried yet:

  1. Connect the WD My Cloud to my laptop directly with a UTP cable, however I believe this only works when having a static IP set on both devices. I can’t change that anymore on the WD My Cloud, so this does not seem to be an option.
  2. Last resort I now see is removing the case, detaching the hard drive. and trying to link it to my laptop using a SATA/USB connector, and then using DiskInternals Linux Reader (as I believe its a Linux drive?) to see if I can access the files again.

Did anyone else tried that option or has any other solutions that I can try? I would like to avoid the last one as I am not that technical, but if its the only option forward of course happy to try.

Looking forward to your feedback.

Best regards,

Jurgen

@jurgen2k Is your My Cloud blue light flashing fast or is it a slow on and off? If it is in Standby/Sleep mode then it will be the slow on and off.

There is a new firmware update for the 2nd generation if you want to download and install it.

@cat0w Thanks for your response.

Its not in stand-by. Its fast blinking.

Not sure how to try the new firmware when I cant get it an ip address and on the network. It makes the dashboard unreachable as well.

I believe it would require hooking it up to a laptop using SATA/USB, doing a manual download of the firmware and replacing it on the HD? I might try that after recovering the data.

Best regards,

Jurgen

When the device is in the fast blinking mode. Pull the network cable. Does the led change
color to red?

No change, it keeps flashing fast in blue

Has anything changed on the local network? New router? New broadband provider? New network equipment?

Couple of troubleshooting steps.
Disconnect all other network devices (including WiFi connected devices). Power down the router and the My Cloud. Wait a few minutes and then power on the router and wait for it to finish booting into operating mode. Then power on the My Cloud. Leave all other network devices disconnected from the router. Then observe how the My Cloud boots and if it boots properly to a solid blue LED. If it does then power on the rest of the network devices and use a computer to check My Cloud operation.

Try putting a network switch between the My Cloud and the network router. There is a known issue with certain routers and the My Cloud that can be solved by connecting the My Cloud to a network switch, then connecting that switch to the network router.

I’m experiencing the same problem as the thread OP as well.

No change in hardware configuration at all.

WD MyCloud 4TB (Gen 1 i think)
S/n starts with #WCC same as OP
Bought about the same time as OP, June/July 2016

Really need some help. Asked some data recovery specialists and they are quoting upwards of $500 for the recovery of data.

i had a similar issue and i found a solution. i made a step by step video that might help you.

Hope it helps

3 Likes

super thanks you saved me this step by step video worked for me 100%, i gain access back to my blinking blue light wd my cloud without losing any data :slight_smile:

1 Like

Hi Jurgen, did you manage to solve somehow problem with blue flashing light? I have exactly same problem and tried to do same troubleshooting steps but without change. Light still flashing for many days. The “manual” in the video is not easy. I hope, there can be the easier solution. Thanks, Jiri (WD My Cloud, 3TB)

Hi,

No, needed to extract the harddrive and boot it through Linux as an external drive to eventually get the data off.

I will never go for a solution like this ever again.

Thats all the fun! Didnt you know this? WD made all there cloud devices so you either break them and throw them away and buy from another company or they hope your dumb enough to purchase another product like the my passport or something else that resembles a backup device but really isnt. If a hard drive is in a shoe box, its still a hard drive right? Just saying…

Edit: I use to be PRO WD, until i had my first RMA out of 19 years of using there devices, I was called a crook, a thief among other things. I was also told to pass this on to the retail store I purchased it from. Best Buy. In the end I decided to just not purchase WD Products ever again. I hope you do the same.SO i dont leave you hanging, I sent in a WD my Book 6tb, Apparently someone stole the drive and put god knows what in it, I did not know this until I was told my RMA was denied because I am white trash, a thief, so many I lost count, Robbie from Tier 2 knows what he said. Ask him. Long story short, If you purchase a device and someone stole from you before you even knew it, WD will blame you. So dont buy WD

adimahluf Excellent video instructions. You helped save all my data on this WD which has been blinking bad blue for the last 3-4 months. Now back in business. Thank you very much!!

I found your video very useful.However please explain how I am getting to the command line after booting the WD MyCloud from the Disk-on key.

I have a 3TB that stopped working. I found a relatively easy way to fix it.

Disassemble it. There are some instruction on how to do it on youtube. Be carefull not to brake it.

Create an Ubuntu bootable media. DVD or pendrive, or use your installed Ubuntu if you have one. Search www.ubuntu.com to download and to get instructions on how to create a bootable device and have it booted with mycloud hardrive installed on it.

On Ubuntu, open a terminal and run: sudo gnome-disks. Below is not the WD disk, but an example. It should be easy to locate it on your left panel based on your disk size. if not, try one and it should show several partitions.


On each partition but the biggest, click the partition then the gear below and then check filesystem.
In my case the last partition showed and error (before the big partition). To avoid problems I copied its contents to another place and repaired the bad partition by clicking the gear again and then Repair filesystem.

Shut the computer down, remove the disk and assemble everything back again. If everything went ok, it should work by now, as it worked for me. If you can’t install in a computer, you shoud be able to find a sata usb adapter and access it connected to a usb port.

Good luck! :smiley:

Hello, Thank you for your video.
However, I cannot find on my PC the usbrecovery.tar.gz file. Can I find it online?
Thank you in advance for your reply

Hi I am facing the same issue. The WD My Cloud 3TB suddenly cannot be accessed neither from the dashboard or the file system.
The led is blue and flashing/blinking non stop.
Have you solved the issue somehow ?

Hi All,
I’ve had the same issues with one of our WD My Cloud Gen 2 drive. I have used adimahluf’s video instructions (Very good) and got to the stage were the firmware can be installed via a browser. This is were I get stuck. On the Video the firmware version showing is 1.0.something in Safe Mode, on my browser (IE) this is blank.
Safe%20Mode
When I try to upload the firmware the % loaded isn’t showing and the wheel keeps spinning. It only stopped last night due to a power black out. Tried again and it just sits there. Anyone have any idea?

Thanks.