WD My Cloud 3 TB blinking blue light - can't excess


I searched the forum extensively but all threads relating to my problem all have expired google drive links etc. so I can’t excess the solution.

For some time now, my cloud drive (WD 3TB My Cloud Personal Network Attached Storage - NAS - WDBCTL0030HWT-10) disappeared from my network. The drive is directly connected to my router and, up until this incident, I never had any problems with it.

I unplugged/plugged back everything ( for 4 minutes, for 30 minutes, for a day), but the power led (blue) is blinking endlessly. The drive does not show on the network, neither on my notebooks nor on my cellphones. I cannot access it via dashboard (http://wdmycloud/ ) .
I can hear (& feel by touch) the drive working, and it is working very hard.

I tried connecting it to my laptop with a usb cable but it does not show up.

I have found this post: 4TB My Cloud disappeared- Fast blinking blue light! HELP
And a youtube video ( How to fix WD MYCloud Blue light flashing issue)

But all links to the reboot files don’t work. Also I’m pretty oke with computers but not amazing.

I really dont want to lose my files. I do have a flashdrive (7 gb) but no knowledge of linux or anything so it’s me my windows pc, a flashdrive and a broken wd my cloud.

Maybe someone can help me and explain how to reinstal the firmware without losing my files through the usb on the wd my cloud?

Would be great, thanks in advance!

Have you read the User Manual for the 2nd generation My Cloud, be sure to look at LEDs? What are the LEDs on the back of the My Cloud doing and on your router? Look at Connecting a USB Hard Drive, Chapter 12!


I don’t really get this answer. It does not answer my question at all. My my cloud is still not working. Maybe anybody has an awser?

@QuiBoe First, did you look at the User Manual and what Blue blinking LEDs stand for?

Did you look at Chapter 12 about connecting a device to your My Cloud by USB? You can’t connect your My Cloud to your Laptop by using the USB connection. You would need to use the Ethernet port and an Ethernet cable.

You can’t. the USB port on the My Cloud is for attaching USB hard drives. It is not for connecting direct to a computer. You can connect the My Cloud network/Ethernet port to a computer but not the USB port.

One generally manually updates the My Cloud firmware using the My Cloud Dashboard > Settings > Firmware > Manual Update > Update from File option/button.

If the Dashboard cannot be reached by the default My Cloud name method, try using the My Cloud IP address instead. One may have to access the local network router’s administration page to see what IP address it has handed out to the My Cloud.

If using Windows, ensure SMB 1.0/CIFS is enabled. Microsoft disables this setting in recent updates or in new installs.

If one hasn’t done so, try a 40 second reset as a troubleshooting step.

If all else fails, one can remove (shuck) the internal hard drive from the My Cloud enclosure and attach it to a computer using a USB to SATA adapter, docking unit, or spare SATA adapter. Then use either Linux or use third party EXT4 drivers on Windows to attempt access of the My Cloud drive contents.

Does it possible to write the firmware via Paragon or etc?

See my response to your exact same question in another thread. Trying to fix firmware issues varies by single bay/single drive My cloud version. Some methods involve using a Linux OS and may potentially destroy any user data on the drive by putting the My Cloud back to factory default state.

Hi All,
An update on the issue in this thread as posted by @QuiBoe:
The drive was moved to my house (different network, some more tools) and i took over the search. Status was blinking blue led, no IP to be found in my router. Make use of all your comments and other threads in the community (thank you all for that and especially @Bennor for all the summaries and links) went through following steps.

  • did the 4 & 40 sec resets, checked/changed network cables, power adapter. ==> Blue blink Led
  • Reboot with boot-USB ( fox_exe procedure) ==> Red blink Led now , with an IP adres now on the network, however no acces possible.
  • Removed the disk from the enclosure (nice youtube video’s out there) and mounted it an externa sata bay/device , usb connected to an Linux (mint) computer.
  • Ran GParted which unused 2,73 TB , ran testdisk which reconstructed the partitions and was able to see all the files now.
  • Copied all the files to other disks, one has be patient but recovering the files of QuiBoe is worth it.
  • Mounted the WD-circuitboard on the drive and connected network + power. ==> blinking red led, IP adres found, via webbrouwser connected and Safemode was indicated:
    Was able to find and upload the latest firmware (v2.31.204). Could configure the drive, left auto FW update to No. Skipped te part on RAID configuration, the only choice is empty now. Performed and systemtest ==> error on station1, Disk test ==> ok., FW is seen as updated However capacity is 0 MB
    Performed the the setting RAID modus in the WD menu , setting it to JBOD. (the only choice). Looks ok , in such that 3TB is found

    However ends up in error Hard Drive(s) Formatting Failure (Error Code:600)
    and a blue flashing Led on the WD-device. Once more mounting in satabay and running Gparted shows no partition, running Testdisk restores the partitions and disk is once again seen in the WB-circuitboard/network setup.
    Tried several times also paying attention to unmounting drive first form linux, or power down the external bay first etc. as suggested (and being a solution) in an other thread.(on this error 600)

But remain unsuccessful…
Now looking for pointers towards solving the RAID change error ie bringing back alive the WD my Cloud. (and upload the saved / recoverd files)
Thanks for your time