My cloud 3TB blue LED blinking nonstop - solution?

Good afternoon, first, sorry for my english,

I wrote this post here because I see it as last chance…
I had also email communication with WD support but didn`t find any help solution, read forum here but people have same problem I see but without solution

I will describe problem:

(First very short describe - blue LED on front side is blinking all the time, cant stop after one week of continuous work, cant reach drive anymore)

I have WD My cloud 3TB, bought November 2016, everything worked perfect, I used it everyday for watching movies for my son.
Every midnight it wakes up and syncronize or something like that, after 10 minutes came back to sleep mode until i play again any movie…

Problem starts in December last year when I came to room and listen disc is working at unusually time and work all day…
It didn`t came to sleep mode whole day… I saw on front side blue LED is blinking all the time… Wait 3 days if something happened but no result.

I cant reach drive from my TV, android box, PC, I dont see it anywhere, every device wrote its not accessible.. I cant connect on PC to drive - write me it`s offline (home internet and rest of devices works perfect)

I have read all posts about this problem on all forums but didn`t find answer. Then i changed lot of emails with WD support and they gave me these answers to fix my problem:

  • connect My cloud directly to PC - can`t see it as a drive - in browser shows it as offline drive
  • make 4 seconds reset - done, without change
  • make 40 seconds reset - done, nothing changed
  • check backside LED colour - everything ok
  • changed cables - no change
  • I wait one week to “finish” firmware update (WD support idea) - nothing changed (I wait 9 days in this mode, when disc was working and front LED blinking blue - reason? WD support wrote wait because it`s indexing)
  • next email from WD support: take off drive from cover and connect it with SATA to PC and use some LINUX program in link they sent - didnt try yet because Im afraid of damage and never use LINUX, don`t know how to use it…
  • suggest from support: in case this doesn`t work - contact one of our DATA RECOVERY PARTNERS

That`s all support from WD :frowning:

I turned it off during christmas time and affraid it turn on… Im sad, I think I lost all my data, cant connect anywhere and disc is still not working - still blinking blue LED on front and not reachable… I`m very dissapointed that this happened with disc which has to work more than 2 years :slightly_frowning_face:

Do you have any solution to my problem? Tell me please whats happened with My cloud that I cant see it anymore and LED is still blinking after connecting to power? thx

1 Like

What Linux program did they send you (I assume via email)? What is the name of the program? Can you post a link to it?

The flashing blue LED seems to have cropped up for some after the last firmware update. No real solution yet other than possibly running one of the unbrick methods where you just push the firmware to the drive.

hi Bennor, thx for answer, this was in email:

First of all, I would like to express my sincere apologies for the inconvenience this issue has caused and let you know that you could remove the hard drive from the enclosure and connect it externally to your computer with a SATA to USB cable in order to check if the data can be recovered by using a Linux Filesystem reader (Disclaimer).

Hi, robertl1. I have the same problem after firmware upgrade a few days ago. The cloud reboot after upgrade then blue LED blinking all the time. So I opened the cloud & took the HDD out with USB cable to connect my uBuntu (created by vmware). Thanks a lot the data is still there. I want to check what is going on with my cloud. So I opened a serial console with _UART_Pins on the motherboard to look any abnormal boot msg. The msg. was the following:
EXT4-fs (sda3): warning: mounting fs with errors, running e2fsck is recommended
EXT4-fs (sda3): recovery complete
EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
EXT4-fs (sda7): recovery complete
EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: (null)
umount: can’t umount /usr/local/tmp/image.cfs: No such file or directory
rm: can’t remove ‘/usr/local/tmp/image.cfs’: No such file or directory
umount: can’t umount /usr/local/tmp: Invalid argument
EXT4-fs error (device sda3): ext4_mb_generate_buddy:758: group 2, 0 clusters in bitmap, 21495 in gd
JBD2: Spotted dirty metadata buffer (dev = sda3, blocknr = 0). There’s a risk of filesystem corruption in case of system crash.

It looks like the /dev/sda3 was corrupted & the image.cfs could not be located. So I downloaded the ubuntu-on-usb.img.gz from with 8g USB stick, follow the instruction to copy uRamdisk, uImage, image.cfs to /dev/sda3/boot after execute command: mkswap /dev/sda1 & mkfs.ext4 /dev/sda3 . (Note : my cloud is gen 2 version). Then the problem was solved and I have a healthy cloud now!

Please refer the partition table of mine:
fdisk -l /dev/sda
Number Start (sector) End (sector) Size Code Name
1 2048 4196351 2048M 0700 Linux swap
4 4196352 6293503 1024M 0700 Microsoft basic data
5 6293504 8390655 1024M 0700 Microsoft basic data
6 8390656 12584959 2048M 0700 Microsoft basic data
7 12584960 14682111 1024M 0700 Microsoft basic data
3 14682112 16779263 1024M 0700 Microsoft basic data
2 16779264 5860533134 2786G 0700 Microsoft basic data

I wish to help you. Thank you!

Hi all,
thanks for answers… I thought it will be easier… :frowning: just plug in drive again, download some aplication and that will do some repair… (checked also some YT videos but without solution)
Im not familiar with ubuntu or linux and all this codes, Im only simple user who wants to use My cloud as everyday user… :slight_smile: Its a pity.. I didnt expect this disappointment and problems with My cloud and will buy another brand in the future…

I think no one can help me anymore here with some easy solution…

If someone in SLOVAKIA can “UNBRICK” my drive please write me, thx :slightly_smiling_face:

Thank you so much, I have my cloud working again!!
I just mount the sda2 (data files) and copy to /sda3(boot).



I will try to put here my steps:

Boot with the USB.

  1. Mount the data partition:
    mount /dev/sda2 /mnt/data

  2. Check if you have the files uRamdisk, uImage and image.cfs in the folder upload:
    ls /mnt/data/.systemfile/upload

  3. If the files exists, execute commands:
    mkswap /dev/sda1 & mkfs.ext4 /dev/sda3

  4. And copy the files from data to sda3:
    mount /dev/sda3 /mnt/root
    cd /mnt/data/.systemfile/upload
    cp uRamdisk uImage image.cfs /mnt/root/boot
    umount /mnt/root /mnt/data
    reboot -r

  5. Wait the WD disk start again and show red and orange led light and unplug the power and remove USB, NOW CROSS YOUR FINGERS your system should start healthy again.

I hope this can help you.