Rapid flashing blue light

Hi everyone,

I have my cloud firmware updated overnight. The next day I noticed rapid flashing light and can’t connect to it. It was perfectly working prior to the firmware upgrade. Can anyone help please as I need to access my files for work. Thank you in advance.

1 Like

If you have a 2nd generation My Cloud (Firmware 02.xx.xx) look at the User Manual for what a flashing blue light stands for. See Page 7.

If it continues to flash and will not quit come back here and see if someone can provide more information.

Thanks for the advice. I did had a good read. It appears the device is updating which confirmed by the email received. But to my surprise it seems the update has been taking a long time. This is the third day of having the blinking blue light. Anymore tips to solve this?

I am having the same problem. Three days now. A drive I cannot access - that has important work files on it - is as useless as an ashtray on a motorbike. I am going to have to look for alternatives to WD.

My cloud, after an update and a massive files delete and replace, blinks in blue since 3 days now. No access by the Web. Anybody solved this ? should I unplug it and replug ??? Thank’s

I tried unplugging the device for a good few hours but did’nt make any difference. I dont know what else needs to be done. I suppose ring the WD support group.

I’m in the same situation, my device can’t stop flashing blue light

Same here… help!

Its been at least 3 days now. How long will this take? I need access to my drive!

I also have the same problem. I think there’s a bug inside the firmware that makes this happen.

2 Likes

Me too!

Same here. They bricked our device.

It is not pingable, so the network is not running. Which means: no outside access possible.

Reset (4 sec, 40 sec) does not work too. The device is broken.

My solution: I ordered another NAS from another company. I have backups and will use the WD RED hard drive from the Mycloud which is probably still ok.

:unamused:

I am trying the solution described in:


But at the moment the unit remains with the led flash in red.

I also have some problem. Who can help us?

You can access the device with telnet by booting a different kernel with a USB-Stick.

This is only for hardcore Linux experts who can mount filesystems and use the shell. Be aware that you can lose all data if you make a mistake.

Connect the Mycloud to your router (with DHCP server).
Boot the system from USB-Stick.
Telnet into the device (no password).
Save your data first over the local net.
Setup a completely new device (with loss of all private data).

You can unplug the boot USB and plugin an external USB device to save your data. Mount the new device and use tar for bulk copy.

Follow instructions here:
http://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

I have managed to recover my WDmyCloud NAS 2Tb Gen2.
Indeed, the easiest method is to boot the NAS from the USB memory.
I have used only Windows and have followed the instructions “Linux” from the NAS with accuracy. Deleting data etc. The advantage of doing everything via telnet is that there is no need to open the device or complicate with privileges and other usual Linux messes. There is no need to change sda ​​for sdh or anything like that because you are managing the operating system of your NAS that only has a hard drive and a USB stick.

I tell you how I have managed to follow the instructions of that link
http://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

You need the file My_Cloud_GLCR_2.30.193.Bin to use it right at the end of the process:
https://drive.google.com/file/d/1dTv3dvdObIg943Ym0W2tdX5k0K7WJMSD/view?usp=sharing
And you need the following file to prepare the bootable USB memory. The name is usbrecovery.tar.gz and you have to unzip it directly on the USB stick with WinRar or similar:
https://drive.google.com/file/d/1Gm28LaJUGDIvv93rUnwQqe6DTFq2vFuZ/view?usp=sharing
If you unzip it correctly, you should only see the “boot” folder inside the USB stick and four files inside it. These:
uImage
uImage-wdrecovery
uRamdisk
uRamdisk-wdrecovery
I have noticed that the boot works only once and the led turns orange / yellow and red in my case. If you try to start a second time, the led does not turn orange / yellow. You must reformat the USB memory and unzip the usbrecovery.tar.gz file to retry the boot.
It should be borne in mind that routers with DHCP IP range type 192.168.0.xxx it may happen that the NAS does not acquire a valid IP. At least with the router that I used. When I tried again on another DHCP router with a 192.168.1.xxx range, it did respond by delivering the following MAC: 00: 50: 43: 02: 02: 00 instead of the real mac.
With the software for windows NETSCAN I searched for the IP. There are many ways to search for the IP.
https://www.softperfect.com/products/networkscanner/
To connect to the device via TELNET I downloaded and installed Putty software on Windows.
https://www.putty.org/
When you connect with this program, a “linux” screen of the NAS device appears. This is where you have to write everything described in the instructions in the link http://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/
Doing so deletes the entire hard drive. The data will be erased, obviously.
When you get everything done and access via Web, you must upload the firmware (My_Cloud_GLCR_2.30.193.Bin) that you downloaded before.
That is all.
I know. It is the same as other users have already explained …

1 Like

Thanks, Pieter, for your success report!

Some minor remarks: You can indeed boot many times from the same USB stick. Nothing gets deleted. Rebooting means: power off/ power on :slight_smile:

I’m still evaluating if it is necessary to set up the device “as new”, losing all data. Maybe you can recover without formating the different partitions.

I will report about it here when I have the time to do so.

Thanks! I am now impatiently waiting for further news from you : )

Has anyone had any luck using the WD data recovery partners? There are things on my drive that aren’t backed up that I would really like to save.

You can save all your existing data to an external USB drive.

Your data drive on the mycloud is /dev/sda2. Mount it to /mnt/root.

Your USB drive is /dev/sdb1 or /dev/sdb2, depends how you formatted it.

Once both drives are mounted, you can move over all your data.

Your external USB drive should be formatted as a Linux filesysten (ext2/ext4). A Fat32 (Windows) system is possible, but you get serious trouble if some of your files are over 4GB.

Finally I got the Mycloud running again, WITHOUT losing my data.

I can run the web interface and can login via SSH.

BUT … big BUT: while the data on /dev/sda2 is still there, filesystem is fine, the device can’t see it. Even if I mount it my hand, the web interface says: no volume found.

There must be some trick… any ideas from the hacker community?