4TB My Cloud disappeared- Fast blinking blue light! HELP

#1

Hello, 2 days ago, my cloud drive (WD 4TB My Cloud Personal Network Attached Storage - NAS - WDBCTL0040HWT-NESN) disappeared from my network, The drive is directly connected to a Linksys router and, up until this incident, I never had any problems with it.

I unplugged/plugged back everything, but the power led (blue) is blinking endlessly. The drive does not show on the network, neither on my notebooks, my cellphones or smartvs. I cannot access it via dashboard (http://wdmycloud/) .
I can hear (& feel by touch) the drive working, but it has been over 24hours of the same behavior.
A couple of weeks ago, I’ve checked its status and it was healthy, no problems reported. Everything seemed up-to-date.

I do not know it the drive downloaded and try to install a new firmware version. Was a new firmware just released during the last week?

So far I managed to manage my anxiety of reseting, trying opening the case, etc, but I need to access my data!

Can someone please help me on what to do? I’ve read on different forums that this MIGHT be that the drive is rebuilding the raid and this might take up to several days. - But how can I be sure?

What else can I do?

Would it help to connect the drive to a notebook via a USB cable? But that would mean, that I would have to unplug the drive first.
Doing this should show me locally the drive immediately?
(I only have a USB2 male-male, not a USB3).

HELP!

#2

I can’t help but can confirm I have the exact same problem and have only encountered it in the last 24 hours or so. Mine was working perfectly before then.

I have tried to connect the drive directly to my PC (i.e. not via the router) but same result - endlessly flashing blue light

#3

Are you saying you could not see it in your network on your router? Do you use Linksys Smart Wi-Fi?

When this happened did you check to see what the LEDs on the rear were doing, if anything and what was happening on your router for the My Cloud connection? What is showing on those LEDs now?

#5

The hard drive is NOT visible on the router using Linksys Wi-Fi, (I don’t see it’s MAC Address). I do see it connected on the router port. If I disconnect it or move it, I see the connection physically showing on the router, NOT on the Lynksys wi-fi dashboard. The lights on the drive ethernet port, the bottom is always on, the top is almost always on, but it flashes, as if its trafficking…

The status of the drive it is the same as yesterday. Still flashing blue.

Does it help anything trying short/long reset or should I have to wait?

#6

@Pepegrillo It sounds like you have a second generation My Cloud. Look at this information and the User Manual for your generation of My Cloud. WDMyCloudImage

#7

If the led is not flashing yellow on a gen1 or red on a gen2. The My Cloud is connected to the network. You should be able to ping the device. I would use some utility that scans the local network and shows all of the ip/mac addresses that are connected.

#8

That’s the one. The only thing is that on the owner’s manual it does not say much about my problem.

Today I unplugged the drive, and tonight I’ll see if connecting it via USB or using another router, I can at least see it. I kinda doubt that a 4tb drive that is only 40% full would take over 48hs to rebuild, if that’s what happened to it.
Worst case scenario, if I lost the data, I would, at least, like to be able to reset to factory the drive and set it up once again…

#9

The only leds are:
Flashing Blue on the front (which is the power led as wel)
Green on the Ethernet port,
No yellow, no red.

I’ll try using a different router connecting only My cloud and a notebook to see if I can find it. because I already tried using Linksys wifi dashboard and could not find it on the network map, or ping it to its reserved IP address (i don’t have that many devices anyway, so finding it should be a 30 seconds job, but it does not show)

#10

You cannot use the USB port on the My Cloud to connect to another computer. The computer won’t see the My Cloud. The USB port on the My cloud is for connecting external USB hard drives.

#11

oh…:pensive:

I thought I could,
So, the only thing left is trying to find it via Ethernet & a router on the network?

#12

The single bay/single drive My Cloud devices are, at their core, a network attached storage device (NAS). They are designed and intended to be connected to the local network using the Ethernet port on the back of the My Cloud enclosure.

#13

Update… I’ve tried connecting the drive to a new router, used an IP scanner, no luck, it does not show.
Now I did a 40 second reset, still blue light flashing, 2 hous after. So… I guess that this did not solve anything
A) Is the drive still trying to rebuild the image?
B) What happens if I now unplugged the drive?
C) I reset the drive while the Ethernet port was NOT connected. Does it matter?
D) I decided to connect the Ethernet port (the router is NOT connected to internet). Something weird that I noticed. the BOTTOM ethernet light, has turned to AMBER. This happens wheather a cable is connected or not. Should this add to my worries?

#14

Does the color of the blue led change color when you disconnect the network cable from the My Cloud. The front led can change colors.

PS amber light on the back may mean 100MB with green meaning 1GB.

#15

Hi, I had the same issue. The problem is with the FW version 2.31.174 (Released Mar 26th).

Thanks to the gentleman / woman who had posted the following steps, i was able to recover my WD NAS. Follow the listed steps.

  1. Download these files:
    The product support site only gives you the latest (but faulty FW). Don’t pick this. Pick the FW from:

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/ (Version 2.30.193). Store it in your laptop.

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz (WD Recovery + My miniOS)

  1. Use any USB Flash drive, format it to FAT32 (Important!)
  2. Unpack usbrecovery.tar.gz to this drive (You will get “boot” folder and 4 files inside)
  3. Plug this USB drive to WD MyCloud, turn on power. Wait yellow-red (blinking) light.
  4. Connect via Telnet (Search IP in your router, unde DHCP section.)

This is a trial and error situation to find the right IP. If you router shows you the list of attached devices, try all the wired connections. Use the PuTTY tool for telnet.

  1. Install original WD recovery and reboot:
    Type each of these commands over the Telnet connection.

mkdir -p /mnt/usb /mnt/root
mount /dev/sda3 /mnt/root
mount /dev/sdb1 /mnt/usb
cp -r /mnt/usb/boot /mnt/root/
cd /mnt/root/boot
rm uImage uRamdisk
mv uImage-wdrecovery uImage
mv uRamdisk-wdrecovery uRamdisk
cd /
umount /mnt/root /mnt/usb
sync
reboot -f

  1. After reboot device get old IP address and accessible via Web-GUI (Recovery mode). Use original firmware (.bin file) here (2.30.193).

Done!

  1. If you wish to not run into the same trouble again, remember to turn the auto FW update off.
#16

The front LED is still blinking blue. What puzzled me was the amber light on the ethernet port. still ON even though I unplugged the cable.

As of friday night, after doing the 40 seconds reset. I left the drive rebuilding (or so I hope), and I decided to let it take until monday night, before trying something else (what, I don’t now - maybe open the case, unpluging and pluging back everything, hoping for the best?? :slightly_frowning_face:)

#17

Ok, this is fresh info.
What scares me is…If I do this, I’m LOOKING FOR (in puropose) for a "yellow-red (blinking) light."?
I Thought those were BAD.
Then… the current situation is that, while the blue light is blinking/fast flashing, I DO NOT see the drive on my network (i used a different router, just connecting the drive and my notebook via ethernet, then using an IP scanner)
So… if I do this, you’re telling me that after booting via the usb flashdrive I will find the drive on my network?
Then…let’s say I find it. to what port do i connect via telnet, 80? 21? I don’t specify port?

One last IMPORTANT question. do I lose all my data?

Thx

Sebsa

#18

You still didn’t say if the led changed color when you pulled the Ethernet cable.

#19

The front led always flashing blue. The ether net led port light. Remained amber AFTER pulling the chord.

That’s no the case anymore though, onnfifsy night I fifi the 40 seconds reset with the drive unconnected, so, obviously, no lights on the back.

48hs ñater

Stiññ flashing blue on the front. I hear disk acticlvity. Should I still wait? Or am I losing time? What else could I do?

#20

Let me explain the recovery method. Since the WD NAS is bricked, you have to boot it with a USB stick that contains the boot (read recovery) image (uImage - Linux Kernel & uRamDisk - Filesystem). The preparation of the USB boot disk involves the above.

Once you insert the USB boot drive and power on (insert & then power on), the flashing blue light would stop and turn to yellow-red blinking. This means WD has booted up with the recovery image. The recovery image contains a minimal DHCP client that gets an IP Address from the Router. Mind you, this may not be the same IP address WD was getting during its working days.

There are 2 ways to get this IP address. Method 1 - Login to your RT. Go to LAN settings / menu. Search for attached devices. One of the IP addresses must correspond to WD. Usually there is an IP Address + MAC Address mapping in this list. I noticed, the MAC address wasn’t coming right. This is a trial and error part.

Method 2 - Netscan should also give you the same info as the router.

Now, to the Telnet part. Install PuTTY. A very simple low footprint tool. When you launch it, it provides different connection options. Default, i suppose is SSH. Select the Telnet button. Port number will default to 23. Enter the IP address and connect. You get the WD shell from where you need to type the listed commands.

The recovery image runs a minimal web server. So when WD reboots with recovery image, it comes up back with the original IP address and can be accessed through the web. Note, when WD restarts, remember to pull out the USB stick. Otherwise, it will again boot with the USB disk, not the recovery image.

No, you won’t lose any data. This was possibly an untested FW that screwed up all the devices. After I recovered my NAS, I loaded the newest image again to test. It got to that bricking stage again.

Firmware update killed my My Cloud 2TB
#21

The links you provide to anionix.ru no longer work. That domain seems to have been abandoned.