4TB My Cloud disappeared- Fast blinking blue light! HELP

#22

Does anybody know where to find these files?

#23

See the following link which is an alternate to the anionix.ru site.
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU

Direct link to the usbrecovery.tar.gz file: https://drive.google.com/open?id=0B_6OlQ_H0PxVUWdCU01DcTdMWk0

#24

Thanks a lot for the info, Now I understand the process and I’m not afraid to an upcoming yellow/red light.

I do have a couple of questions

  1. Am I wasting time, by leaving the drive on watching the blue blinking light? (I performed the 40 seconds reset on FRIDAY NIGHT Thats almost 60 hours by now) - I left the drive NOT CONNECTED TO ANYTHING (no ehternet)

  2. Under normal circumstances. would the drive come to a steady blue light with NO Ethernet cable connected to it?

  3. On the post where the firmware was mentioned, I was recommended to download a previous FW version, unfortunately to a domain that is no longer active… so, I ALREADY downloaded the BOOT software from the other new link provided… but as far as the firmware goes. …

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/ (Version 2.30.193).

If the current fw on my drive is corrupted (this is what people are saying caused the problem). So, do I NEED to download a FW version from somewhere or during this boot process the corrupted fw will be overwritten, that is… I should forget about the firmware?

If NOT, and I DO neet to download a firmware, not the latest, (Firmware Release 2.31.174 (03/26/2019) ) the only providaded by WD, any help finding this previous FW version (Version 2.30.193)?

  1. And Finally, this one is important. What’s the average time for this process to complete?. Am I looking at days, hours or minutes?

Thanks ALL for your help. I’m still hopeful of getting NAS back :slightly_smiling_face:

#25

The following Google Drive link is a mirror of the anionix.ru link (hosted by the same person)
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU

One can download earlier firmware for their single bay/single drive My Cloud model from the following link:

#26

THANKS FOR YOUR CONTINUOUS HELP!

Mine is a Gen2 Mycloud 4Tb, which fw do you recomend I download? Because, previous to this, the auto firmware update feature was ON, so, I would assume that previous versions to the one of march 26, were applied succesfully and the recomendation was using 2.30.193 (5/8/18)

So, should I go for 2.31.163 (1/8/19)? or 2.30.193?

2.31.174 (03/26/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.174.bin
2.31.163 (01/08/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.163.bin
2.31.149 (10/18/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.149.bin
2.30.196 (09/21/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.30.196.bin
2.30.193 (05/08/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.30.193.bin

Blue light fixed on wd mycloud, (not quite) - need to rebuild access to files1
#27
  1. Yes, you are wasting time with those 4 and 40 secs resets. Nothing will happen.
  2. No, lack of Ethernet connectivity (under regular operation) will show up in the LED. Don’t fret about the Ethernet cable and its LEDs for this issue.
  3. Take 2.31.163 (01/08/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.163.bin . The last stable one.
  4. 15 minutes is all it takes to recover.
#28

OK. I’ll proceed tonight, then… fingers crossed :crossed_fingers:

Thanks everyone!.

I’ll keep you updated on the drive status

#29

Hi,

I have the same issue.

I tried to boot with the USB stick with the folder “boot” inside. But the led is still blinking blue (fast).

:confused:

#30

I have the same problem as you. I did get a red/yellow light using a USB stick with the recovery tool (starts flashing blue, takes 2-3 minutes to get to red/yellow), but the device didn’t get an IP so I couldn’t do anything. So don’t get your hopes up. Time to open up the case and see if I can copy the files somewhere else.

#31

Are you sure? When I tried to boot from a recovery USB. Even though my router has reserved an IP address for my device. The recovery USB ended up with a different IP address. In my
case .247. So check with your router to see what address it assigned to the My Cloud.

#32

Update:

A LITTLE progress, but no success (yet). Still need help

I used the pendrive - Amber/red Flashing light
Found the IP address on the router - One curious data, the MAC Address does not match the one on the bottom of the drive - (the one reserved on the router)

I downloaded and installed PuTTY (0.71) - I double clicked on putty.exe, On Session field, I completed the IP Address and changed to port 23 (by default was 22). New window opened, and stayed there a green block cursor, could not write, or do anything.
So I closed the window. I tried using the command line: psftp (ENTER) open IPA.DDR.ESS.xxx 23 and I get : FATAL ERROR: Incoming packet was garbled on decryption

Anybody can help me how to pass this?

#36

Latest Update…

First, once again, I am puzzled by the fact that the MAC Address that I found, was different that the one i have registered for the drive (which is also the one the label) booting from a pendrive should NOT change this…should it?

Anyway, moving on.

No luck with PuTTY, finally I connected using Windows Telnet client and i got a prompt /#

I wrote and enter all the commands always ending with a prompt back…
Except when I entered umount /mnt/root /mnt/usb

I did not get a prompt back, just the cursor.
Minutes went by, I started typing, but nothing really happened.
After an hour or so…, I closed the window, unpluged the drive and plugged it back on

To my (sad) surprise the drive started with a blinking blue light, and after about 30 seconds, it changed into a red blinking light…

I finally got to how PuTTY worked, (I was using as SSH when I was supposed to used TELNET), anyway, tried the same procedure with PuTTY and with a couple of telnet clients, but I always get to the unmount command then nothing… last time, I left it there, writing NOTHING after the umount command and hitting ENTER, for 8 hours. Still nothing happened. Still blinking red light when it turns on without the pendrive

What happens on the umount command? - I’m no unix user, i read about the command, but i just don’t know why I don’t get ANY response from it… is there any way of knowing what`s going on?

Better yet, any alternative procedure?

PS: The drive seemed to be working (reading/writing noises) all through the night (it was on my bedside table)

#37

Unmount will hang if you didn’t execute the “cd /” command before. I trust you did that. Just to eliminate that possibility. Try to format the USB drive (to FAT32), copy the files again. To eliminate any errors on the USB drive.

Since you are stuck anyway, you may try without the umount command. There is a “sync” command before the reboot. Try that and reboot. During reboot the unmount happens automatically. The unmount and sync are to ensure the copied files are properly done.

On the RED blinking light, there is a thread. The red light keeps blinking. Including the Ethernet connection not being proper…

#38

First, thanks for your help!!!
Now… Yes I entered the cd / command before.

I will try formatting the flash drive and copying everything again and just to rule anything else, I’ll do it into another flash drive.

It there a command that I could run that shows me if there’s something happening?
Sync should take… How long before getting the prompt back?
Using putty to telnet or windows telnet is the same thing, right?

The red light… I don’t know that’s new…which worries me, because something obviously did change after I ran the sequence. And I get the red flashing light on the front, with or without connecting the ehternet cable.

#39

The gen2 front led turn red when the network cable is pulled.

#40

It didn’t happened before. Before it was blinkg blue regardless of whether there was or not connected. Now it’s the opposite, red whether it’s connected or not…

#41

Cross posting my post from another recent thread where the flashing blue front LED is being discussed. The following link deals with the second generation (v2.x firmware) single bay My Cloud and the two methods used to attempt to unbrick it and restore the firmware to it.

If you don’t know which single bay My Cloud version you have, check the P/N number on the bottom of the enclosure. P/N ending with -00 indicates first generation v3.x/v4.x single bay My Cloud units. These units have a slightly different unbricking process than the second gen units. P/N ending with -10 indicates second generation v2.x single bay My Cloud units. The link above deals with the second generation units.

#42

From bad to worst?

So, i bothered one of the IT guys of my company, to see if he could spare me a few minutes
He tried the steps and got the same results.
He was able to navigate through the drive and found the partition (I think, he told me something3?) where all the files were…

He also opened several telnet windows and was able (don’t know using what commands) to tell me that, on one of the steps, there was a problem creating one of the partitions

He told that using the command e2fsck /dev/sda3 to repair the partition

After this, he booted once again, using the flashdrive and this time TADA!!! all the steps
No errors and no delays with any of the commands :smiley::smiley::smiley:

However, :pensive: after the reboot -f command, we weren´t sure when to remove the flashdrive. we tried it right away and the telnet connection died, but the drive did not came back (same amber/red light)

We tried hitting enter and inmediately pulling the flashdrive - nothing (same thing)

reboot -f and a couple of seconds after getting the prompt back, unpluging the drive, pulling out the flash drive, but no luck…

Whenever the drive boots without the flash drive, after 30 seconds or so, RED FLASHING LIGHT

So…there’s the situation

Now the questions

He told me that MAYBE the files on the pendrive where not correct for the drive BUT I’ve checked I have a gen2, the files that I downloaded were supposedly for gen2 mycloud… I already tried a different pendrive

Can I run a check disk of the entire drive from the usb booting pendrive?

He told me that MAYBE the files on the usb flashdrive were not correct for my hard drive BUT i checked and I DO have a gen2, and these files are for gen2 mycloud…

Can I ran a check disk of the entire drive, using the usb flasdrive? If so? how?

Since I see that the files are there…can I copy them somehow? (how?) - The IT person told that copying with telnet is practically impossible and slow. That if the booting flashdrive had SSH there would be a different story

If I can access & copy the files (there about 300Gb of files that I would really need), then I would move to formatting the drive with no problem…

Unfortuntately I can’t take any more time of IT…

Anybody can provide help?. I don’t want to give up on my files just yet.

Still hopeful

#43

When you and the tech were booting the device was it connected to the internet?

#44

Nop. It was only connected to the router. No internet