The red light keeps blinking

Hi there,
Today I found WD My Cloud’s power light turns into red and keeps blinking. I checked the router and I found that I am unable to access the dashboard anymore. Can you guys face such issue before? If yes ,what’s the solution?

@blacklsj

First you need to determine which generation of My Cloud you have, a 1st generation (04.xx.xx) or 2nd (02.xx.xx) and look in the correct User Manual at LEDs. Use link below.

If you can’t solve the problem after looking at the User Manual then let us know.

Hi CatoW, thank you for your advice.
I have found that mine is second generation. The temperature is ok and the router is working properly, I replaced a new ethernet cable. So I think it might below reasons that red LED blinking. So what should I do next step?

Fault/action required Red Blinking The following faults trigger this state:
• Disk SMART failure
• Data volume does not exist
• System volume does not exist
• System thermal shutdown (75 C)

A gen2 will also blink red when there is not network connection.

Hi Rac8006,
I changed the ethernet cable and the light of rear port are green. I think the connection is ok.

I replaced a router and plug in the different ports but the same issue. Almost despairing.

Have you tried the 4-second and 40-second resets? See the user manual for details.

Yes, I tried both but it does not work.

Sounds like it’s pretty serious. Time for serious measures…

Hi CPT_paranoia,
Thank you for your post.
I know my cloud has turned into the brick, but I don’t have the sense to do the unbrick stuff i. The retailer shop said they could give me a new one because I am under warranty if don’t mind the data inside. However, I really mind the data inside because I use it as the backup, I might be wrong, I should use the portable external hard drive to store my data as before. I thought NAS is more reliable and safe. The data recovery in New Zealand authorised by WD is only one, they quote me the cheapest cost is NZ$800, it is crazy.

It’s a hard drive, and is no more reliable than any other.

It’s only a backup if it’s a copy of data held elsewhere. If you have no other copy, it’s not a backup, it’s your primary data store.

If one opens up the My Cloud they’ll find (typically) a WD Red SATA hard drive. Hard drives can and do fail.

One method of guarding against hard drive failure is to run an NAS capable of multi hard drive RAID. This way if one drive fails the other drives of the multi bay unit remains accessible.

For the single bay My Cloud one can backup the entire My Cloud hard drive using the My Cloud Dashboard > Safepoint (first gen v4.x My Cloud) or My Cloud Dashboard > Backup (second gen v2.x My Cloud). This will backup the My Cloud contents to a USB hard drive attached to the My Cloud’s USB port.

Try following the second link:

Someone who didn’t seem very confident about their technical skills, managed to recover their data, using a trial version of an extfs driver.

Ran into the same issue and as this page shows up on top of the Google search results I thought I’d share my solution as probably still some MyClouds are in use. In my case one of the disk’s file system was damaged, but it can be fixed rather easily if you feel comfortable working with the Linux cli.

Short version: Get the disk out of the case, connect it to a Linux machine using a SATA => USB adapter, run fsck on all partitions, put it back in the case, voila, it works.

Long version:
1.) Get the drive out of the case (Western Digital My Cloud NAS - WD 4TB öffnen und Daten retten sichern - YouTube)
2.) Connect the drive to any machine running Linux (I used a raspi), either via SATA or with a USB/SATA adapter
3.) Find the correct harddrive and partitions by running sudo fdisk -l /dev/sda Might well be sdb, sdc, … in your case. Make sure it is the drive connected and not one build into your host machine
4.) Run this command for every partition on that drive (that is, sda1, sda2, sda3, …):
sudo fsck /dev/sda1
5.) Put drive back in case, reconnect. For me it worked now.

1 Like