MyCloud gen2 sometimes falls into low speed mode after upgrade to 8TB

I was quite happy user of My Cloud gen2 4TB for several years, but now i need more storage space, so decided to upgrade hdd to 8TB.
I purchased WD My Book 8TB for good price, took out the hdd, and carefully tested it and use for My Cloud upgrade.

First i followed this replace guide here:

All worked fine until time to upload a new firmware, i always ended here with endles waitiung loop after i selected a firmware file. I tried more different fw versions according various advices here, but nothning helped.

Finaly i tried another guide, with few little differences and it was successful:

My Cloud is now fully working, with good speed (on 1GBit cable 110MB/s, 50-60MB/s on G5Hz wifi, on Netgear R7400).

But sometime it behaves weird, webGUI is significantly slower that before, and sometimes transfer speed decreases to very very low, max 10MB/s on big files, and only low kilobytes/s when transfering smaller files.
Nothing helps, only restart of MyCloud device. After cloud restart the same file transfer is resumed in good speed (above 100MB/s).
After some time (hours? days? I’m not sure when and why…) it again falls into “low speed mode” and only mycloud restart will solve it.

I’m sure it is not hardware problem, i never experienced this with my cloud device before hdd replace, and new 8TB is also carefully tested and 100% ok.

Any ideas how to solve this?

The My Cloud OS likes to keep some services (like indexing) running in the background. These services can slow down the My Cloud Dashboard or make disc usage slow. One can search for “sleep” and see some of the services one can disable. Note: disabling services may impact one or more features one may use with their My Cloud.

The other major cause for sluggish My Cloud is if one uses Remote Access and the Media Servers (Twonky and iTunes). Disable all three of those services and see if the My Cloud responsiveness improves. Continual media scanning of a large media library on the My Cloud is typically the culprit for some.

Bottom line though the single bay/single drive My Cloud hardware (processor and RAM) are the reason why the unit can be sluggish. Nothing you can really do about that other than bump up to a better more capable (hardware wise) NAS box. Everything we users to do improve responsiveness is ultimately constrained by the weak hardware and RAM of the unit.

I use My cloud as shared network drive only, so i disabled all Media services, DLNA, iTunes.
There is now same settings I had before hdd replace and I never experienced so noticeable drop of transfer speed (which dont recover even after waiting…).

I can see 60 running services via webGUI. Maybe some can be stopped to gain more system resources and speed. I need just basic cloud access via shared network drive. Nothing more.
How many services can i stop?
Is there some ssh script that can do this? (and then recover it back, if needed).

Do a search (using the forum search feature) for “sleep”. There is a lot of discussion on which modules to stop or disable that could improve a sluggish My Cloud.

For example, on a first gen My Cloud one can try the following entries in the S98user_start script.

# Attempts to fix sleep issue with Samba
/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start

# Stop certain unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /

# Stopped My Cloud services
/etc/rc2.d/S20restsdk-serverd stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop

Because you replaced the hard drive it is possible the hard drive itself could be an issue or the cause. Certain hard drives are not designed for NAS use and may behave in unexpected ways under constant use. Some drives use SMR rather than CMR which may cause issues in certain NAS enclosures. As a troubleshooting step one should also rule out possible network issues or router issues. One way to is to isolate the My Cloud by connecting it directly to the computer, bypassing the router entirely.