HDD Replacement from 4TB to 500GB


I have a WD MyCloud 4TB (P/N WDBCTL0040HWT-10) and it had the firmware version 2.30.181.
The HDD died and for now I’d like to use a 500GB WD Green drive.

I’m pretty confused about knowing what Gen it is. I’ve tried Fox’s methods for both 1st and 2nd generations (from this link: https://drive.google.com/drive/u/0/folders/0B_6OlQ_H0PxVZTBtM3EyRVhDVms, but every time when I put back the drive and turn it on the MyCloud light flashes red. I know the 500GB is functional 100%.

Hope somebody could give me some hints about what to do. Do I have to use other sizes for the partitions? If more info is needed, please let me know :slight_smile:

Firmware version 2 shows it to be a gen2.

Firmware version 3 or 4 would be Gen1.

Yes, we know it makes no sense…

1 Like

Thanks! it really makes no sense for me as well… but oddly, even when I try the method for the Gen2 it doesn’t work and I get a blinking red led.

Did you use these directions for the v2.x single bay My cloud? There are two methods in these directions, if one doesn’t work, try the other.

Make sure to follow the steps exactly.

Yes, I have the single bay My Cloud. I’ve tried only the second method. Right now I’m going to try the first method and will let you know how it goes.

Well, I tried the 1st method and again, it flashes red. I got the usbrecovery.tar.gz from another site, because the link in Fox´s instructions is down. Do you think this is affecting the final result? I honestly don’t know what else to try

This should be a direct link to the usbrecovery.tar.gz file on Fox_Exe’s Google Drive:

This link will get you into the Gen 2 My Cloud folder on Fox’s Google drive where you can browse all the files there and download what you need.

Sometimes files got moved after Fox wrote up the unbrick directions.