WD MyCloud stuck at safe mode

Safe Mode

Your device firmware appears to be corrupted and your device is currently running in Safe Mode.

Please download the latest firmware from the WD Support website at http:\www.support.wdc.com and upload the firmware file below:

Firmware Version: (BLANK)

I download the FIRMWARE and upload it, but it takes forever to upload stuck at the upload screen.
I had look at other thread with similar issues but none of them help.

very much appreciate anyone can help me with this issues.
I’m using Mac and my WD MyCloud is 2nd gen, with -10 product code.

Are you uploading the firmware from a computer connected via Ethernet to the same router the My Cloud is connected too?

Other troubleshooting suggestions. Try a 40 second reset, if you haven’t already, perhaps that might clear the firmware error. Power off the My Cloud and wait a few minutes, then power it back on and see if the issue persists.

I uploading the firmware via Wifi to the same router that My Cloud is connected too.

I should try upload firmware via Ethernet cable to the router that My cloud is connected to or direct using Ethernet cable between computer to My Cloud.

I tried reset with power on with 4 second reset, unfortunately not working.
perhaps I should try power off with 40 second.

Are you trying to download and install the latest firmware update? If yes, download the firmware to your computer desktop and then install it by opening the Dashboard and doing a Manual install. Use link below for the download.

Software and Firmware Downloads | WD Support (wdc.com)

I was unable login to the Dashboard to do the manual install.
my WD My Cloud was in safe mode.

@Jacksiow Have you looked at any of these? Results from a Knowledge Base search.

How to Update My Cloud Firmware in Safe Mode (wd.com)

Find Answers and Discussions (wd.com)

Hi @cat0w Yes, I had tried to look at knowledge base before I create this post, unfortunately none of them help.

I just try to do the rest, 4 seconds with power on and 40 seconds with power off. It didn’t help as well.

I also tried your link instruction, which download the latest firmware and upload it.
on my Mac, it just keep spinning and the process wont stop.
today I tried it on my window laptop (two different window laptop), I choose the firmware and unable to click “Apply” it just don’s respond at all.

@Jacksiow
Maybe it’s time to follow what is at the bottom of the page in that link.

. . . if you are heading down that route of data recovery. . .

. . .try extracting the hdd; place it in an external enclosure, and try to read the data with a PC.

Note that the HDD will be formatted with EXT4; so won’t be directly readable by a WinPC. You will need a driver (program) that can read EXT4 using LINUX in a Windows environment.

Just to make sure, you followed the following procedure for performing a 40 second reset?

To execute the 40 Second Reset :

  1. Power down the device and remove the power cord from the device
  2. Using a paperclip or narrow tipped pen, press and hold the reset button
  3. While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  4. After releasing the reset button the device will reboot

Note: This process may take upwards of 15 minutes. Please wait until the Power LED is solid blue, indicating the device is ready to use.

Edit to add: Couple of other suggestions. Temporarily disable any web browser add-ons/extensions. Its possible one of them may interfere with the safe mode page loading or uploading of a file. Same goes for any third party security software on the computer. Disable the security software and see if the issue persists.

If the firmware is corrupted to the point it cannot be fixed via normal methods then one may have to resort to using one of the unbrick processes. Down side with unbricking is one may have to erase the hard drive by re partitioning it. User Fox_Exe has directions (see the repository here: https://fox-exe.ru/WDMyCloud/ some here have used successfully to recover their single bay My Cloud hard drive. Its possible one might be able to jury rig those directions to just push the firmware image files to their appropriate locations (except the EXT4 user data partition). Like indicated above, if using windows, to recover or back one’s data from a corrupted My Cloud hard drive one will need third party Linux drivers or use a Linux boot disc/USB flash drive.

One other possibility. If one previously had SSH enabled and can still access their single bay My Cloud using SSH. Then it might be possible to push the firmware to the My Cloud using SSH. No idea if this works. No idea if it works on the second gen single bay My Cloud units. The two discussions below may only be dealing with first gen single bay My Cloud units. As always proceed at your own risk. Backup your data first (if you can). One will have change the URL’s for the firmware to download the latest one’s. See the My Cloud Support website for links to the latest firmware.

Hi @Bennor @NAS_user @cat0w,

thanks for all the solutions advised.

thanks God, I finally manage to upload the firmware after reset.
all of the data is still in the drive, I manage to back up all important data from My Cloud to another external hard disk.

then I run 3 different test available in the setting, System test (passed), Scan disk (passed) but both Disk test (quick test & full test) are failed, showing Drive SMART failure, code 3.

I try to replug all the cable and reboot the WD my cloud, finally manage to run and passed the Disk test (full test) after 8 hours. I will try to run both Quick test and Full test once more to be assure it’s okay.

anyway, should I be concern of the error or send to fix?

after the passed on full disk test, I run the first quick test unfortunately it failed again then i reboot the WD my cloud and passed on the second quick test.

then I run another full test which failed again.

I’m not sure what is wrong here.

A SMART drive warning typically (in most cases) indicates the drive is likely on it’s way to failure or there is serious issue with the drive. One should backup their My Cloud data immediately.

One can try to read the SMART info by using the following command (issued via SSH to the My Cloud).

smartctl -H /dev/sda

That command might give one a clue to what the SMART warning is.

If one wants to replace the hard drive inside their single bay My Cloud, there are a number of “unbrick” methods (or drive cloning options) that one can use. One can use the forum search feature for many past discussions on replacing the single bay My Cloud hard drive.

Edit to add: If one has a multi bay My Cloud model then see the specific subforum for that device to see how to replace one or more drives in that device.

@Bennor

I had backed up all of my data.

is there any way I can diagnosis or understand what’s wrong with the WD My Cloud before replace the hard drive inside.

My prior post explains one way to try and get additional information on what might be wrong with the drive.

One can try to read the SMART info by using the following command (issued via SSH to the My Cloud).

smartctl -H /dev/sda

That command might give one a clue to what the SMART warning is.

One would have to enable SSH through the My Cloud Dashboard > Settings section then use an SSH client (like Putty if using Windows) to issue commands to the My Cloud using SSH.

Another option is to remove the hard drive from the My Cloud enclosure and attach it to a computer (using a USB to SATA adapter, a spare SATA port, a SATA docking station, etc.). Then using Linux (or a Linux boot disc/USB flash drive) one can try and run Linux drive health programs against the drive to see if it can determine exactly what is wrong with the drive. Because of the custom nature of the My Cloud firmware one typically cannot download and run Linux programs within the firmware itself even though the firmware uses Linux. Doing an apt-get or installing programs to the My Cloud OS may render the firmware corrupt. One can find a number of online articles about how to check a drive using Linux.

Ubuntu is one popular Linux disto that can be run as a boot disc or boot USB flash drive.

@dswv42

appreciate your help.

@dswv42

there is nothing I can do or repair on the hard drive?
I think it’s not worth to buy a new WD red hard drive to replace it compare to get a new WD My Cloud.

@dswv42

alright.
thanks you all for the solution advised, luckily I manage to back up all my important data before it fails completely.

While one can attempt to fix certain SMART errors like heat warnings, once a drive shows errors like reallocated sectors that means the drive is on its way to failing. There are some software programs that will attempt to fix sector reallocations and other errors it is usually a stop gap temporary measure as the drive will continue to fail.

Note that the single bay My Cloud unit are typically no longer being sold as brand new devices rather they are either used or refurbished. WD is phasing out support for the second gen and the first gen is already no longer being supported. And the My Cloud Home, as many have unfortunately discovered, is not like the My Cloud, and is not a direct replacement for a single bay My Cloud unit.

One can replace the single bay/single drive My Cloud hard drive with another hard drive. In the United States the 4TB WD Red drive(s) typically can be found on sale from time to time for $100 or less at Amazon, New Egg or Best Buy. But in reality one could almost use any non SSD hard drive in the unit if they had a spare one laying around. Plenty of past discussions on replacing the My Cloud hard drive with a larger (or smaller) hard drive that can be found using the forum search feature (magnifying glass icon upper right). Search for “unbrick” or “unbricking”. What quite a few do is buy WD Easystore Desktop drives that go on sale from time to time and “shuck” the hard drive from it’s enclosure and use the bare drive in NAS enclosures from various manufacturers.

What ever one decides, it is always advisable to use the backup method included with the NAS operating system to guard against drive failure. On the My Cloud the backup feature is called Safepoint on the first gen or Backup on the second gen in the my Cloud Dashboard. Then its a simple method of restoring that backed up data to a new drive (or access that data on another computer when the NAS fails).