WD MyCloud Home Offline - Why?

I have a 4TB single drive WD MyCloud Home. It can be operating normally, but then go Offline for no apparent reason. It then seems to take numerous attempts to make it available again.

Windows 10 can see the device in its Network.
WD Discovery can see the device.
Rebooting the WD MyCloud Home makes no difference - still offline.
Rebooting the PC makes no difference - still offline.
Signing out in WD Discovery & Signing in again makes no difference - still offline.

I can re-try the Sign-out / Sign-in multiple times (maybe 5-10 attempts or even 25-30 attempts) and it remains Offline. Occasionally, it will work and it comes back online, but this may take hours, sometimes days. When it does come back Online, it rarely stays online for a full 24-hour period.

Why is the device going Offline ?

There is a limit of 5 SMB connections for one MCH device, at least earlier versions of firmware had that limitations and one connection has to be dropped upon a new connection. Open a support case to find out if there is same limit for the new firmware.

I have nearly the same situation. Got back to my Mac Studio for about some days in the morning, got a message that the mycloud firmware got updated and BAMM device is offline. Did so many reboots of the device, the router, tried different network cables with different CAT version ( i have high quality cables ) did everything. I mean everything what they mention in their FAQs and surely above, because i am not a beginner. I was able to download the debug log, because someone from the support told me on the phone i need to download, because they will setup a ticket, aske me a looooot of question and the better i can answer, the better they can help. They also told me that they need the debug-log as fast as possible

I did everything immediately in filled out every point in the form with all the details. and surely i uploaded the debug-log to WeTransfer, what they told me to upload there.

And you know what? Yesterday i got the mail from wetransfer that my upload will expire soon and no one downloaded anything. I replied to the ticket 3 times now and no one answered until now.

I am 100% sure nothing and no one will take this issue serious.

The alarm bells should ring immediately for everyone when they always recommend you to get your data recovered by experts which WD is partnered to. Ask yourself why WD isnt releasing a software you are able to extract your data when something like this happens. :wink:

I had lots of WD HDDs in my entire life until today and i had 4-5 headcrashs with the hardware. 2x WD Red. 1 time WD Blue and 1 time WD Green. And now the WD MCH.

I am the clown who always bought another one and another one. I spent around a week browsing through different forums and all i see is that people are disappointed by WD because they never help you.

I will never ever buy a WD product in my life again and i neve ever saw such a bad bad support from a company in my age of 50

WD support could be better but it is probably no worse than other large tech companies. The problems you have mentioned are many and disparate and likely have nothing to do with the OP. Read up on the many macOS versions changes and how low level macOS file operations have fundamentally changed that broke many third party devices.

Always have 3 copies of backup for your important data, one of them offsite and you will find yourself cursing the hard disk vendor a lot less. The MCHome is not a backup device, it is a convenient cloud storage hardware and the cheapest one for consumers.

I dont see the MCH as a backup device. It was installed to store all photos from my iDevices on there + the ones from my family. So there is no fundamentally data is lost, but it is annoying. And you cant tell that macOS is responsible for the faulty MCH. There are so so so so many other people around with the exact same problem and they are not on macOS. That is to easy bro to push this into a folder for apple issues.

The MCH doesnt work on ANY OS, because i tried Win, Linux, Ubuntu and also macOS.

And i thought i mentioned that i can read the debug-logs. I see what is going on here.

I told that the made some changes and uploaded a new software on my device. I made a screenshot from this message and exactly after this the device is gone forever and when i have a closer look in the logs i see when my MCH was the last time recognized. And it was BEFORE the update.

Cheap or not cheap, but how the hell can such systems exist in 2022, where you NEED internet connection to access and you are 100% in the hand of the company when it comes to up updates. I have absolutely no choice to decline the update and i need to take the consequences when something happens while updating or upgrading a new firmware.

I surely had to take a much closer look when i bought this device to sort this things out.

and yes… i have a synology DS1515+ running for my business data. this device runs for years now and yes, it was much much more expensive.

but overall you cant say it is apples fault when the device is not running anymore. take a look how long WD needs to get their WD Discovery working on macOS Big Sur. I was totally shocked when they released a macOS Ventura version right after ventura was released.

for me WD MCH is one of the absolute shittiest product on the whole market and i am sure you know how many problems this device makes (no matter if its on windows, mac or whatever). so as a company i have to take care and sort things out or i need to get this product out of the products catalog.

that is what i think about and i can tell you, that lots of HDDs went through my hands when i was working as an IT administrator.

It is unacceptable when a supporter tells me that i have to fill out a ticket with lots of details and i should fill this out as best as possible, force me to upload the debug-logs to wetransfer, because supporter can take a closer look very quick and then nothing happens. what drives me nuts is the fact that no one downloaded the logs and the link expires soon.

it is only bla bla yadda yadda

The new fw 8.12.0-178 no longer required internet online to access the MCHome, but that is no consolation if you say the fw update broke the MCH which is certainly possible but more likely to occur with an old MCH that is out of warranty and with MCH that is packed with user data > 50% full. There are instruction in the forum to recover the data and/or replace the hard disk or even replace the MCH OS but that is beyond the technical ability of most home users.

I would call myself an advance user, so i tried many things posted in the forum. right now i got the HDD in an 3.5" external enclosure and i am trying to get the 6TB mounted under ubuntu.

but here it comes.

Until now i had not a single chance to get the HDD mounted under ubuntu. Superblock os unreadable.

trying to repair the block right now but if you ask me: it doesnt seem very good.
I did something like that some times before and i always had some kind of luck to recover some data. not everything, but most of the time what i was looking for.

this thing here gives me some questions marks.

and here we are again: why doesnt WD release a tool to encrypt the files on the hdd, to make this much more easier for everyone then spending hundreds and thousands of dollars or euros to recover their data.

and yes… i am out of the warranty and my volume is 6 TB and around 81% FREE SPACE (if i remember correct) Didnt used the drive that much. just with the iOS my cloud app a daily backup of my photos and videos. but the sad part is, that i used it as a temp backup medium when i got my apple mac studio and was copying the files from my iMac over to the MCH to install my apple mac studio and copy the files back. just only a couple of hours and then i got hit :slight_smile:

the lost data from the iMac are not fundamentally important, but nice to have it back. i will continue to try my luck but overall it is done for me. and it is crystal clear for me to never ever buy a WD product again. sooner or later the companys with good support and quality hardware will last the longest.

shameless WD

Use Rescuezilla, it is free. Use sata instead of USB if possible, try image clone the original hdd and see if that can be done, avoid directly editing the original hdd. The target HDD has to be identical or larger than the original and since the 6TB WD hdd in the MCHome is likely to be SMR, that means a CMR 6TB won’t work because a SMR is nearly always a few sectors larger than the CMR counterpart. The image clone will take a few hours and if it is successful, there is a chance it could boot in the MCH. The MCH boot sectors should not be edited but the data containing partition 24 could be shrank or expanded at a later time to fit an alternate target hdd.

Thanks man, but exactly this i was trying to do. The Problem is, that i cant get the sdb24 mounted (the 6TB) and i get superblock cant be read. This makes it very very hard to get my hands on the data. And so both 2 methods wont work i guess. :frowning:

Avoid using USB, use SATA instead in any old Linux capable PC with several SATAs that can be had for $50 to $75. Also try fsck from this:

Many thanks for all your effort. Really appreciate it. Today i got a call from WD direct telling me they will try to help me and the very smart and friendly Kristen told me she will forward all my explanation etc. to the WD Tech Team in the USA.

I really wonder if there is any possibility to get some data back. I’ll keep you updated as soon as there are any news.

@NoPlex
I will try that. My Mother is still using a PC and i can connect the HDD via SATA there. What keeps me positive is the fact, that i dont hear the well know CLICK CLICK CLICK from the HDD. That doesnt mean anything, but it keeps me motivated to try my luck. :joy:

As I am the person originally posting this thread, I would have expected WD Support to come back and post (what should be) a fairly straightforward answer to my question … that is, an explanation of why my WDH gets reported as being Offline. What causes it ? I see quite a few replies from people who I think are also WD users (thanks to them, but nothing from WD support, as far as I can see). So, if you are WD Support, please identify yourself as such and give an answer.

To recap, I am using Win10 and have a 4TB single drive WDH. It has worked OK up to now, but in recent weeks it has frequently dropped its connection and reported as “Offline”. When this has previously occured, I have rebooted the WDH and signed-in once again. Although annoying, this has fixed the problem.

The problem has now progressed in that when it now goes offline, nothing seems to fix it. So, it seems to me that the problem relates to the remote WD connection being unable to communicate with its own WD product. Is this correct and if so, what is the answer ?

Despite the fact that I posted my original query some time ago, I’ve not yet received any response from WD Support with regard to my “Offline” problem. In the meantime, I have a WD-Home that I cannot use.

Does anyone from WD Support monitor this Community Forum ?

I would not have thought my question would be that complicated for WD Support to answer, considering that the software is developed by WD. In case there is any confusion, I’ll try to simplify it … What condition causes WD Discovery to report a WDH as being “Offline” ?