WD MyCloud Desktop Apps Blank Screen

I have seen this mentioned a couple of times but haven’t really seen a resolution.

I have the WD Mycloud desktop on a Windows 7 machine and its working fine. However on an 8.1 machine it just comes up with a blank screen. 

I have reinstalled the app a couple of times and updated both Flash and Java on the 8.1 machine but it is still not working. I can access my drive from the Wd2go website but I’d much prefer to do it via the desktop app.

Thanks for any advice.

I don’t have Windows 8.1 but here is something you can try. Right click on the shortcut icon and select Properties>Compatibility and see if you can set it for Windows 7 or an earlier version. Be sure to click on Apply and OK. After this try it again and see what happens.

 

Maybe this will work until WD or someone finds an answer.

 

Posted by,
cat0w (USA)

 

Thanks for the suggestion. though sadly it didn’t work.

ANSWER:

Here’s what worked for me.

Manually add WDMyCloud to your firewall’s list of approved apps. We were using Norton 360 and getting the blank screen. Solved it immeidately.

I have the same problem.I have the WD Mycloud desktop latest version on a Windows 7.What i have discovered so far…

I installed the WD Mycloud on a new machine…

The first time i started the app i get a screen with no text only buttons and at the top right corner the version is showing null…

Then i connect the machine to the internet and in two seconds the splash screen of WD Mycloud desktop app is showing text and buttons normally…

Uninstall - reinstall (with no internet connection) the app is playing normal…

What i am thinking is that some sort os signing is done in local certificate store.

I am gone install the app in a freah install win 7 and run wireshark just to see the traffic…

It was not a certificate problem…

The problem is that flash player cannot write to folder %appdata%\Adobe\Flash Player\AssetCache either because of file security settings or the setting in flash player --> “Local Storage” is set to none, which that was in my case.

  adobe.JPG

When i set to unlimited WD mycloud desktop app run without the annoying blank screen and the annoying null at the top right corner…  

Thanks for the suggestions on Firewall and Flash settings, but neither worked for me.  I added inbouund and outbound rules to my MS Firewall settings, and my flash settings didn’t have the local storage setting restriction shown.  My desktop still looks as follows: