WD MyCloud corrupt firmware reset issues

I have a single bay My Cloud and a little while ago it became inaccessible. I have tried both the resets and even tried to connect via Telnet and have replaced files like uImage and uRamdisk with recovery ones. Now I am able to reach the safe mode window but the firmware doesnt install. The process just keeps on spinning. Any help would be greatly appreciated.

Screenshot from 2020-03-29 01-37-01

1 Like


You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/25172

What generation MyCloud do you have, 1st or 2nd? All the information on this forum appears to be for the 2nd gen only.

Already tried the safe mode upload. But there is a process and it keeps on spinning. The product is out of warranty sir.

Where to see for it sir?

Were you able to fix your device? What was the issue you were facing?

I am experiencing a solid yellow light on my device and it is not connecting to the network in any way.

Multiple people seem to be reporting issues. Was there any update pushed from WD recently?

The issue with my device was different and it couldn’t be solved. Have you tied to reset the device?

1 Like

Tried both soft and hard reset.

Neither of them working.