WD My Passport Wireless Pro 4TB all leds flashing blue


#1

Hello there,

I’ve got a problem with my device. This device has only one week. At first it was working fine, but suddenly it started to all leds flashing blue.
I can’t mount it via usb, because the drive is not recognized either on mac or windows. On mac, this drive can’t be seen in Finder and disk utilities. I’ve tried to run disk utility via cmd+R on startup, the drive was recognized but couldn’t be mounted even to format.

I’ve also tried to run a new firmware but the procedure didn’t start, I suppose because of the drive problem.

In the manual it is said that when all leds blink three times, and pause, than another three times blink the drive is in the recovery mode. I can push the drive in that mode, but the manual says nothing what to do next without the dashboard access.

Any Ideas?

In the end I read all topics according to the blinking leds, but by now nothing worked for me.


#2

Hi,

Have you tried resetting the unit? If not, please try that. The My Passport Wireless Pro can be reset by physically using the Power and WPS buttons, or restored through the Dashboard. Please see below for more information on each method.


#3

Hi,

I can’t make a reset procedure. When I power on the drive the hdd led is state and wifi led is flashing.

When I press power and wps button nothing happens. The unit doesn’t reboot.

When I still hold pressing it tries to startup and in the end all leds are flashing.


#4

You should try the SD card update of the firmware. Just scroll towards the bottom of

If this doesn’t work, I recommend dealing with the WD support team as a week seems way too short.

Details are:
How to Install the Product Update: SD Card

  1. Download the firmware to your desktop.
  2. Unzip the file and you will find the actual firmware in this format: MyPassportWireless_x.bin.
  3. Format an SD card FAT-32.
  4. Create a folder on the SD card named “update”.
  5. Copy the MyPassportWireless_x.bin file into the “update” folder.
  6. Turn OFF the My Passport Wireless.
  7. Insert the SD Card.
  8. Turn ON the My Passport Wireless.
  9. The My Passport Wireless will boot up, then will start flashing a White LED while the update is happening.
  10. Once the update is complete the LED will return to the normal ON state.

#5

Hello, i have the 1TB version. I tried the firmware fix you sugested. It did not work, all the lights started to flash again.
Is there something else i can try.
I have photos on this drive as a back up. I need to access them.
Pleas help.


#6

Hello,

Did you find solution for fix your issues? I have the same trouble.
The Manual reset & the SD reset isn’t working :frowning:

I need to hv back the data present on that drive.
Tks


#7

Battery must be almost fully charged so connect unit to included charger for a few hours.

Reset must be performed when unit is ON. Hold both buttons in for 10-15 seconds or until blinking pattern changes, then release. Then be patient until it processes the reset which can take over five minutes.

If this does’t repair things, you have a problem that requires contacting WD Support. Try reset as I’ve described at least twice if first try does not work.