WD My Cloud windows app finds device but unable to connect

I have a WD My Cloud 3TB device and use it with 2 windows computers. I recently had to reinstall windows on one of them (windows 10 home 1803 build 17134.472). When I attempt to set up the desktop app again I am unable to login. The app is able to find the device on the network and shows the ip address correctly but when I click on connect, it shows red text unable to connect for a split second, then goes to a login box where I cannot type in anything to the username. Only the password box and login button are enabled. I also tried the connect via wdmycloud.com online login and same result, I see a device, and when I click through, I’m unable to connect. This is working perfectly from the other windows computer. My WD My Cloud windows app verion is 1.0.7.17

Well known and complained about issue recently. The WD My Cloud Desktop program is End of Life (EoL) March of 2016 and apparently no longer is supported by WD. Recent firmware updates (mostly v2.x firmware My Cloud’s) are the one’s experiencing this issue. WD Support has a Knowledge Base article on this issue:

For remote access one is basically limited to using the MyCloud.com web portal or the insecure FTP method. Or use a mobile device and the WD mobile app.

For local network My Cloud access one does not need to use any WD software. One can access their My Cloud using Windows File Explorer or Mac Finder.

@rvfmt Why don’t you just use, File Explorer>Network? See example image below. Click on, tap or activate image to enlarge it. The Desktop app works with my 1st generation Cloud but not the 2nd generation.