WD DX4000 Stuck in “LOADING OS. PLEASE WAIT…”

I have a WD DX4000 Sentinel using four HDDs (3×2TB + 1×3TB); about three weeks ago, the 3TB HDD failed.

I got a replacement yesterday. Before I inserted the new HDD, the LCD already read “LOADING OS. PLEASE WAIT…”

Since then, nothing has happened, the storage hasn’t been rebuilt, and the message on the LCD hasn’t changed.

I can’t connect to the server via my browser or the dashboard, although I’m able to access the folders via Windows Explorer from my PC, and I can also log onto the server via Remote Desktop Connection.

I have also noticed that the date is stuck on the 10th of September, even if I change it, it keeps changing back every time I log onto the server.

I’d be great if someone could help me. I’m going nuts…

The very first thing you need to do is backup/copy all your data to another place.

After that from remote desktop I think I would open services.msc and make sure all the services set to automatic are started.  Not all will start but you can kinda tell which ones should be started like WD lcd service and windows server client stuff

Get your data safe first and then we will see.

The date thing happens sometimes.  It seems to get stuck at the last time the box was shut down so you have to remember to check the date eveerytime you reboot.  No one has figured out why this happens sometimes.

1 Like

Thanks, Gramps!

Right now I’m using Windows Server Backup to perform a backup of the most important folders I have on the NAS, as I don’t have the resources to make a bare-metal or full-server backup at the moment. I hope that’s enough…

Once the backup is completed, I’ll (try to) start all the services set to automatic that haven’t been started yet, as per your instructions. Meanwhile, I have taken a screenshot (please see below) of all those services, in case you wouldn’t mind taking a look at it. I’m not an IT savvy, so probably there’s something in there I don’t notice.

Any further comments will be highly appreciated :wink:

Well we know why is says loading OS, The WD LCD service is not running along with everything else.  Almost like it is started in safe mode.

Alright, you know when your backup is done you can hook it to a win 7 or better, open diskmgmt.msc, click action, attach vhd, and open your backup to copy files out of the backup if you need them.

I guess maybe try to start the wd lcd service and the windows server.  They may say dependencies, find them and start them.  Just curious if you can get into the dashboard/monitor and see if it says the raid is okay/rebuilding or what.

Then perhaps just do a restart from the remote desktop and see if it fires back up properly.

1 Like

The box is still working on the backup (52% done), I believe it’ll be done within 20 hours.

I tried to start the WD LCD Provider Service, but I got an error saying its dependencies weren’t started. Then I tried to start some of those services, but got the same error.

After that, I looked for a service—within the WD LCD Provider Service dependencies—that wouldn’t depend on other services.

That’s how I found the Net.Tcp Port Sharing Service. I tried to start it, and the error I got was different: (Error 1053: The service did not respond to the start or control request in a timely fashion). You can see a screenshot of the error below.

I’ll keep trying to start more services once the backup has been completed.

Regarding the RAID, I can’t get into the Dashboard, and I don’t know how to check that via Remote Desktop Connection. Could you please let me know how can I do that?

WDLCDProvider.png

I was trying to get the LCD service or the dashboard running to check the raid.  I don’t know of any other way.

Yea, once you have verified you have a good copy of your data you can finger around with the services and or reboot

You might also try ctrl-alt-end to start task manager and check disc activity.  I am guessing it would be high if it was rebuilding?  If so just wait till it drops down to reboot

1 Like

The backup is now complete, took much less than expected :smileyvery-happy:

I’m going to play now with the services to see if I get either the LCD or the Dashboard running.

I have checked the disk activity (see below), and it seems the RAID is not being rebuilt.

Also, I took a look at the disk management window, and it looks as if the last HDD I inserted is on a separate disk…

If you have a copy of your data, I believe I would shut down the box and remove the new drive.  Turn it back on and see if everything starts ok.  While you have the drive out make sure that the numbers match exactly as the old drive.  Model # dash Firmware

If all is started and the numbers match, slide the drive in.

I think is was not assembled by the Borg because none of the services were running to do it.

1 Like

I have shut down the box, and removed the new drive.

After turn it back on, the LCD still reads “LOADING OS. PLEASE WAIT…”

The new drive is fully compatible—WD sent me a replacement for it after double-checking the serial numbers of both my machine and the old drive.

Meanwhile, I have installed two optional updates (now the machine is up to date), and reboot it several times after playing around with services without sucess.

Running out of hope and ideas… :cry:

all of your automatic services are like in the pic you posted earlier, not started ?

click start, type msconfig and press enter just like you would on a win 7 box.

Is it set to safe mode, do not start stuff?

1 Like

Yes, all of them are still the same.

Somehow, I’ve got the feeling the main problem is with the Net.Tcp Port Sharing Service as it is the only service that is not dependent on any other service and thus the error shown is different—Error 1053: The service did not respond to the start or control request in a timely fashion.

I have checked online for a way to start this service, but nothing has worked so far…

This is what I see… Is there anything I have to change?

msconfig1.png

msconfig2.png

msconfig3.png

LOL, that all looks fine, but you don’t have to post a pic of it, you can just tell me, on the services tab, you know the one we are trying to figure out… Are they all checked?

Hahaha… Yeah, I know, I just feel safer if you check the pics.

All the services are checked (the “Enable all” button is greyed out).

I am not complaining about the pics, I was just making fun of you for posting all those and leaving out Services.

I dunno.  I have been doing some searching and there may be some stuff to try.  But since this box is headless we might end up not being able to see it anymore.

One thing we can do pretty quick is open the event viewer, application logs, then try to start the tcp sharing…fails. then hit refresh in the event log and see if we get any beter info than timed out.

If you have a usb nic laying around we could configure it while we have access to the box and finger around.  And all is not lost, you can always just do a system recovery keeping data and start over.  You will have to re-add users and computers and check the shares.  rerun the wizard to setup the website to connect from afar. Are you doing client backups?

I really need to step out for a couple of hours.  Let me know what direction you want to take

1 Like

Ah, okay, I wasn’t sure which tab you wanted to check :smiley:

I did the Event Viewer thing, you can see the result below. Just let me know if you need to see anything else. Maybe I took again a screenshot of something you didn’t need… :confounded:

I’m not sure what a USB NIC is… so I guess I don’t have one, hehe

System recovery keeping the data sounds like a viable option, I’m doing client backups on three computers, but wouldn’t mind losing the backups and going through the setup once more.

It’s rather late here, will check your messages and keep you posted tomorrow.

Thanks a lot for your support so far!!!

Looks like it is almost tomorrow in your event log :slight_smile:

Need to look at the dot net errors.  Have you recently installed anything on the server?

Something like this, many people make them Cisco etc 

Later

1 Like

The drive failed on August 28, then this problem started while I was on holidays, so I’m not sure on which exact date, but am guessing it was on September 10, which is the date the box comes back to every time I reboot it.

I haven’t installed anything on the server during that period, but I noticed a big bunch of updates were installed on that date, so I have started uninstalling every update back to September 10. If that doesn’t solve the issue, I’ll do the Event Viewer check again and send you a screenshot of the .NET errors.

Will keep you posted! Fingers crossed!

Some of the searches mentioned  dot net 3.5.  You might consider ./repair/reinstall that

1 Like