WD DX4000 Stuck in “LOADING OS. PLEASE WAIT…”

Okay, finally fixed! Here’s what I did:

I uninstalled all of the updates back to September 10, but that didn’t solve the issue.

Then I considered your suggestion of fixing .NET Framework. I used this .NET Framework Setup Verification Tool to check if any version of .NET Framework on the box had problems, and… bingo! .NET Framework 4.5.2 returned a failure.

After identifying the faulty version, I tried to repair it via the Programs and Features windows, but that didn’t work. Then I used this Microsoft .NET Framework Repair Tool, which didn’t fix the issue either.

Finally, I decided to uninstall the software, and then install this Microsoft .NET Framework 4.5.2. That did the trick, I rebooted the box, and the message on the LCD changed after a while to “STORAGE DEGRADED,” so I slided in the new drive, and the storage is now being repaired… 58% so far!

As a last resource, I had found this .NET Framework Cleanup Tool, which luckily I didn’t have to use :smiley:

Thanks again, Gramps, for pointing me in the right direction!

WONDERFUL  :slight_smile:

You may still need to keep an eye on the date when you reboot.

Thanks again for the detailed reports of your journey.  Hopefully no one else will need it, but now it is shared to the world for all to benefit. LOL

For the DX4000 bug related to the clock day not updated when it is shut down or rebooted you can refer to this turn-around I found as the WD support was not able to provide an answer (they say it is a W2008 server bug but I am more keen to thinking this is an hardware bug)

http://community.wd.com/t5/Sentinel-Products/WD-DX4000-internal-clock-loose-days-when-switched-off-but/td-p/880153

regards

Davide

Davide,

I fixed the date-related bug after solving the issue with the .NET Framework. All I had to do was to manually update the time, and then syncronize it with an Internet time server as per the screenshot below. Now it works just fine.

reboot the box and then check the date

Yes, the date is fine even after rebooting the box.

Maybe in order to fix this bug, .NET Framework must be reinstalled?

Put a note on your calendar  to reboot in 2 weeks and let us know please.

Maybe I’ll run the dot net checker?

Sure, I’ll update you in a couple of weeks.

Hey Gramps,

It’s been a couple of weeks now—I have rebooted the box several times during this period, and the date and time are working just fine, I haven’t had to update them a single time.

Maybe this bug has something to do with the .NET…

Good deal.  Is that a light at the end of the tunnel I see?

Thanks for the follow up.

I’m having this EXACT same issue. Just warpping up the uninstall and reinstall of .net 4.5.2 to see if by miracle this solution works for me. WDC is sending me a replacement drive because the 3TB RED I had on hand was reporting as cont compatible. They directed me to a patch, https://support.wdc.com/downloads.aspx?p=273&lang=en dated 3/7/2016 and had me apply it. When I restarted, got this ■■■■ hang up on LOADING OS, PLEASE WAIT.

Unfortunately, their patch doesn’t come with an undo! Hoping by all hope this makes it right and I can continue to install the new drive and rebuild the RAID…

loading os does not mean it might not be on, only that the wd lcd service is not started. Can you remote to the server with MSTSC?

WOW!!! FIXED!!!. Thumbs up on this solution for sure. and yes Gramps, could remote in and see most all of the WDC services would not start and quite a few others as well. Found this thread on a google search and bam, done. fixed. The rebuild in on its way, and its doing it with a WD RED 3TB that before the patch was being rejected as not compatible. All good! and very thankful I came across your posting on this board.

That’s great! Really glad someone could benefit from that solution. It was a hell fixing the box :sweat_smile: